Mensaje de error en varias pantallas en Microsoft Dynamics SL: "Mensaje de sistema 10232 - Error de aserción"


Síntomas


Recibe un mensaje de error similar al siguiente en varias pantallas en Microsoft Dynamics SL 7.0: o{17944DF6-4CA9-4C98-98D7-03952B59E82Ct{17944DF6-4CA9-4C98-98D7-03952B59E82C. {} 17944DF6-4CA9 - 4C 98-98D 7-03952B59E82C:
¡Mensaje de sistema 10232 - Error de aserción! Archivo: % línea: % expresión: %s haga clic en Aceptar para detener el programa e informe del error a Microsoft Support, anotando la expresión error, nombre de archivo y número de línea.

Causa


Este mensaje de error puede producirse por varias razones.
  • Se produce cuando una personalización de la pantalla está dañado o en conflicto con otra personalización. Vea la solución 1.
  • Se produce durante el proceso de importación de transacción porque la macro de archivo o el control de datos no coincide correctamente con la pantalla que se va a importar a. Vea la solución 2.
  • Se produce cuando la versión del archivo swimapi.dll que está instalado en la unidad local difiere de la versión que está instalada en el servidor de archivos de Microsoft Dynamics SL. Vea la solución 3.
  • Se produce al hacer clic en Pegar en la pantalla de la plantilla (98.230.00) . Vea la solución 4
  • Se produce cuando se intenta abrir una pantalla que contiene una cuadrícula. Vea la solución 5.
  • Se produce cuando se intenta seleccionar una impresora para una plantilla de informe. Vea la solución 6.

Solución


Resolución 1


Determinar si una personalización de la pantalla está dañado o en conflicto con otra personalización abriendo la pantalla en el modo estándar. Para ello, siga estos pasos:


Si está ejecutando Microsoft Dynamics SL 7.0 y versiones posteriores, siga estos pasos:
  1. En la barra de estado, haga clic en automático.
  2. Haga clic en estándary, a continuación, haga clic en Aceptar..
  3. Abra la pantalla personalizada.
    Nota: Si el mensaje de sistema 10232 no se produce cuando se abre la pantalla en el modo estándar, la personalización es el origen del problema y tenga que volver a crearse.

Si está ejecutando Microsoft Dynamics SL 6.5, siga estos pasos:
  1. En el menú de Personalizar , haga clic en Seleccionar nivel.
  2. Haga clic en estándary, a continuación, haga clic en Aceptar.
  3. Abra la pantalla personalizada.
    Nota: Si el mensaje de sistema 10232 no se produce cuando se abre la pantalla en el modo estándar, la personalización es el origen del problema y tenga que volver a crearse.

Resolución 2


Crear una macro de archivo y control de datos que coincide con la pantalla que está importando los datos a.
Nota Consulte el archivo de Ayuda de la importación en la transacción o el manual de importación de transacción para obtener más información acerca de cómo crear archivos de datos y controlar las macros que tengan el formato correcto.

Resolución 3


Compruebe que la compilación de kernel de Microsoft Dynamics SL que está instalada en la unidad local es el mismo que en el servidor de archivos. Para ello, siga estos pasos:
  1. Inicie Microsoft Dynamics SL y, a continuación, haga clic en Ayuda.
  2. En el menú Ayuda , haga clic en Acerca de Microsoft Dynamics SLy anote el número de versión.
  3. Repita los pasos 1 y 2 en el servidor de archivos de Microsoft Dynamics SL.

Nota: Si los números de versión son diferentes, instale la actualización de Microsoft Dynamics SL adecuada en la unidad local.
Para obtener más información acerca del núcleo de Microsoft Dynamics SL versiones, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

Lista de 850447 de las versiones, versiones, compilaciones del núcleo de Microsoft Dynamics SL


Resolución 4


Eliminar y, a continuación, volver a crear la plantilla. Para ello, siga estos pasos:
  1. Abra la pantalla adecuada.
  2. Haga clic en acciones, haga clic en plantillay, a continuación, escriba el identificador en el cuadro Identificador de plantilla .
  3. Haga clic en Eliminary, a continuación, haga clic en cuando se le pida con el siguiente mensaje de confirmación:
    Mensaje de sistema 12: ¿está seguro de que desea eliminar?
  4. Volver a crear la plantilla con los valores adecuados.

Resolución 5


Registrar manualmente el MSIGRID. Archivo OCX. Para ello, siga estos pasos:
  1. Busque la MSIGRID. Archivo OCX en las siguientes rutas:
    Sistema operativo de 32 bits: < unidadDelSistema >: \Windows\System32
    Sistema operativo de 64 bits: < unidadDelSistema >: \Windows\SysWOW64

    Nota < unidadDelSistema > representa la unidad donde está instalado Microsoft Windows.
  2. Haga clic en el MSIGRID. OCX de archivo y, a continuación, haga clic en Abrir con .
  3. En el cuadro de diálogo de Windows , haga clic en Seleccionar el programa de una lista y, a continuación, haga clic en Aceptar .
  4. En el cuadro de diálogo Abrir con , haga clic en Examinar .
  5. Busque y abra la carpeta siguiente: sistema operativo de 32 bits: < unidadDelSistema >: \Windows\System32 64 bits sistema operativo: < unidadDelSistema >: \Windows\SysWOW64
  6. Haga doble clic en el archivo Regsvr32.exe y, a continuación, haga clic en Aceptar .
  7. Busque y abra la carpeta siguiente: sistema operativo de 32 bits: < unidadDelSistema >: \Windows\System32 64 bits sistema operativo: < unidadDelSistema >: \Windows\SysWOW64
  8. Haga clic en Aceptar cuando reciba el mensaje siguiente:
    RegSvr32 - DllRegisterServer en SystemDrive: \windows\system32\msigrid.ocx se realizó correctamente.

Resolución 6


Eliminar la plantilla y, a continuación, seleccione la impresora deseada en la pantalla de Opciones de la impresora (98.220.00) antes de volver a crear la plantilla.
Nota: Cuando se crea una plantilla, información del controlador de la impresora de destino para la impresora especificada en la pantalla de Opciones de la impresora (98.220.00) está codificado en la plantilla.