Mensaje de error al imprimir o vista preliminar un informe en Microsoft Dynamics SL: "Mensaje de sistema 7011"

Se aplica a: Dynamics SL 2011

Síntomas


Considere el siguiente escenario. Imprimir o vista preliminar de informes en cualquiera de los siguientes módulos:
  • Compras en Microsoft Dynamics SL
  • Administración de pedidos en Microsoft Dynamics SL
  • Inventario en Microsoft Dynamics SL
  • Tiempo y gastos para proyectos de Microsoft Dynamics SL


Al realizar esta acción, recibirá uno de la serie de mensajes de error siguiente:

Serie 1:
Error de sistema mensaje 7011 - ROI Get RIPARAM para CRPERC. Error =.
Después de recibir este mensaje, recibirá el siguiente mensaje de error:
Error de sistema mensaje 7011 - ROI Get RIPARAM para CRPEMSGCNT. Error =.
Vea las causas 1, 2, 3 y 4.

Serie 2:
La aplicación CRPEHLPR MFC ha detectado un problema y debe cerrarse. Sentimos las molestias.
Seguido de:
Error de sistema mensaje 7011 - ROI Get RIPARAM para CRPERC. Error =.
Seguido de:
Mensaje de sistema 7011 - Error de ROI Get RIPARAM para CRPEMSGCNT. Error =.
Ver la causa 5.


Serie 3:
¡Error en tiempo de ejecución de Microsoft Visual C++ Runtime Library! Programa: La aplicación ha solicitado el tiempo de ejecución para terminar de una manera inusual. Póngase en contacto con el equipo de soporte de la aplicación para obtener más información.
Seguido de:
Error de sistema mensaje 7011 - ROI Get RIPARAM para CRPERC. Error =.
Seguido de:
Mensaje de sistema 7011 - Error de ROI Get RIPARAM para CRPEMSGCNT. Error =.
Consulte la causa 6.


Causa


Este problema se produce por una de las razones siguientes.

Causa 1

Los bloques de la característica Prevención de ejecución de datos (DEP) algunos archivos cuando Microsoft Dynamics SL o Microsoft Business Solutions - son archivos de programa Solomon en un equipo que está ejecutando uno de los siguientes sistemas operativos:
  • Windows Server 2008 o Windows Server 2008 R2
  • Windows 7
  • Windows Server 2003 con Service Pack 1 (SP1)
  • Windows Vista con Service Pack 1 (SP1)
  • Windows XP Professional con Service Pack 2 (SP2)

Causa 2:

Hay registros dañados en la base de datos de la aplicación Microsoft Dynamics SL o en Microsoft Business Solutions - base de datos de aplicación de Solomon.

Causa 3:

El archivo Capicom.dll se registró incorrectamente.


Causa 4:

Microsoft Dynamics SL se usa Crystal Reports 10. Esta versión de Crystal Reports es una actualización desde una versión anterior. Por lo tanto, la configuración del programa ya no es compatibles.

Causa 5:

Este problema se produce porque hay una fórmula de supresión de un subinforme que está asociado con el informe que está intentando imprimir.

Causa 6:

La función de aplicación MSDSL o el usuario E7F575915A2E4897A517779C0DD7CE SQL no está sincronizado correctamente con las bases de datos de Microsoft Dynamics SL. O bien, la función y el usuario no se sincronizan correctamente. Esta situación puede producirse si se cumplen las condiciones siguientes:
  • Seleccione el escenario de actualización Synchronize All Ownership y seguridad en la pantalla de Mantenimiento de bases de datos (98.290.00) y la pantalla de Mantenimiento de bases de datos (98.290.00) es de una versión anterior de Microsoft Dynamics SL.
  • Ejecutar el escenario de actualización en cualquier base de datos que existe en la misma instancia de SQL Server como base de datos de Microsoft Dynamics SL 7.0.

Solución


Para resolver este problema, utilice la resolución adecuada.

Resolución 1


Configure la característica Prevención de ejecución de datos para habilitar la ejecución del archivo Crpehlpr.exe y ejecute el archivo Roi.exe. Para ello, siga estos pasos:
  1. Haga clic en Mi PC y, a continuación, en Propiedades.

  2. En Windows Server 2003 o Windows XP, haga clic en la ficha Opciones avanzadas . En Windows Vista, Windows 7 o Windows Server 2008, haga clic en el vínculo Configuración avanzada del sistema .
  3. En la sección rendimiento , haga clic en configuración.

  4. En la ficha Prevención de ejecución de datos , haga clic en Agregar.

    Nota: La opción predeterminada es Activar DEP para todos los programas y servicios excepto los que seleccione.
  5. Busque el directorio de instalación del programa Microsoft Dynamics SL o Microsoft Business Solutions - el directorio de instalación del programa de Solomon. Si tiene una unidad adicional que es una unidad asignada a este directorio de instalación, debe agregar el archivo a través de ambas rutas.

    Por ejemplo, instale Microsoft Dynamics SL 7.0 a la carpeta siguiente:
    C:\Program Files\Microsoft Dynamics\SL\Applications
    En el mismo equipo, asigna la unidad S a la carpeta siguiente:
    C:\Program Files\Microsoft Dynamics\SL
    Si sigue este paso, debe agregar los archivos mediante el uso de las siguientes rutas:
    • C:\Program Files\Microsoft Dynamics\SL\Applications\
    • S:\Applications\
  6. Busque y, a continuación, haga clic para seleccionar el siguiente archivo:
    Crpehlpr.exe
    .
  7. Haga clic en Abrir, haga clic en Aplicary, a continuación, haga clic en Aceptar.
  8. Repita los pasos 1 a 7 para el archivo Roi.exe.

Resolución 2


Elimine los registros dañados desde la base de datos de la aplicación Microsoft Dynamics SL o desde Microsoft Business Solutions - base de datos de aplicación de Solomon. Para ello, siga estos pasos:

Nota: Antes de seguir las instrucciones de este artículo, asegúrese de que tiene una copia de seguridad completa de la base de datos que pueda restaurar si surge algún problema.
  1. Asegúrese de que todos los usuarios de Microsoft Dynamics SL o todos los de Microsoft Business Solutions - Solomon los usuarios se desconectan.
  2. Inicie el analizador de consultas SQL de Microsoft. O bien, inicie Microsoft SQL Server Management Studio.
  3. Conectarse a la base de datos de aplicación apropiada de Microsoft Dynamics SL o Microsoft Business Solutions - base de datos de aplicación de Solomon.
  4. Ejecute las instrucciones siguientes.
    Delete from Roidetail
    Delete from Rptcompany
    Delete from Rptruntime

Resolución 3


Para resolver este problema, registre manualmente el archivo Capicom.dll. Para ello, siga estos pasos:
  1. Busque el archivo Capicom.dll en el equipo local. De forma predeterminada, este archivo está en la carpeta siguiente:
    SystemDrive:\Windows\System32
  2. Compruebe que la versión del archivo Capicom.dll es 2.1.0.1 o una versión posterior. Para ello, siga estos pasos:
    1. Haga clic en el archivo Capicom.dll y, a continuación, haga clic en Propiedades.
    2. En la ficha versión , compruebe que la versión del archivo es 2.1.0.1 o una versión posterior.
    3. Haga clic en Aceptar.

  3. Haga clic en el archivo Capicom.dll y, a continuación, haga clic en Abrir con.
  4. En el cuadro de diálogo de Windows , haga clic en Seleccionar el programa de una listay, a continuación, haga clic en Aceptar.
  5. En el cuadro de diálogo Abrir con , haga clic en Examinar.
  6. Busque y, a continuación, abra la carpeta siguiente:
    UnidadDelSistema: \Windows\System32
  7. Haga doble clic en el archivo Regsvr32.exe y, a continuación, haga clic en Aceptar.
  8. Haga clic en Aceptar cuando reciba el mensaje siguiente:
    RegSvr32 - DllRegisterServer en SystemDrive:\windows\system32\capicom.dll tuvo éxito.
Nota: Si se produce el mensaje de error "Mensaje de sistema 9827" registrar el archivo Capicom.dll en cualquier computerbefore de estación de trabajo, debe volver a ejecutar el escenario de actualización Synchronize All Ownership y seguridad en la pantalla de Mantenimiento de bases de datos (98.290.00) .

Resolución 4:


Para resolver este problema, seleccione la casilla de verificación No Printer en el archivo de informe en Business Objects Crystal Reports. Para ello, siga estos pasos:
  1. Abra Crystal Reports y, a continuación, haga clic en para abrir el archivo de informe.
  2. Haga clic en archivo.
  3. Haga clic en configuración de la impresora.
  4. Haga clic para activar la casilla de verificación No Printer y, a continuación, haga clic en Aceptar.
  5. Haga clic en Guardar.

Resolución 5:


Cambie el informe en Business Objects Crystal Reports para quitar la supresión en el subinforme.
  1. En Business Objects Crystal Reports, abra el archivo de informe que está produciendo el error.
  2. Si hay un subinforme dentro de cualquier sección del informe, haga clic en el subinforme. Nota: Si no hay ningún subinforme, esta solución no funcionará.
  3. Haga clic en Format Sub-Report. El botón Suprimir la fórmula que aparece debe contener texto en color rojo. La presencia de este texto en rojo indica que hay una fórmula de supresión. Si la fórmula utiliza variables del informe primario, las variables deben quitarse. Notas
    • Si no recibe la indicación de que exista una fórmula de supresión, esta solución no funcionará.
    • Si la fórmula de supresión utiliza una combinación de variables del subinforme y variables del informe primario, se deben separar estas variables para que se puedan quitar las variables del informe primario.
    • Si la sección que contiene el subinforme también contiene otras variables mostradas, se deben separar las variables.
    • Si la sección que contiene el subinforme ya tiene una fórmula de supresión, debe decidir si desea combinar las fórmulas y cómo hacerlo.
  4. Haga clic en Suprimir la fórmula para abrir el cuadro de diálogo Editor de formato y, a continuación, haga clic en Seleccionar todo en el menú Edición .

    Notas: Si la fórmula de supresión utiliza sólo las variables desde el subinforme, esta solución no funcionará.
  5. En el menú Edición , haga clic en Copiar para copiar la fórmula.
  6. Elimine la fórmula.
  7. Haga clic en Aceptar para cerrar el cuadro de diálogo Editor de formato .
  8. (Ratón) en la sección izquierda de la pantalla donde aparece el subinforme y, a continuación, haga clic en Section Expert.
  9. En el cuadro de diálogo Section Expert , haga clic en Suprimir la fórmulay, a continuación, haga clic en Pegar en el menú Edición para pegar la fórmula.
  10. Haga clic en Guardar y cerrary, a continuación, haga clic en Aceptar.
  11. En el menú archivo , haga clic en Guardar.

Resolución 6:

Haga clic aquí para ver u ocultar la información detallada

Sincronizar el usuario. Para ello, siga estos pasos:
  1. Utilice SQL Server Management Studio para ejecutar la instrucción siguiente contra la base de datos de sistema de Microsoft Dynamics SL:
    DELETE FROM RPTExtra 
  2. Seleccione el escenario de actualización Synchronize All Ownership y seguridad en la pantalla de Mantenimiento de bases de datos (98.290.00) y, a continuación, haga clic en Comenzar a procesar.