Mensaje de error cuando examina el registro de aplicación en el equipo que está ejecutando servicios de AOS de Microsoft Dynamics AX 4.0: "excepción de RPC 1726 ocurridos en sesión 10"

Se aplica a: Microsoft Dynamics AX 4.0Axapta Object Server

Síntomas


Cuando revise el registro de aplicación en un equipo que ejecuta Servicios de Microsoft Dynamics AX 4.0 Application Object Server (AOS), puede ver mensajes de error similares a los siguientes:
Mensaje de error 1
Tipo de evento: información
Evento Source: Dynamics Server 17
Date:7/4/2007
Tiempo: 12:30: 14 PM
Categoría del suceso: ninguna
Descripción:
Servidor de objetos 01: Error RPC: se produjo una excepción de RPC 1726 en la sesión 10
Mensaje de error 2
Tipo de evento: información
Evento Source: Dynamics Server 01
Categoría del suceso: ninguna
Evento ID:110
Date:7/4/2007
Tiempo: 12:30: 33 A.M.
User:N/A
Computer:ComputerName
Descripción:
Servidor de objetos 01: Ningún ping de 10. Terminar la sesión.
El primer mensaje de error puede asociarse con el segundo mensaje de error. Hasta que el servidor AOS finaliza la sesión 10, cada sesión que devuelve mensajes de error RPC dejará de responder. Si hay demasiadas sesiones dejen de responder y devuelven mensajes de error RPC, puede apagar el servidor AOS.

Causa


Este problema puede producirse porque los usuarios salen de Microsoft Dynamics AX brusco. Por ejemplo, los usuarios fin el proceso de Microsoft Dynamics AX mediante el Administrador de tareas.

RPC 1726 es un mensaje de error de conexión general. Sin embargo, el mensaje de error de RPC 1726 pueden asociarse con el "No ping de 10. Terminar la sesión"mensaje de error. En este caso, el problema es causado normalmente por los usuarios salir de Microsoft Dynamics AX brusco.

Solución


Si experimenta este problema en el cliente de Microsoft Dynamics AX, no salga del cliente presionando CTRL + ALT + SUPR. Recomendamos que utilice la combinación de teclas CTRL+INTER y espere a que el sistema vuelva a ser sensible o póngase en contacto con el Administrador de Microsoft Dynamics AX o a otro usuario que tiene derechos para el formulario usuarios en línea. El administrador o el otro usuario puede hacer clic en Cerrar sesión para cerrar la sesión del cliente.

Más información


Si experimenta este problema en el servidor AOS, es importante determinar qué sesión es la causa y lo que están haciendo los usuarios para que se produzca el problema.

Para ello, ejecute el siguiente script:
select * from sysuserlog where logouttime = 0 and sessionid = <X> 
Nota: Reemplace < X > con la sesión que se indica en el mensaje de error RPC. De los resultados de la consulta, observe las columnas USERID y nombreDeEquipo . Los valores de columna indican quién inicia sesión en y desde dónde.

Normalmente, las excepciones de RPC son causadas por brusco saliendo de la aplicación. Sin embargo, las excepciones también pueden indicar que un proceso empresarial se bloquea o se tarda mucho tiempo.

Referencias


Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:

953375 cómo encontrar un identificador de usuario que está asociado con un identificador de sesión de un "error de RPC: se produjo una excepción de RPC 1726 en la sesión [idsesión]" mensaje de error en el registro de aplicación en el servidor AOS en Microsoft Dynamics AX

953374 recibe un mensaje de advertencia en el registro de aplicación en el servidor AOS en Microsoft Dynamics AX: "SPID [SPID_number] para el Id de sesión [idsesión], todavía está presente en la base de datos. Elimine el SPID de la base de datos"