Mensaje de error al iniciar el cliente de Microsoft Dynamics AX 4.0 Service Pack 1: "el nombre de red especificado ya no está disponible"

Se aplica a: Microsoft Dynamics AX 4.0Axapta Object Server

Síntomas


Al iniciar Microsoft Dynamics AX 4.0 Service Pack 1 (SP1) en un equipo cliente, recibirá el siguiente mensaje de error:
Error en el archivo: \\ \appl\standard\axsys.aodruta de instalación de Microsoft Dynamics AXal leer registro = 0

Error de Windows: =

Código de error: 64 = especificado nombre de red ya no está disponible.

¿Vuelve a intentarlo?
Además, se graba el suceso siguiente en el equipo cliente:notas
  • En este mensaje de error, la palabra "producido" es un error ortográfico de la palabra "ocurrió."

  • El marcador de posición file_name en la descripción del error representa un archivo que se encuentra en la carpeta compartida que contiene los archivos de instalación del programa.

Causa


Este problema puede producirse si se cumple alguna de las condiciones siguientes:
  • Se detiene el servicio de Application Object Server (AOS).
  • Un fallo de alimentación, una falla de switch o un error de hardware ocurrido que causó la conexión para que se detenga repentinamente.
  • Detección de virus o software de copia de seguridad bloquea algunos archivos.
  • La conexión de red se perdió a la carpeta compartida que contiene los archivos de instalación del programa.
  • Se implementaron los cambios de código mientras otros usuarios estaban utilizando Microsoft Dynamics AX.
Nota: Para obtener más información acerca de cómo implementar los cambios de código, consulte la Guía de programadores de Microsoft Dynamics AX. Para ver a esta guía, haga clic en Ayuday, a continuación, haga clic en manual del programador de Microsoft Dynamics AX.

Solución


Para resolver este problema, siga estos pasos:
  1. Detenga el servicio AOS. Para ello, haga clic en Inicio, haga clic en Ejecutar, escriba services.mscy, a continuación, haga clic en Aceptar. Busque el servicio AOS. Si está ejecutando el servicio, haga clic en el servicio y, a continuación, haga clic en Detener.

    Nota: El nombre del servicio AOS utiliza el formato siguiente:
    Número de instancia AOS -nombre de la instancia de Dynamics Server$
  2. Inicie la consola del Administrador de soporte, analizador de consultas de Microsoft SQL o SQL Server Management Studio. Para ello, utilice uno de los métodos siguientes dependiendo del programa que está utilizando.

    Método 1: Para SQL Server Desktop Engine

    Si utiliza SQL Server Desktop Engine (también conocido como MSDE 2000), inicie la consola del Administrador de soporte. Para ello, haga clic en Inicio, seleccione Todos los programas, elija Consola de administrador de Microsofty, a continuación, haga clic en Consola de administrador de soporte.

    Método 2: Para SQL Server 2000

    Si está utilizando SQL Server 2000, inicie el analizador de consultas SQL. Para ello, haga clic en Inicio, seleccione Todos los programas, seleccione Microsoft SQL Servery, a continuación, haga clic en Analizador de consultas.

    Método 3: Para SQL Server 2005

    Si está utilizando SQL Server 2005, inicie SQL Server Management Studio. Para ello, haga clic en Inicio, seleccione Todos los programas, seleccione Microsoft SQL Server 2005y, a continuación, haga clic en SQL Server Management Studio.
  3. Cierre todas las conexiones abiertas con el servidor de base de datos de Microsoft Dynamics AX.
  4. Reinicie el servicio AOS.
  5. Reinicie al cliente de Microsoft Dynamics AX.

Más información


Para evitar este problema, utilice uno o varios de los métodos siguientes:
  • En la configuración de AOS, utilice una dirección IP en lugar de un nombre de sistema de nombres de dominio (DNS), una unidad asignada o una carpeta compartida oculta que contiene los archivos de instalación del programa.
  • Mientras están conectados a los servidores que están ejecutando el servicio AOS, deshabilitar la detección de virus en tiempo real de la carpeta compartida que contiene los archivos de programa compartidos.
  • Configuración incorrecta de los adaptadores de red en equipo puede causar problemas de conexión. Asegúrese de que la configuración de la Opción de poder guardar no está habilitada en el adaptador de red. El servicio AOS y el cliente utilizan el primer adaptador de red está disponible. Asegúrese de que los adaptadores de red de área local (LAN) son primeros en el orden de enlace antes de todos los adaptadores de red inalámbrica.
  • Supervisar los archivos bloqueados y los archivos disponibles mediante la consola de administración de equipos en el servidor de archivos de programa. Para ello, siga estos pasos:
    1. Haga clic en Inicio, haga clic en Ejecutar, escriba compmgmt.msc y, a continuación, haga clic en Aceptar.
    2. En el árbol de la consola Administración de equipos, haga clic en Carpetas compartidas.