Problemas conocidos al instalar SQL Server en Windows 7 o Windows Server 2008 R2

Se aplica a: SQL Server 2008 EnterpriseSQL Server 2008 DeveloperSQL Server 2008 Standard

Resumen


En este artículo se describen los problemas conocidos al instalar Microsoft SQL Server en un equipo con Windows 7 o Windows Server 2008 R2.

Notas

  • Para todas las ediciones, excepto Express Edition de SQL Server 2008 que se ejecuta en Windows 7 o en Windows Server 2008 R2, debe tener instalado al menos SQL Server 2008 Service Pack 1 (SP1).

    Nota Express Edition ya incluye el Service Pack 1.
  • Para todas las ediciones de SQL Server 2005 que se ejecutan en Windows 7 o en Windows Server 2008 R2, debe tener instalado al menos SQL Server 2005 Service Pack 3 (SP3).
  • En este artículo, Windows 7 indica la versión de cliente de Windows 7. Windows Server 2008 R2 indica la versión de servidor de Windows 7.
  • Para obtener más información sobre los requisitos de hardware y software de varias versiones de SQL Server, consulte Requisitos de hardware y software para instalar SQL Server 2012.
  • Para consultar las notas de la versión que recogen varios problemas conocidos en el momento de publicarse el producto, visite Notas de la versión de SQL Server 2012.

Problemas conocidos


  • Windows 7 no utiliza la propiedad RequireKerberos para determinar si está habilitada la autenticación Kerberos

    Como Windows 7 no usa la propiedad RequireKerberos para determinar si la autenticación Kerberos está habilitada para un recurso Nombre de red, la instalación del clúster de conmutación por error de SQL Server 2008 RTM produce un error.
  • Cuando la directiva del Estándar federal de procesamiento de información (FIPS) está habilitada en Windows 7 o en Windows Server 2008 R2, se produce un error de validación de clúster durante la instalación de SQL Server 2008.

    Cuando la directiva de FIPS está habilitada en Windows 7 o en Windows Server 2008 R2, se produce un error de validación de clúster durante la instalación de SQL Server 2008. Por tanto, se produce un error en el programa de instalación.

    Para resolver estos dos problemas, debe instalar SQL Server 2008 junto con SQL Server 2008 (SP1) o una actualización posterior para instalaciones en clúster. Para obtener información adicional sobre cómo obtener Microsoft SQL Server 2008 SP1, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

    968382 Cómo obtener el Service Pack más reciente para SQL Server 2008

    Para obtener más información sobre cómo actualizar el programa de instalación de SQL Server en un entorno en clúster o no agrupado, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

    955392 Cómo actualizar o integrar una instalación de SQL Server 2008

  • La instalación de SQL Server 2008 puede producir un error en Windows Server 2008 R2

    La instalación de SQL Server 2008 puede producir un error en Windows Server 2008 R2 si Microsoft .NET Framework no está habilitado. Este problema se produce porque la instalación de .NET Framework 3.5 es un requisito previo para esta instalación.

    En Windows Server 2008 R2, .NET Framework 3.5 se incluye como componente de Windows. De forma predeterminada, .NET Framework 3.5 no está habilitado. Para evitar este error de instalación, debe habilitar .NET Framework 3.5 desde el componente de características de Windows antes de ejecutar la instalación de SQL Server 2008.
  • El programa de instalación de SQL Server 2008 puede producir un error

    El programa de instalación de SQL Server 2008 puede generar el siguiente error:
    No se puede llamar a Invoke ni a BeginInvoke en un control hasta que se haya creado el identificador de ventana.
    Puede instalar una actualización acumulativa para resolver este problema. Para obtener más información al respecto, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
    975055 CORRECCIÓN: Aparece un mensaje de error al instalar SQL Server 2008 en un equipo con Windows 7: "No se puede llamar a Invoke o a BeginInvoke en un control hasta que se haya creado el identificador de ventana"

Más información


Requisitos mínimos de versión para Windows 7 o Windows Server 2008 R2.

Antes de instalar SQL Server en un equipo que ejecute Windows 7 o Windows Server 2008 R2, debe asegurarse de que cumple los siguientes requisitos previos mínimos, según corresponda a su situación.

SQL Server 2008

Instalaciones en clúster

Debe instalar SQL Server 2008 junto con SQL Server 2008 Service Pack 1 o una actualización posterior (también conocida como versión de instalación integrada).

Instalaciones no agrupadas

Debe instalar SQL Server 2008 seguido de SQL Server 2008 Service Pack 1 o una actualización posterior.
Nota El tiempo de ejecución de SQL Server 2008 Express es compatible con Windows 7 y Windows Server 2008 R2.
Si desea obtener más información sobre los requisitos de hardware y software para instalar SQL Server 2008, visite el sitio web Requisitos de hardware y software para instalar SQL Server 2012 de Microsoft Developer Network (MSDN).

SQL Server 2005

Debe instalar SQL Server 2005 seguido de SQL Server Service Pack 3 o una actualización posterior.

Para obtener más información sobre las instalaciones en clúster de SQL Server 2005, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

973993 Algunos nodos no se actualizan como se esperaba al aplicar Service Pack 3 o una actualización de Service Pack 3 en un clúster de SQL Server 2005 que se basa en clúster de conmutación por error de Windows Server 2008 R2

Para obtener más información sobre cómo obtener los Service Pack de SQL Server 2005, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

913089 Cómo obtener el Service Pack más reciente para SQL Server 2005

Más información sobre SQL Server 2005


Nota
El tiempo de ejecución de SQL Server 2005 Express Service Pack 2 es compatible con Windows 7 y Windows Server 2008 R2.


.NET Framework

Debe habilitar Microsoft .NET Framework 3.5 SP1 antes de instalar SQL Server 2008 en un equipo con Windows Server 2008 R2. .NET Framework 3.5 SP1 es un requisito previo para SQL Server 2008. El programa de instalación de SQL Server 2008 instala .NET Framework 3.5 SP1 si no está instalado todavía. Sin embargo, para el clúster de conmutación por error, debe instalarse .NET Framework 3.5 SP1 antes de la instalación de clúster de conmutación por error de SQL Server 2008.

En Windows Server 2008 R2, .NET Framework es un componente del sistema. Por tanto, no se puede instalar .NET Framework desde un punto de redistribución. Debe instalar .NET Framework desde la función de servidor o mediante ServerManagerCmd.exe.

No es necesario instalar .NET Framework en las situaciones siguientes:
  • En un equipo que ejecuta Windows Server 2008 R2 y en el que .NET Framework 3.5 SP1 está instalado
  • En un equipo con Windows 7

Nota De forma predeterminada, .NET Framework 3.5 SP1 está instalado en Windows 7.