Id. de evento 1309 y no puede acceder a OWA y ECP después de instalar Exchange Server 2016 o Exchange Server 2013

Número de KB original: 3099532

Síntomas

Instaló correctamente Microsoft Exchange Server 2016 o Exchange Server 2013. Es posible que se haya producido un error en el proceso de instalación o que se haya interrumpido en alguna fase y, a continuación, se haya reanudado y finalmente se haya completado correctamente. Sin embargo, al intentar acceder a Exchange Panel de control (ECP) o Outlook Web App (OWA), recibe el siguiente mensaje de error:

Hubo un problema

Lo sentimos, no podemos obtener esa información ahora mismo. Inténtelo de nuevo más tarde. Si el problema persiste, póngase en contacto con su equipo de soporte técnico.

Captura de pantalla del mensaje de error: no podemos obtener esa información en este momento.

Además, el siguiente evento puede registrarse en el registro de aplicaciones:

Log Name:  Application
Source:  ASP.NET 4.0.30319.0
Event ID:  1309
Task Category:  Web Event
Level:  Warning
Keywords:  Classic
User:  N/A
Computer:  Exch2.contoso.com
Description:

Event code: 3005
Event message: An unhandled exception has occurred.

Event ID: f23d9d455f3145068c57286262ac517f
Event sequence: 1
Event occurrence: 1
Event detail code: 0

Application information:
  Application domain: /LM/W3SVC/2/ROOT/owa-5-130879214460462920
  Trust level: Full
  Application Virtual Path: /owa
  Application Path: C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\owa\
  Machine name: EXCH2

Process information:
  Process ID: 4348
  Process name: w3wp.exe
  Account name: NT AUTHORITY\SYSTEM

Exception information:
  Exception type: TargetInvocationException
  Exception message: Exception has been thrown by the target of an invocation.
  at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck,
  Boolean&canBeCached, RuntimeMethodHandleInternal&ctor, Boolean&bNeedSecurityCheck)

    * SharedWebConfig.config is missing from either of these locations:
      C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy
      C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess

Causa

Este problema se produce si falta SharedWebConfig.config de cualquiera de las siguientes ubicaciones:

  • C:\Archivos de programa\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy
  • C:\Archivos de programa\Microsoft\Exchange Server\V15\ClientAccess

Solución

Para resolver este problema, siga estos pasos:

  1. En el servidor que se enfrenta al problema, identifique la ubicación de la que falta el archivo.

  2. Genere el archivo que falta:

    1. Ejecute cd %ExchangeInstallPath%\bin para cambiar el directorio actual a la carpeta bin que se encuentra en la ruta de instalación de Exchange.

    2. Use la herramienta DependentAssemblyGenerator.exe para generar el archivo:

      • Si el archivo falta en C:\Archivos de programa\Microsoft\Exchange Server\V15\ClientAccess, ejecute el siguiente comando:
      DependentAssemblyGenerator.exe -exchangePath "%ExchangeInstallPath%\bin" -exchangePath "%ExchangeInstallPath%\ClientAccess" -configFile "%ExchangeInstallPath%\ClientAccess\SharedWebConfig.config"
      
      • Si el archivo falta en C:\Archivos de programa\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy, ejecute el siguiente comando:
      DependentAssemblyGenerator.exe -exchangePath "%ExchangeInstallPath%\bin" -exchangePath "%ExchangeInstallPath%\FrontEnd\HttpProxy" -configFile "%ExchangeInstallPath%\FrontEnd\HttpProxy\SharedWebConfig.config"
      
  3. Ejecute IISRESET o reinicie el servidor.

Más información

El archivo SharedWebConfig.config genera durante la fase posterior a la instalación del programa de instalación. Si el programa de instalación se reanuda después de una interrupción, no realiza los pasos posteriores a la instalación para los roles que se instalaron correctamente antes de la interrupción.