Se produce una pérdida de memoria en una aplicación basada en.NET Framework 2.0 que utiliza la clase AesCryptoServiceProvider


Síntomas


Cuando se ejecuta una aplicación basada en.NET Framework 2.0 que utiliza la clase AesCryptoServiceProvider de Microsoft, se produce una pérdida de memoria.

Causa


Este problema se produce debido a las razones siguientes.

Causa 1

Dos puntos de control nativos que se encuentran en una relación principal/secundario en un objeto AesCryptoServiceProvider pertenecen para separar objetos administrados. Cuando se elimina el identificador principal de la primera, el sistema no puede rastrear y suelte toda la memoria que posee el identificador secundario.

Causa 2

El objeto AesCryptoServiceProvider pérdidas de una referencia a un objeto en su interfaz ICryptoTransform.

Solución


Información de la revisión

Ahora hay una revisión compatible de Microsoft. Sin embargo, se pretende corregir el problema que describe este artículo. Aplíquela sólo a sistemas que experimenten este problema específico.

Para resolver este problema, póngase en contacto con los servicios de soporte técnico de Microsoft para obtener la revisión. Para obtener una lista completa de números de teléfono de los servicios de soporte al cliente de Microsoft e información acerca de los costos de soporte técnico, visite el siguiente sitio Web de Microsoft:Nota: En casos especiales, los costos derivados normalmente de las llamadas al soporte técnico pueden cancelarse si un profesional de soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión.

Para descargar este hotfix desde MSDN Code Gallery, visite el siguiente sitio Web de Microsoft:Nota: MSDN Code Gallery muestra los idiomas para los que la revisión está disponible. Si no ve su idioma en la lista, es porque la página de recursos de galería de código no está disponible para ese idioma.

También puede descargar este hotfix desde el siguiente sitio Web de Microsoft:

Requisitos previos

Debe tener.NET Framework 2.0 Service Pack 2 (SP2) o el de Microsoft.NET Framework 3.5 Service Pack 1 (SP1) instalado para poder aplicar este hotfix.

Requisito de reinicio

No es necesario que reinicie el equipo después de aplicar la revisión si no se utilizan los archivos afectados.

Información de reemplazo de revisión

Este hotfix no sustituye a otras revisiones.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.
Para todas las versiones de x86 de Windows Server 2003, Windows XP, Windows Vista y de Windows Server 2008
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
System.core.dll3.5.30729.4530667,64801-Apr-201009:55x86
Para todas las versiones de x64 de Windows Server 2003, Windows XP, Windows Vista y de Windows Server 2008
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
System.core.dll3.5.30729.4530667,64801-Apr-201009:55x86
Para todas las versiones basadas en x86 compatibles de Windows 7
Nombre del archivoVersión del archivoArchivo

tamaño
FechaHoraPlataforma
System.core.dll3.5.30729.5025667,64829-Apr-201023:55x86
Para todas las versiones basadas en x64 de Windows 7 y Windows Server 2008 R2
Nombre del archivoVersión del archivoArchivo

tamaño
FechaHoraPlataforma
System.core.dll3.5.30729.5025667,64830-Apr-201000:31x64
Para todas las versiones basadas en IA-64 compatibles de Windows Server 2008 R2
Nombre del archivoVersión del archivoArchivo

tamaño
FechaHoraPlataforma
System.core.dll3.5.30729.5025667,64829-Apr-201023:50IA-64

Estado


Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".