Solucionar errores SOAP en las páginas del proyecto de Portal de negocio en Microsoft Dynamics SL


Síntomas


Cuando visite cualquiera de los proyectos relacionados con páginas como hora de entrada, entrada de gastos, Communicator Webpart, analista de proyectos y analista ejecutivo de proyecto en business portal, recibirá un mensaje de error rojo largo similar a uno de los siguientes:

Mensaje de error 1:

Error: Datos adjuntos: máximo reintentos de conexión sobrepasado. HRESULT = 0 x 80004005: error - cliente no especificado: se ha producido un error inesperado durante el procesamiento de esta solicitud. HRESULT = 0 x 80004005: error - cliente no especificado: enviar el mensaje Soap falló o no fue ninguna respuesta reconocible recibió HRESULT = 0 x 80004005: error - cliente no especificado: error de cliente no especificado. HRESULT = 0 x 80004005: error no especificado faultcode = cliente faultstring = adjunto: número máximo de reintentos de conexión sobrepasada.

Vea las resoluciones 6, 7, 8 y 9

Mensaje de error 2:

Tiempo de espera de conexión: conector. HRESULT = 0x800A1527 - cliente: se ha producido un error inesperado durante el procesamiento de esta solicitud. HRESULT = 0x800A1527 - cliente: enviar el mensaje Soap falló o no fue ninguna respuesta reconocible recibió HRESULT = 0x800A1527 - cliente: error de cliente no especificado.

Vea las resoluciones 6, 7, 8 y 9

Mensaje de error 3:

Certificado de conector: malo. HRESULT = 0x800A1529 - cliente: se ha producido un error inesperado durante el procesamiento de esta solicitud. HRESULT = 0x800A1529 - cliente: enviar el mensaje Soap falló o no fue ninguna respuesta reconocible recibió HRESULT = 0x800A1529 - cliente: error de cliente no especificado. HRESULT = 0X800A1529

Vea la solución 6 y 9

Mensaje de error 4:

Conector: error HTTP no especificado. HRESULT = 0x800A1518 - cliente: se ha producido un error inesperado durante el procesamiento de esta solicitud. HRESULT = 0x800A1518 - cliente: enviar el mensaje Soap falló o no fue ninguna respuesta reconocible recibió HRESULT = 0x800A1518 - cliente: error de cliente no especificado. HRESULT = 0X800A1518

Vea las resoluciones 6, 7, 8 y 9

Mensaje de error 5:

Habilitar la autorización de esquema coincidente conexión failure.:No en conector. HRESULT = 0 x 80004005: error - cliente no especificado: se ha producido un error inesperado durante el procesamiento de esta solicitud. HRESULT = 0 x 80004005: error - cliente no especificado: enviar el mensaje Soap falló o no fue ninguna respuesta reconocible recibió HRESULT = 0 x 80004005: error - cliente no especificado: error de cliente no especificado. HRESULT = 0 x 80004005: error no especificado

Vea las resoluciones 7 y 9

Mensaje de error 6:

Error en cliente: cargar la solicitud en SoapReader. HRESULT = 0 x 80070057: el parámetro es incorrecto. -Cliente: error de cliente no especificado. HRESULT = 0 x 80070057: el parámetro es incorrecto. faultcode = cliente.

Vea las resoluciones 6, 7, 8 y 9

Mensaje de error 7:

La aplicación no puede abrir la base de datos del sistema.
[DBNETLIB] [ConnectionOpen (Connect()).] SQL Server no existe o acceso denegado.
El administrador del sistema debe ejecutar pcConfiguration en el servidor de Portal de negocio para corregir este problema.

Vea las resoluciones 5 y 9

Mensaje de error 8:

Se detectó un error.
Error: Se produjo un error al abrir la base de datos del sistema. (pcconnect)

Vea las resoluciones 1, 2, 3, 4 y 9

Mensaje de error 9:

La aplicación no puede leer la información de conexión de Solomon.
El administrador del sistema debe ejecutar pcConfiguration en el servidor de Portal de negocio para solucionar este problema

Vea las resoluciones 1, 2, 3, 4 y 9

Mensaje de error 10:

No se puede conectar a la base de datos de sistema ejecutar PCConfiguration. Nombre de usuario válido y una contraseña.

Vea las resoluciones 4 y 9

Mensaje de error 11:

Error: Cliente SOAP: se produjo un error durante el procesamiento de la solicitud SOAP.
Ruta no válida para el PCService.asmx especificado en ProjectService.wsdl
El administrador del sistema debe ejecutar pcConfiguration - servicio de actualización de Web en el servidor de Portal de negocio para solucionar este problema.

Vea las resoluciones 6 y 9

Causa


Para las páginas del proyecto a la función, servicios de Internet Information Server (IIS) debe para poder preparar y enviar una solicitud SOAP Simple Object Access Protocol () en el archivo PCService.asmx.  Hay varias cosas que tienen que configurar para que funcione.  Si uno o más de los siguientes no son el programa de instalación correctamente, puede provocar los errores enumerados en la sección "Síntomas":

  1. La información de inicio de sesión de base de datos de Microsoft Dynamics SL falta o está almacenado incorrectamente en el registro.
  2. El Microsoft.Solomon.Pma.Security.ImpersonateDLL.dll falta, no está registrado, o los usuarios no tienen permisos para el archivo.
  3. La identidad del grupo de aplicaciones no tiene permisos para la clave del registro HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Business Portal\PMA\Solomon
  4. El capicom.dll falta, no registrado, de una versión incorrecta, o los usuarios no tienen permisos para el archivo
  5. El servidor que ejecuta IIS y el servidor SQL debe ser capaz de comunicarse mediante el protocolo TCP/IP
  6. La ruta de acceso al archivo PCService.asx en la ProjectService.wsdl es incorrecta
    1. La ruta de acceso debe apuntar al nombre del servidor IIS
    2. La ruta debe incluir el número de puerto
    3. La ruta debe ser una URL no SSL
    4. Si usa encabezados de Host de IIS, debe resolver la ruta de acceso al sitio Web correcto
  7. El sitio de IIS no está usando la autenticación de Windows (NTLM)
  8. La variable de SessionState del archivo Web.config no está configurada correctamente

El mensaje de error no suele proporciona toda la información en la que los elementos anteriores puede ser incorrecta.  Por lo que se recomienda que pruebe las posibles resoluciones.

Solución


Solución 1: Ejecute la utilidad PCConfiguration

  1. Busque el archivo PCConfiguration.exe en el servidor de Business Portal hacia fuera y haga doble clic para ejecutar.  Esto se encuentra normalmente en la carpeta c:\Inetpub\wwwroot\bin o en la carpeta C:\Inetpub\wwwroot\wss\VirtualDirectories\80\bin.
  2. Rellene los siguientes cuadros:
    1. Nombre de SQL Server: escriba el nombre del servidor SQL que aloja las bases de datos de Microsoft Dynamics SL
    2. Sistema DB - introduzca el nombre de la base de datos de sistema de Microsoft Dynamics SL
    3. El usuario SQL, escriba el nombre de un usuario SQL que tiene acceso a la base de datos del sistema.  "SA" o "BusinessPortalUser" son opciones comunes.
    4. Contraseña: escriba la contraseña para el usuario especificado en el cuadro de usuario SQL
  3. Haga clic en Probar conexión.  Si recibe un error, compruebe los valores en el paso 2. Nota: Este botón no puede realizar la acción debido a error 55474.
  4. Haga clic en Actualizar registro.  Debe recibir el mensaje siguiente: "los datos se han escrito correctamente en el registro"
  5. Cierre la utilidad y vuelva a intentarlo las páginas de Portal de negocio.

Solución 2 : Compruebe el archivo Microsoft.Solomon.Pma.Security.ImpersonateDLL.dll

  1. En el servidor de Portal de negocio, inicie el Administrador de Internet Information Services (IIS)
  2. (Ratón) en el sitio Web de Portal de negocio y seleccione 'Propiedades'
  3. En la ficha directorio principal, tome nota del valor en el cuadro "Ruta Local"
  4. En la ficha directorio principal, tome nota del valor en el cuadro combinado "Grupo de aplicaciones"
  5. Haga clic en Aceptar para cerrar la ventana de 'Propiedades'
  6. En el Administrador de IIS, expanda en 'Grupos de aplicaciones'.  Haga clic en el grupo de aplicaciones se encuentra en el paso 4 y seleccione 'propiedades'.
  7. En la ficha 'Identidad', tenga en cuenta el usuario especificado como la identidad del grupo de aplicaciones.
  8. Haga clic en Aceptar para cerrar la ventana de 'Propiedades'.
  9. Cierre fuera el Administrador de IIS
  10. En el Explorador de Windows, vaya al directorio hallado en el paso 3
  11. En la carpeta Bin, desplácese hacia abajo y busque el archivo Microsoft.Solomon.Pma.Security.ImpersonateDLL.dll.
    1. Si falta este archivo, tendrá que volver a instalar Business Portal
  12. Haga clic en el archivo y seleccione Propiedades
  13. En la ficha 'Seguridad', asegúrese de que el usuario del paso 7 tiene derechos 'Lectura' y 'leer y ejecutar'
  14. Haga clic en Aceptar para cerrar la ventana de 'Propiedades'
  15. Haga clic en el archivo nuevo y seleccione 'Abrir con...'
  16. Seleccione "Seleccionar el programa de una lista"
  17. Haga clic en "Examinar..."
  18. Vaya a la carpeta C:\Windows\System32 y buscar el archivo Regsvr32.exe y, a continuación, haga clic en 'Abrir'
  19. Haga clic en Aceptar.  Recibirá el siguiente mensaje: "DllRegisterServer en C:\Inetpub\wwwroot\bin\Microsoft.Solomon.Pma.Security.ImpersonateDLL.dll tuvo éxito".
  20. Intente cargar de nuevo las páginas de Portal de negocio

Resolución 3 : Compruebe la clave del registro

  1. En el servidor de Portal de negocio, inicie el Administrador de Internet Information Services (IIS)
  2. (Ratón) en el sitio Web de Portal de negocio y seleccione Propiedades
  3. En la ficha directorio principal, anote el valor en el cuadro combinado "Grupo de aplicaciones"
  4. Haga clic en Aceptar para cerrar el cuadro de diálogo Propiedades y cerrar fuera del Administrador de IIS
  5. Haga clic en Inicio -> Ejecutar y escriba RegEdt32.  Esto debe abrir el Editor del registro
  6. Vaya a HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Business Portal\PMA\Solomon
    1. Si falta esta clave del registro, vea la solución 1 para ejecutar la utilidad de PCConfiguration
  7. Haga clic en "Salomón" y seleccione "Permisos"
  8. Asegúrese de que el usuario del paso 3 se 'permisos de lectura'
  9. Intente cargar de nuevo las páginas de Portal de negocio

Para obtener más información, consulte 912363 de artículo de Knowledge Base .

Solución 4 : Compruebe el archivo capicom.dll

  1. En el servidor de Portal de negocio, vaya a la carpeta C:\windows\system32
  2. Haga clic en CAPICOM. Archivo DLL y seleccione 'propiedades'
    1. Si falta este archivo, tendrá que copiar el archivo desde otra estación de trabajo o vuelva a instalar Business Portal
  3. En la ficha versión, asegúrese de que la versión del archivo muestra 2.1.0.1
    1. Si la versión del archivo es incorrecta, tendrá que copiar el archivo desde otra estación de trabajo o vuelva a instalar Business Portal
  4. En la ficha seguridad, asegúrese de que ha leído el grupo dominio\Usuarios y lectura y ejecución de derechos a este archivo.  ConsulteEl artículo 927618 de Knowledge Base
  5. Haga clic en Aceptar para cerrar el cuadro de diálogo de propiedades
  6. Haga clic en el archivo nuevo y seleccione 'Abrir con...'
  7. Seleccione "Seleccionar el programa de una lista"
  8. Haga clic en "Examinar..."
  9. Vaya a la carpeta C:\Windows\System32 y buscar el archivo Regsvr32.exe y, a continuación, haga clic en Abrir
  10. Haga clic en Aceptar.  Recibirá el siguiente mensaje: "DllRegisterServer en C:\WINDOWS\system32\capicom.dll tuvo éxito".
  11. Intente cargar de nuevo las páginas de Portal de negocio
  12. Si sigue recibiendo el error:
    1. Vea la solución 1, volver a ejecutar la utilidad PCConfiguration.
    2. Reinicie IIS haciendo clic en Inicio -> Ejecutar y escriba "IISReset"
    3. Intente cargar de nuevo las páginas de Portal de negocio

Para obtener más información, consulte 909144 de artículo de Knowledge Base .

Resolución 5: Compruebe el servidor IIS y el servidor SQL son capaces de comunicarse mediante el protocolo TCP/IP

  1. El protocolo TCP/IP debe estar habilitado en ambos el SQL Server y en el servidor que ejecuta IIS que aloja los sitios de portal de negocio.
  2. Para obtener información acerca de cómo comprobarlo, consulte Knowledge Base artículo 954024

Resolución 6 : Compruebe la ruta de acceso del archivo PCService.asx en el archivo ProjectService.wsdl

  1. En el servidor de Portal de negocio, busque hacia fuera el archivo ProjectService.wsdl.  Normalmente se encuentra en el directorio C:\Program Files\Microsoft Dynamics\Business Portal\Applications\PMA.
  2. Abra el archivo en el Bloc de notas
  3. Desplácese hasta el final del archivo y busque la etiqueta que comienza con "< SOAP: dirección ="
  4. Debe haber una dirección URL para el archivo PCService.asmx dentro de esta etiqueta.  Debería parecerse al siguiente:

    "HTTP://machinename:80/BusinessPortal/Applications/PMA/PCService.asmx"

    Esta dirección URL tiene unos requisitos específicos.  Compruebe y corrija los elementos siguientes según sea necesario:
    1. La dirección URL debe especificar el nombre del equipo (por ejemplo, BPSERVER).  Direcciones IP (como 192.168.0.10), localhost o un nombre de dominio (como BP.contoso.com) no funciona para las solicitudes SOAP.
      1. Para buscar el nombre del equipo, haga clic en Inicio -> Ejecutar y escriba CMD
      2. Escriba un nombre de host y presione ENTRAR
      3. El nombre del equipo debe devolverse.  Machinename en la dirección URL se ha establecido para que coincida con éste.
    2. La dirección URL no debería utilizar SSL.  La dirección URL debe comenzar con "http://" y no "https://"
      1. Si su sitio Web está configurado para requerir SSL, consulte 924723 de artículo de Knowledge Base para conocer los pasos acerca de cómo configurar una excepción para permitir una conexión sin SSL al archivo PCService.asmx.
    3. Debe resolver la dirección URL para el sitio BusinessPortal Web de IIS
      1. Esto puede ser un problema si utiliza encabezados de Host para diferenciar varios sitios Web que se ejecutan en el mismo servidor.
      2. Para obtener más información, consulte 2005711 de artículo de Knowledge Base .
  5. Probar la dirección URL para asegurarse de que es válido.  Para ello, copie la dirección URL y pegarlo en el Explorador de Internet en el servidor de Portal de negocio.  Se abrirá una página titulada "PCServices".  Si en su lugar aparece un error de sharepoint o un error "page cannot be displayed", vuelva a comprobar los elementos en el paso 4.
  6. Ahora que el archivo ProjectService.wsdl tiene una dirección URL válida, inténtelo de nuevo las páginas de Portal de negocio

Para obtener más información, consulte Knowledge Base artículo 892356 o 897024 de artículo de Knowledge Base .

Resolución 7 - comprobar el método de autenticación en IIS

  1. En el servidor de Portal de negocio, inicie el Administrador de Internet Information Services (IIS)
  2. (Ratón) en el sitio Web de Portal de negocio y seleccione Propiedades
  3. En la ficha seguridad de directorios, en la sección "autenticación y control de acceso", haga clic en Editar...
  4. Asegúrese de que se comprueba que la "autenticación integrada de Windows"
  5. Asegúrese de que "Habilitar el acceso anónimo", "Autenticación de texto implícita para servidores de dominio de Windows" y "Autenticación de .NET Passport" están desactivados
  6. "Autenticación básica" no debe comprobarse. Sin embargo, no debe causar un problema si se activa
  7. Haga clic en Aceptar y, a continuación, haga clic en Aceptar otra vez para cerrar el cuadro de diálogo de propiedades
  8. Cierre fuera el Administrador de IIS
  9. Reinicie IIS haciendo clic en Inicio -> Ejecutar y escriba "IISReset"
  10. Vuelva a las páginas de Portal de negocio

Resolución 8 : Compruebe la variable de Sessionstate en el archivo web.config

  1. En el servidor de Portal de negocio, inicie el Administrador de Internet Information Services (IIS)
  2. (Ratón) en el sitio Web de Portal de negocio y seleccione Propiedades
  3. En la ficha directorio principal, anote el valor en el cuadro "Ruta Local"
  4. Haga clic en Aceptar para cerrar el cuadro de diálogo Propiedades y cerrar fuera del Administrador de IIS
  5. Examinar hacia fuera en el directorio que encontró en el paso 3 y busque el archivo web.config
  6. Haga una copia de seguridad del archivo web.config
  7. Abra el archivo web.config en el Bloc de notas
  8. Busque la etiqueta que comienza con "< sessionState"
  9. Cambiar la etiqueta completa a "< sessionState mode ="InProc"/ >"
  10. Guarde el archivo y cierre el Bloc de notas
  11. Reinicie IIS haciendo clic en Inicio -> Ejecutar y escriba "IISReset"
  12. Intente cargar de nuevo las páginas de Portal de negocio

Resolución 9 - ejecute el script PCConnectDebug y enviar resultados a admitir.

  1. Descargar B2004933_pcConnectDebug.zip
  2. Descomprima el archivo en el servidor de Portal de negocio
  3. Copie el archivo "pcConnectDebug.asp" en el directorio C:\Program Files\Microsoft Dynamics\Business Portal\Applications\PMA.
  4. En el servidor de Business Portal, abra Internet Explorer e inicie sesión en el Portal de negocio
  5. Haga clic en la página Web del centro de proyectos
  6. Pegue la dirección URL siguiente para abrir la página de PCConnectDebug:
    http://servername:port/BusinessPortal/Applications/PMA/pcconnectdebug.asp 

    Reemplace "nombreDeServidor" con el nombre del servidor de BP.  Reemplazar el "puerto" por el número de puerto que se ejecuta el sitio Web de BP.
  7. Solicitará que "Haga clic en Aceptar" para continuar.  Haga clic en Aceptar.
  8. Se mostrará una página Web que comienza con "Iniciando... depurar".   En Internet Explorer, haga clic en archivo -> Guardar como... y guarde la página en un archivo.
    1. Advertencia: dependiendo de cuánto era capaz de llegar a la depuración, los resultados pueden contener una contraseña en texto sin cifrar.  No dude en modificar el archivo en el Bloc de notas y reemplace la contraseña real con la palabra "thePassword" antes de enviar el archivo de ayuda.
  9. Enviar este archivo a servicios de soporte técnico de Microsoft para su análisis posterior.
  10. Tan pronto como se resuelve el problema, elimine el archivo pcConnectDebug.asp desde el directorio C:\Program Files\Microsoft Dynamics\Business Portal\Applications\PMA.

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