El estado nuevo de la impresora es "Sin conexión" después de eliminar una cola de impresión y, a continuación, reiniciar un equipo basado en Windows


Síntomas


Imagine la siguiente situación:

  • Elimina una cola de impresión mientras está en un estado sin conexión.
  • Agrega una nueva cola de impresión que tiene el mismo nombre que la cola de impresión anterior.
  • Reinicia el equipo.

En este escenario, el estado de la nueva cola de impresión aparece como Sin conexión.

Causa


Este problema se produce si el equipo tiene el siguiente valor del Registro configurado cuando establece el estado de la impresora como Sin conexión.

Clave: HKEY_CURRENT_CONFIG\System\CurrentControlSet\Control\Print\Printers\<nombre de la cola de impresión>
Valor: PrinterOnLine
Información: 0

Sin embargo, el archivo Localspl.dll no elimina este valor cuando se elimina la cola de impresión. Por tanto, cuando agrega una cola de impresión que tiene el mismo nombre que la cola de impresión anterior, la nueva cola de impresión hereda el estado Sin conexión de la cola de impresión eliminada.

Solución


Para que podamos solucionar su problema, diríjase a la sección "Solucionarlo en mi lugar". Si prefiere solucionar este problema usted mismo, vaya a la sección "Solucionarlo por mí mismo".

Solucionarlo en mi lugar

Para solucionar el problema de forma automática, haga clic en el vínculo o en el botón Descargar. Haga clic en Ejecutar en el cuadro de diálogo Descarga de archivos y después siga los pasos del asistente de Fix it.


Notas
  • Ejecute este paquete después de eliminar una cola de impresión pero antes de agregar la nueva cola de impresión con el mismo nombre.
  • Este asistente podría estar sólo en inglés. Sin embargo, la solución automática también funciona con versiones de Windows en otros idiomas.
  • Si no está utilizando el equipo que tiene el problema, puede guardar la solución Fix it en una unidad flash o en un CD para posteriormente ejecutarlas en el equipo donde está el problema.
A continuación, vaya a la sección "¿Esta información le ha ayudado a resolver su problema?".


 

Solucionarlo por mí mismo

Para solucionar este problema, haga clic con el botón derecho en la nueva cola de impresión en la herramienta Impresoras y faxes y, después, anule la selección de Usar impresora sin conexión. De este modo, la clave del Registro se restablece al valor correcto. También puede eliminar la clave del Registro que se menciona en la sección "Causa" tras eliminar una cola de impresión pero antes de agregar una nueva cola de impresión con el mismo nombre.


¿Esta información le ayudó a resolver el problema?