Dos caracteres especiales se agregan al final del valor, al copiar un valor de celda de una hoja de cálculo de Excel a Microsoft Dynamics NAV 5.0 Service Pack 1

Se aplica a: Microsoft Dynamics NAV 5.0

En este artículo se aplica a Microsoft Dynamics NAV para todos los países y todas las configuraciones regionales.

Síntomas


Cuando copia un valor de celda de una hoja de cálculo de Excel a Microsoft Dynamics NAV 5.0 Service Pack 1 (SP1), los dos caracteres especiales se agregan al final del valor. Estos caracteres especiales son signos de rectángulo como caracteres de salto de línea.

Nota: Si ejecuta Microsoft Dynamics NAV y Microsoft Excel en un equipo basado en Windows 7, estos dos caracteres no están visibles. Si ejecuta Microsoft Dynamics NAV y Microsoft Excel en un equipo basado en Windows Server 2003, los caracteres están visibles.

Estos caracteres se agregan a los campos de Microsoft Dynamics NAV. Por lo tanto, debe eliminar manualmente los caracteres especiales.

Causa


Este problema se produce porque del retorno de carro caracteres (CR) (ASCII 13) o el carácter (LF) (ASCII 10) de avance de línea se agrega al valor de una celda se copia de una hoja de cálculo de Excel en una aplicación. El cliente adaptado a roles (RTC) utiliza el control de texto, basándose en el control de texto estándar. NET. Si el control de texto de .NET tiene la propiedad Multiline establecida en "No", al pegar un texto de control que contiene el carácter CR o el carácter LF, se copia sólo el texto antes de los caracteres. Si el control de texto tiene la propiedad Multiline se establece en "True", la "nueva línea" carácter puede utilizarse. Para obtener más información, visite el siguiente sitio Web de Microsoft:
Propiedad TextBoxBase.Multiline
En un cliente clásico, Microsoft Dynamics NAV debe implementar un procesamiento especial para el método de pegado de controles de edición de texto. El texto "nueva línea" caracteres deben quitarse desde el final de la línea.

Solución


Información de la revisión

Existe un hotfix disponible desde Microsoft. Hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si tiene un problema al descargar, instalar esta revisión, o si tiene otras preguntas de soporte técnico, póngase en contacto con su socio o si está inscrito en un plan de soporte directamente con Microsoft, puede ponerse en contacto con soporte técnico para Microsoft Dynamics y crear una nueva solicitud de soporte técnico. Para ello, visite el siguiente sitio Web de Microsoft:También puede comunicarse con soporte técnico para Microsoft Dynamics por teléfono mediante estos vínculos para números de teléfono específico del país. Para ello, visite uno de los siguientes sitios Web de Microsoft:

Asociados de negociosClientesEn casos especiales, los costos derivados normalmente de las llamadas pueden cancelarse si un profesional de soporte técnico de Microsoft Dynamics y productos relacionados de soporte determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión.



Cómo obtener la revisión de Microsoft Dynamics NAV o actualizar archivos

Después de solicitar una revisión de Microsoft Dynamics NAV, se le enviará un hipervínculo en un mensaje de correo.


El mensaje incluirá un hipervínculo y una contraseña. Puede usar el hipervínculo para descargar la revisión de Microsoft Dynamics NAV o los archivos de actualización. Al hacer clic en el hipervínculo, se abre el cuadro de diálogo Descargar archivo-Advertencia de seguridad . A continuación, deberá ejecutar, guardar o cancelar la descarga.


Si hace clic en Ejecutar, los archivos comienzan la descarga y el proceso de extracción. Debe especificar una carpeta para los archivos nuevos y, a continuación, proporcione la contraseña.


Si hace clic en Guardar, especifique una ruta de acceso para guardar el archivo comprimido. Cuando se abre el archivo que guardó, deberá especificar una ruta para los archivos. A continuación, debe proporcionar la contraseña incluida en el correo electrónico.


Si hace clic en Cancelar, se detiene el proceso de descarga.



Cómo instalar una revisión de Microsoft Dynamics NAV o un archivo de actualización

Las actualizaciones y revisiones de la plataforma Microsoft Dynamics NAV están disponibles como archivos únicos. Para instalar una revisión de Microsoft Dynamics NAV o una actualización, debe reemplazar los archivos de instalación de Microsoft Dynamics NAV existentes con la revisión o la actualización de los archivos. Para ello, siga estos pasos:

Paso 1: Reemplazar el archivo de instalación de cliente de Microsoft Dynamics NAV

En la instalación de cliente de Microsoft Dynamics NAV, sustituya los archivos siguientes utilizando el archivo de actualización o la revisión.
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Dbm.dll5.0.32009.0434.17609-Dec-201019:53x86
Fin.exe5.0.32009.010,747,90409-Dec-201019:31x86
Finhlink.exe5.0.32009.0339.96809-Dec-201019:44x86
Finsql.exe5.0.32009.010,809,34409-Dec-201020:17x86
Nc_netb.dll5.0.32009.0102,40009-Dec-201019:54x86
Nc_tcp.dll5.0.32009.0102,40009-Dec-201019:54x86
Nc_tcps.dll5.0.32009.0147.45609-Dec-201019:55x86
Ndbcs.dll5.0.32009.01,286,14409-Dec-201020:20x86
Slave.exe5.0.32009.0151,55209-Dec-201019:44x86
Para reemplazar los archivos existentes de Microsoft Dynamics NAV, siga estos pasos:
  1. Cierre Microsoft Dynamics NAV.
  2. Busque el directorio de instalación de cliente de Microsoft Dynamics NAV. El cliente de Microsoft Dynamics NAV se instala normalmente en el directorio siguiente:
    C:\Program Files\Microsoft Dynamics NAV\CSIDE Client\
  3. Copie los archivos que ha descargado.
  4. Pegue los archivos que ha descargado en el directorio de instalación de cliente de Microsoft Dynamics NAV.
  5. Cuando se le pida, haga clic en para sobrescribir los archivos en el directorio de instalación.

Paso 2: Reemplazar el archivo de instalación de Microsoft Dynamics NAV Application Server

Si tiene Microsoft Dynamics NAV Application Server instalado en la instalación de Microsoft Dynamics NAV Application Server, reemplace los archivos siguientes utilizando la revisión o el archivo de actualización.
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Dbm.dll5.0.32009.0434.17609-Dec-201019:53x86
Nas.exe5.0.32009.01,859,58409-Dec-201019:41x86
Nassql.exe5.0.32009.01,916,92809-Dec-201020:19x86
Ndbcs.dll5.0.32009.01,286,14409-Dec-201020:20x86
Slave.exe5.0.32009.0151,55209-Dec-201019:44x86
Para reemplazar los archivos, siga estos pasos.
  1. Detener el servidor de aplicaciones Microsoft Dynamics NAV.
  2. Busque el directorio de instalación de Microsoft Dynamics NAV Application Server. Microsoft Dynamics NAV Application Server normalmente se instala en el directorio siguiente:
    C:\Program Files\Microsoft Dynamics NAV\Application Server\
  3. Copie los archivos que ha descargado.
  4. Pegue los archivos que ha descargado en el directorio de instalación de Microsoft Dynamics NAV Application Server.
  5. Cuando se le pida, haga clic en para sobrescribir los archivos en el directorio de instalación.
  6. Inicie Microsoft Dynamics NAV Application Server.

Paso 3: Vuelva a colocar el archivo de instalación del controlador ODBC de Microsoft Dynamics NAV

Si tiene instalado el controlador ODBC de Microsoft Dynamics NAV, sustituya los archivos siguientes en la instalación del controlador ODBC de Microsoft Dynamics NAV.
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Cfront.dll5.0.32009.01,294,33609-Dec-201019:55x86
Dbm.dll5.0.32009.0434.17609-Dec-201019:53x86
Nc_netb.dll5.0.32009.0102,40009-Dec-201019:54x86
Nc_tcp.dll5.0.32009.0102,40009-Dec-201019:54x86
Nc_tcps.dll5.0.32009.0147.45609-Dec-201019:55x86
Nodbc.dll5.0.32009.02,650,11209-Dec-201019:35x86
Nodbc.xmlNo aplicable120907-Apr-200801:09No aplicable
Nodbccfg.cfg5.0.32009.0614,40009-Dec-201019:36No aplicable
Nodbccfg.xmlNo aplicable2,47207-Apr-200801:09No aplicable
Slave.exe5.0.32009.0151,55209-Dec-201019:44x86
Para reemplazar los archivos, siga estos pasos.
  1. Busque el directorio de instalación del controlador ODBC de Microsoft Dynamics NAV. El controlador ODBC de Microsoft Dynamics NAV se instala normalmente en el directorio siguiente:
    C:\Program Files\Common Files\Dynamics NAV\NODBC\
  2. Copie los archivos que ha descargado.
  3. Pegue los archivos que ha descargado en el directorio de instalación del controlador ODBC de Microsoft Dynamics NAV.
  4. Cuando se le pida, haga clic en para sobrescribir los archivos en el directorio de instalación.

Requisitos previos

Debe tener Microsoft Dynamics NAV 5.0 Service Pack 1 instalado para aplicar esta revisión.

Solución alternativa


Para evitar, editar la celda y marque la celda como "Sólo texto".

Estado


Microsoft ha confirmado que se trata de un error de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información


Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Nota: Es un artículo "Publicación rápida" creado directamente desde dentro de la organización de soporte técnico de Microsoft. La información contenida en este documento se proporciona como está en respuesta a nuevos problemas. Como consecuencia de la velocidad en la puesta a disposición, los materiales pueden incluir errores tipográficos y podrán revisarse en cualquier momento sin previo aviso. Para obtener información adicional, consulte Condiciones de uso.