Sólo dos decimales se reconocen cuando los valores que tienen cinco decimales se envían a Microsoft Dynamics NAV con la versión de Microsoft Dynamics NAV 4.0 del controlador N/ODBC


Microsoft Business Solutions-Navision 4.0 y Microsoft Navision 4.0 ahora forman parte de Microsoft Dynamics NAV 4.0. Todas las referencias a Microsoft Business Solutions-Navision o a Microsoft Navision 4.0 corresponden a Microsoft Dynamics NAV.
En este artículo se aplica a Microsoft Dynamics NAV para todos los países y todas las configuraciones regionales.

Síntomas


Cuando los valores que tienen cinco decimales se envían a Microsoft Dynamics NAV con la versión de Microsoft Dynamics NAV 4.0 del controlador Microsoft Dynamics NAV Open Database Connectivity (N/ODBC), se reconocen sólo dos decimales.

Causa


Este problema se produce porque la versión de Microsoft Dynamics NAV 4.0 del controlador N/ODBC reconoce sólo dos decimales. Esta versión del controlador N/ODBC no es compatible con aplicaciones anteriores y con personalizaciones anteriores realizadas por los socios que se va a actualizar desde versiones anteriores a Microsoft Dynamics NAV 4.0.

Solución


Información del Service pack

Para resolver este problema, obtenga el service pack más reciente para Microsoft Dynamics NAV 4.0. Para obtener más información, visite el siguiente sitio Web de Microsoft:


Información de la revisión

Ahora hay una revisión compatible de Microsoft. El hotfix corrige el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico.

Para resolver este problema inmediatamente, póngase en contacto con soporte técnico de Microsoft Dynamics y productos relacionados obtener la revisión. Puede iniciar sesión en el sitio de Microsoft Dynamics y crear una nueva solicitud de soporte técnico. Para ello, visite el siguiente sitio web de Microsoft:También puede comunicarse con soporte técnico de Microsoft Dynamics y productos relacionados llamando por teléfono al (888) 477-7877.

Nota: En casos especiales, los costos derivados normalmente de las llamadas pueden cancelarse si un profesional de soporte técnico de Microsoft Dynamics y productos relacionados de soporte determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión.

Cómo obtener la revisión de Microsoft Dynamics NAV o actualizar archivos

Después de solicitar una revisión de Microsoft Dynamics NAV o un archivo de actualización del soporte técnico de Microsoft Dynamics, se le enviará un hipervínculo en un mensaje de correo.


El mensaje incluirá un hipervínculo y una contraseña. Puede usar el hipervínculo para descargar la revisión de Microsoft Dynamics NAV o los archivos de actualización. Al hacer clic en el hipervínculo, se abre el cuadro de diálogo Descargar archivo-Advertencia de seguridad . A continuación, deberá ejecutar, guardar o cancelar la descarga.


Si hace clic en Ejecutar, los archivos comienzan la descarga y el proceso de extracción. Debe especificar una carpeta para los archivos nuevos y, a continuación, proporcione la contraseña.


Si hace clic en Guardar, especifique una ruta de acceso para guardar el archivo comprimido. Cuando se abre el archivo que guardó, deberá especificar una ruta para los archivos. A continuación, debe proporcionar la contraseña incluida en el correo electrónico.


Si hace clic en Cancelar, se detiene el proceso de descarga.

Cómo instalar una revisión de Microsoft Dynamics NAV o un archivo de actualización

Las actualizaciones y revisiones de la plataforma Microsoft Dynamics NAV están disponibles como archivos únicos. Para instalar una revisión de Microsoft Dynamics NAV o una actualización, debe reemplazar los archivos de instalación de Microsoft Dynamics NAV existentes con la revisión o la actualización de los archivos. Para aplicar este hotfix, reemplace los siguientes archivos en la instalación del controlador ODBC de Microsoft Dynamics NAV.
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Nodbc.dll4.0.3.252021,227,38401-Nov-200717:34x86
Para reemplazar los archivos, siga estos pasos:
  1. Busque el directorio de instalación del controlador N/ODBC. El controlador N/ODBC se instala normalmente en el directorio siguiente:
    C:\Program Files\Common Files\Navision\NODBC\
  2. Copie los archivos que ha descargado.
  3. Pegue los archivos que ha descargado en el directorio de instalación del controlador N/ODBC.
  4. Haga clic en para sobrescribir los archivos en el directorio.

Estado


Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información


Al enviar valores con cinco posiciones decimales para Microsoft Business Solutions - Navision 3.60 y Navision Attain 2.60 mediante Microsoft Business Solutions - Navision ODBC driver para estas versiones (el controlador C/ODBC), se reconocen cinco decimales.

Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft