En un equipo basado en Windows Server 2003 R2 o Windows Server 2008 aloja los recursos compartidos de NFS, las solicitudes de E/S excesiva pueden provocar una condición TCPZeroWindow y la conexión NFS no se reinicia como se esperaba

Se aplica a: Windows Server 2008 StandardWindows Server 2008 EnterpriseWindows Server 2008 Datacenter

Síntomas


Tiene un equipo basado en Windows Server 2008 o Windows Server 2003 R2 que tiene Microsoft Services para Network File System (MSNFS) instalado y que exporta los recursos compartidos de NFS a los clientes NFS. Cuando las solicitudes de E/S excesiva son generadas por los clientes NFS en los recursos compartidos NFS, puede experimentar los problemas siguientes:
  • Si utiliza captura de red, es posible que el tamaño de la ventana para una conexión TCP se reduce a 0, lo que se denomina condición TCPZeroWindow.
  • Si intenta tener acceso a los recursos compartidos NFS, puede encontrar errores de E/S para la conexión correspondiente similar al siguiente:
    Error de entrada/salida
  • La conexión NFS no se reinicia como se esperaba. Finalmente, todas las conexiones de NFS al servidor van al mismo estado.

Causa


Este problema se produce porque el controlador de representación de datos externa (RPC) de llamada a procedimiento remoto (Rpcxdr.sys) confiable no reinicie conexiones TCP cuando hay muchas solicitudes de I/O.

Solución


Información de hotfix para Windows Server 2003

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

No hay requisitos previos.

Requisito de reinicio

No es necesario que reinicie el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Este hotfix no sustituye a otras revisiones publicadas anteriormente.

Información del registro

Para utilizar este hotfix, no es necesario realizar ningún cambio en el registro.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.

Windows Server 2003, versiones basadas en x86
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataformaRequisito de SPTipo de servicio
Rpcxdr.sys5.2.3790.323569.63225-Oct-200813:37x86SP1SP1QFE
Rpcxdr.sys5.2.3790.323569.63225 - Oct-200813:37x86SP1SP1QFE
Rpcxdr.sys5.2.3790.323569.63225 - Oct-200813:37x86SP1SP1QFE
Rpcxdr.sys5.2.3790.439869.63225 - Oct-200819:13x86SP2SP2QFE
Rpcxdr.sys5.2.3790.439869.63225 - Oct-200819:13x86SP2SP2QFE
Rpcxdr.sys5.2.3790.439869.63225- Oct-200819:13x86SP2SP2QFE
Windows Server 2003, versiones basadas en x 64
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataformaRequisito de SPTipo de servicio
Rpcxdr.sys5.2.3790.3235106,49627-Oct-200806:31x64SP1SP1QFE
Rpcxdr.sys5.2.3790.4398106,49627 -Oct-200806:44x64SP2SP2QFE

Información de hotfix para Windows Server 2008

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Revisiones importantes de Windows Vista y Windows Server 2008 se incluyen en los mismos paquetes. Sin embargo, sólo uno de estos productos puede aparecer en la página "Solicitud de revisión". Para solicitar el paquete de revisiones que se aplica a Windows Vista y Windows Server 2008, seleccione el producto que aparece en la página.

Requisitos previos

No hay requisitos previos.

Requisito de reinicio

No es necesario que reinicie el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Este hotfix no sustituye a otras revisiones publicadas anteriormente.

Información del registro

Para utilizar este hotfix, no es necesario realizar ningún cambio en el registro.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.

Windows Server 2008, versiones basadas en x86
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Rpcxdr.mofNo aplicable4,42418-Dec-200721:26No aplicable
Rpcxdr.sys6.0.6001.2233676,80022-Dec-200801:47x86
Windows Server 2008, versiones basadas en x64
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Rpcxdr.mofNo aplicable4,42418-Dec-200721:26No aplicable
Rpcxdr.sys6.0.6001.2233689.60022-Dec-200802:14x64
Windows Server 2008, versiones basadas en IA-64
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Rpcxdr.mofNo aplicable4,42418-Dec-200721:26No aplicable
Rpcxdr.sys6.0.6001.22336229,88822-Dec-200801:54IA-64

Estado


Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información


Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:
824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft