Iniciar sesión con Microsoft
Iniciar sesión o crear una cuenta
Hola:
Seleccione una cuenta diferente.
Tiene varias cuentas
Elija la cuenta con la que desea iniciar sesión.

Síntomas

Imagine el siguiente escenario:

  • El rol de Hyper-V está habilitado en un sistema basado en Windows Server 2008.

  • El idioma de entrada predeterminado en el equipo se establece en alemán.

  • Una máquina virtual Linux está instalada en este equipo.

En este escenario, la tecla AltGr no funciona en el equipo virtual Linux. Como resultado, no puede escribir los caracteres siguientes:

  • ²

  • ³

  • {

  • [

  • ]

  • }

  • \

  • @

  • μ

  • ~

Nota: La tecla AltGr es la tecla ALT en el teclado alemán.

Causa

Sistemas Windows utilizan el código de detección CTRL izquierdo junto con el código de detección ALT derecha para indicar que la tecla AltGr en un teclado alemán. Sin embargo, el equipo virtual Linux espera recibir sólo el código de detección ALT derecha. Cuando Windows envía la tecla CTRL izquierda analizar código junto con el código de detección ALT derecha, la máquina virtual de Linux no interpreta estos códigos de análisis como la tecla AltGr.

Solución

Información de Service Pack

Para resolver este problema, obtenga el service pack más reciente para Windows Server 2008. Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:

968849 cómo obtener el service pack más reciente para Windows Server 2008

Información de hotfix

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Revisiones importantes de Windows Vista y Windows Server 2008 se incluyen en los mismos paquetes. Sin embargo, sólo uno de estos productos puede aparecer en la página "Solicitud de revisión". Para solicitar el paquete de revisiones que se aplica a Windows Vista y Windows Server 2008, seleccione el producto que aparece en la página.

Requisitos previos

Debe tener Windows Server 2008 con el rol de Hyper-V instalado para aplicar esta revisión.

Requisito de reinicio

Tendrá que reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de hotfix

Este hotfix no sustituye a otras revisiones.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o posterior) que figuran en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en la herramienta fecha y hora del Panel de Control.

Nota de información de archivo de Windows Server 2008


Los archivos MANIFEST (.manifest) y archivos MUM (.mum) instalados para cada entorno son
enumerados por separado
. MUM y los archivos de manifiesto y los archivos de catálogo (.cat) de seguridad asociados, son esenciales para el mantenimiento del estado del componente actualizado. Los archivos de catálogo de seguridad (atributos no enumerados) están firmados con una firma digital de Microsoft.

Windows Server 2008 X 64

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Vmwp.exe

6.0.6001.22366

3,524,608

02-Feb-2009

06:35

x64


Advertencia: pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o mediante cualquier otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar que estos problemas puedan resolverse. Modifique el registro bajo su propio riesgo.
Para resolver el problema, siga estos pasos:

  1. Instale la revisión 963709.

  2. En la siguiente clave del registro, agregue una entrada del registro denominada "KeyboardWorkaroundEnabled", establezca el tipo REG_DWORDy, a continuación, establezca el valor en 1:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Virtualization\Worker

Nota: Después de instalar la revisión y, a continuación, crear la nueva entrada del registro, el sistema basado en Windows Server 2008 quita el código de detección CTRL izquierdo cuando va seguido de un código de detección ALT derecha. Sin embargo, esto puede afectar a intencionado CTRL IZQ + combinaciones de teclas ALT derecha. Para evitar este problema, mantenga presionada la tecla CTRL izquierda durante unos segundos antes de que se mantiene presionada la tecla ALT derecha.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se aplica a" de este artículo.

Más información

Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:

899474 el ALTGR y ALT+CTRL no funcionan en Virtual PC 2004 con el Service Pack 1

Información adicional de archivos para Windows Server 2008

Windows Server 2008 X 64 otros archivos

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Amd64_microsoft-hyper-v-vstack-vmwp_31bf3856ad364e35_6.0.6001.22366_none_91adec95316ef36f.manifest

No aplicable

192,587

02-Feb-2009

07:07

No aplicable

Package_for_kb963709_sc_0~31bf3856ad364e35~amd64~~6.0.1.0.mum

No aplicable

1.528

02-Feb-2009

14:02

No aplicable

Package_for_kb963709_sc~31bf3856ad364e35~amd64~~6.0.1.0.mum

No aplicable

1.430

02-Feb-2009

14:02

No aplicable

Package_for_kb963709_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mum

No aplicable

1,532

02-Feb-2009

14:02

No aplicable

Package_for_kb963709_server~31bf3856ad364e35~amd64~~6.0.1.0.mum

No aplicable

1,438

02-Feb-2009

14:02

No aplicable


Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

¿Necesita más ayuda?

¿Quiere más opciones?

Explore las ventajas de las suscripciones, examine los cursos de aprendizaje, aprenda a proteger su dispositivo y mucho más.

Las comunidades le ayudan a formular y responder preguntas, enviar comentarios y leer a expertos con conocimientos extensos.

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a su experiencia?
Si presiona Enviar, sus comentarios se usarán para mejorar los productos y servicios de Microsoft. El administrador de TI podrá recopilar estos datos. Declaración de privacidad.

¡Gracias por sus comentarios!

×