Agregar un cuadro de lista o un cuadro combinado

Se aplica a
Access para Microsoft 365 Access 2024 Access 2021 Access 2019 Access 2016

Al especificar datos en formularios en bases de datos de escritorio de Access, puede ser más rápido y fácil seleccionar un valor de una lista que recordar un valor para escribir. Una lista de opciones también ayuda a asegurarse de que el valor introducido en un campo es correcto. Un control de lista puede conectarse con datos existentes o puede mostrar valores fijos que se especifican cuando se crea el control. Siga leyendo para obtener información sobre los controles de lista disponibles para los formularios de Access y cómo crearlos y personalizarlos.

¿Qué desea hacer?

Más información sobre los tipos de controles de cuadros de lista

Access proporciona dos controles de lista para los formularios: el cuadro de lista y el cuadro combinado.

Cuadro de lista: El control de cuadro de lista muestra una lista de valores u opciones. El cuadro de lista contiene filas de datos y, por lo general, tiene un tamaño tal que varias filas están visibles en todo momento. Las filas pueden tener una o más columnas, que pueden aparecer con o sin títulos. Si la lista tiene más filas de las que puede mostrar el control, Access muestra una barra de desplazamiento en el control. Los usuarios están limitados a las opciones del cuadro de lista y no pueden escribir un valor en un cuadro de lista.

Cuadro de lista

Cuadro combinado: El control de cuadro combinado proporciona una forma más compacta de presentar una lista de opciones. La lista se oculta hasta que selecciona la flecha desplegable. Un cuadro combinado también le permite escribir un valor que no está en la lista. De esta forma, el control de cuadro combinado combina las características de un cuadro de texto y de un cuadro de lista.

Usar un cuadro combinado (lista desplegable)

  1. Seleccione la flecha para mostrar la lista desplegable.
  2. Seleccione una opción en la lista desplegable.

Los cuadros de lista y los cuadros combinados pueden ser controles enlazados o sin enlazar. Estos controles pueden buscar valores en una lista fija que usted mismo escribe o puede buscar valores en una tabla o consulta. Para crear un cuadro de lista dependiente o un cuadro combinado que busque valores en una tabla o consulta, asegúrese de que el formulario se basa en un origen de registros que incluye un campo de clave externa o campo de búsqueda. Esto hace posible crear las relaciones necesarias para vincular los datos del cuadro de lista o combinado a los datos del formulario.

Principio de página

Crear un cuadro de lista o un cuadro combinado con un asistente

  1. En el panel de navegación, haga clic con el botón secundario en el formulario y seleccione Vista Diseño.

    Nota

    En este procedimiento se asume que el formulario está enlazado a una tabla o consulta. Algunos de los pasos no se aplican si el formulario está desvinculado. Para determinar si el formulario está enlazado a una tabla o consulta, presione F4 para mostrar la hoja de propiedades. En la pestaña Datos de la hoja de propiedades, el cuadro de la propiedad Origen del registro muestra la tabla o la consulta a la que está enlazado el formulario.

  2. En la pestaña Diseño de formulario , en el grupo Controles , asegúrese de que la opción Usar asistentes de control esté seleccionada.

  3. Seleccione la herramienta Cuadro de lista o la herramienta Cuadro combinado .

  4. En el formulario, seleccione dónde quiere colocar el cuadro de lista o el cuadro combinado.

    • Dependiendo de su elección, se inicia el Asistente para cuadros de lista o el Asistente para cuadros combinados .
  5. Cuando el asistente le pregunte cómo quiere obtener los valores para el control, haga lo siguiente:

    • Si desea mostrar los datos actuales de un origen de registros, seleccione Quiero que el cuadro de lista o el cuadro combinado busquen los valores en una tabla o consulta.
    • Si desea mostrar una lista fija de valores que rara vez cambiarán, seleccione Escribiré los valores que quiero.
    • Si desea que el control realice una operación de búsqueda en lugar de servir como una herramienta de entrada de datos, seleccione Buscar un registro en el formulario según el valor que seleccioné en el cuadro de lista o cuadro combinado. Esto crea un control independiente con una macro incrustada que realiza una operación de búsqueda basada en el valor que escribe el usuario.
  6. Siga las instrucciones para especificar cómo aparecerán los valores.

  7. Si elige una de las dos primeras opciones en la primera página del asistente, el asistente le pregunta qué quiere que Access haga cuando usted selecciona un valor. Siga uno de estos procedimientos:

    • Para crear un control independiente, seleccione Recordar el valor para usarlo más adelante. Esto significa que Access mantendrá el valor seleccionado hasta que el usuario lo cambie o cierre el formulario, pero no escribirá el valor en una tabla.
    • Para crear un control dependiente, haga clic en Almacenar ese valor en este campo y, a continuación, seleccione el campo al que desea enlazar el control.
  8. Seleccione Siguiente y escriba una etiqueta para el control. Esta etiqueta aparece junto al control.

  9. Seleccione Finalizar.

Principio de página

Crear un cuadro de lista o un cuadro combinado al agregar un campo de búsqueda a un formulario

Puede crear un cuadro de lista o un cuadro combinado dependiente al agregar un campo de búsqueda a un formulario.

  1. Cree un campo de búsqueda en una tabla. El campo de búsqueda que cree puede ser multivalor o contener un solo valor. Para obtener más información sobre cómo crear campos de búsqueda multivalor, vea Crear o eliminar un campo multivalor.

  2. Siga uno de estos procedimientos:

    • Cree un formulario nuevo que se base en un origen del registro que incluya el campo de búsqueda. Por ejemplo, en el panel de navegación, seleccione una tabla o consulta que contenga el campo de búsqueda y, a continuación, en la pestaña Crear , en el grupo Formularios , seleccione Formulario. Access crea automáticamente un cuadro combinado para el campo de búsqueda.

    • Agregue un cuadro de lista o un cuadro combinado a un formulario:

      1. En la vista Diseño, abra un formulario que se base en un origen del registro que incluya el campo de búsqueda.

      2. Si no se muestra el panel Lista de campos , presione Alt+F8 para mostrarla.

      3. Haga doble clic en el campo de búsqueda o arrastre este campo desde el panel Lista de campos hasta el formulario. Access crea automáticamente un cuadro combinado enlazado al campo.

        Recomendación

        Para cambiar un cuadro combinado a un cuadro de lista, o al revés, haga clic con el botón secundario en el control, seleccione Cambiar a en el menú contextual y, a continuación, seleccione el tipo de control que desee.

Principio de página

Crear un cuadro de lista o un cuadro combinado sin usar un asistente

Si crea un cuadro de lista o un cuadro combinado sin usar un asistente, usted mismo establece muchas de las propiedades del control. Si desea obtener más información sobre una propiedad determinada, seleccione el cuadro de propiedades correspondiente y presione F1.

  1. Abra un formulario en la vista Diseño.

  2. En la pestaña Diseño de formulario , en el grupo Controles , asegúrese de que Usar asistentes de control no está seleccionado.

  3. Seleccione la herramienta Cuadro de lista o la herramienta Cuadro combinado .

  4. Seleccione una vez dentro del formulario para crear un control de tamaño predeterminado, o seleccione y arrastre hasta que el control alcance el tamaño que quiera.

  5. Con el control aún seleccionado, presione F4 para abrir su hoja de propiedades.

  6. Establezca las propiedades Tipo de origen de fila y Origen de fila mediante la tabla siguiente como guía.

    Para realizar esta acción Establezca la propiedad Tipo de origen de fila en Establezca la propiedad Origen de fila de la manera siguiente
    Mostrar valores de una tabla o consulta, o los resultados de una SQL instrucción Tabla/Consulta En la lista desplegable, seleccione la tabla o consulta que contiene los valores que desea que aparezcan en el cuadro de lista o en el cuadro combinado. O bien, escriba una SQL instrucción. O bien, en la pestaña Datos de la hoja de propiedades, seleccione el botón Crear para abrir el Generador de consultas. Para obtener más información sobre cómo crear una consulta, vea Crear una consulta de selección simple.
    Mostrar una lista fija de valores Lista de valores Escriba una lista de valores fijos separados por puntos y comas (;). Por ejemplo, North;South;East;West. O bien, en la pestaña Datos de la hoja de propiedades, seleccione el botón Crear para abrir el cuadro de diálogo Editar elementos de lista y, después, escriba los elementos en líneas independientes.
    Mostrar una lista de campos de una tabla o una consulta Lista de campos En la lista desplegable, seleccione la tabla o la consulta que contiene los nombres de campo que desea que aparezcan en el cuadro de lista o en el cuadro combinado.
  7. Si desea que aparezca más de una columna en el control, seleccione el cuadro de propiedad Recuento de columnas y escriba el número de columnas que desee. Configure la propiedad Ancho de columnas para ajustar el ancho de las columnas. Para obtener más información sobre cada propiedad, coloque el cursor en el cuadro de propiedades y, después, presione F1.

  8. Si desea que Access almacene el valor que seleccione, seleccione el cuadro de propiedad Origen del control y, a continuación, seleccione el campo al que desea enlazar el cuadro de lista o el cuadro combinado.

Principio de página

Personalizar un cuadro de lista o un cuadro combinado

Con el formulario abierto en la vista Diseño, asegúrese de que el cuadro de lista o el cuadro combinado está seleccionado y, después, presione F4 para abrir la hoja de propiedades del control. Luego, siga uno de estos procedimientos:

  • Cambie el criterio de ordenación en un cuadro de lista o cuadro combinado: Si ha usado un asistente para crear el cuadro de lista o el cuadro combinado, Access ordena automáticamente las filas que componen la lista por la primera columna visible. Si quiere especificar un criterio de ordenación diferente o si configuró la propiedad Origen de la fila del control en una consulta guardada, siga este procedimiento:

    • Seleccione la pestaña Datos y, a continuación, seleccione el cuadro de propiedad Origen de fila .
    • En la pestaña Datos de la hoja de propiedades, seleccione el botón Crear para abrir el Generador de consultas.
    • En la fila Ordenar de la columna que quiera ordenar, especifique el criterio de ordenación que quiera.
  • Enlazar una columna desde un cuadro de lista o un cuadro combinado: En el cuadro de propiedades Columna delimitada del cuadro de lista o cuadro combinado, especifique un número que corresponda a la ubicación de la columna en el cuadro de lista o cuadro combinado. Por ejemplo, escriba 1 para enlazar la primera columna del cuadro de lista o cuadro combinado al campo subyacente especificado en la propiedad Origen del control . Incluya las columnas ocultas en el recuento de las columnas. Si establece la propiedad Columna delimitada en 0, Access guarda el índice de la lista en lugar de un valor de una de las columnas. Esto es útil si quiere almacenar una secuencia de números en vez del valor de la lista.

  • Ocultar una columna en un cuadro de lista o un cuadro combinado de un formulario:

    • En el cuadro de propiedad Ancho de columna , escriba 0 la columna o columnas que desea ocultar. Por ejemplo, supongamos que tiene un cuadro combinado dependiente de dos columnas que tiene una columna SupplierID de 0,5 pulgadas de ancho y una columna SupplierName de 2 pulgadas de ancho. La columna IdDeProveedor es la primera columna de la lista, por lo que la propiedad Ancho de columna está establecida en 0.5";2". Para ocultar la columna IdDeProveedor, establezca la propiedad Ancho de columna en 0";2". La columna IdDeProveedor puede seguir siendo la columna dependiente aunque esté oculta.

      Nota

      En un cuadro combinado, cuando la lista no se muestra, la primera columna visible aparece en la parte del cuadro de texto del cuadro combinado. Por ejemplo, la columna NombreProveedor del ejemplo anterior aparecería porque la columna IdProveedor está oculta. Si la columna IdDeProveedor no estuviera oculta, se mostraría en lugar de la columna NombreDeProveedor.

  • Agregar encabezados de columna a un cuadro combinado en un formulario:

    • En el cuadro de propiedad Encabezados de columna , seleccione Sí para mostrar los encabezados de columna. Los encabezados de los cuadros combinados aparecen solo cuando la lista está abierta. Si el cuadro combinado o el cuadro de lista se basan en un origen del registro, Access usa los nombres de campo del origen del registro como los encabezados de columna. Si el cuadro combinado o el cuadro de lista se basa en una lista de valores fijos, Access usa los primeros n elementos de datos de la lista de valores (propiedad Origen de fila ) como encabezados de columna, donde n = el número establecido en la propiedad Recuento de columnas .
  • Desactive la característica de rellenar mientras escribe para un cuadro combinado en un formulario:

    • En el cuadro de propiedad Expandir automáticamente , seleccione No. Cuando la propiedad Expansión automática está establecida en No, debe seleccionar un valor de la lista o escribir el valor completo.
  • Establezca el ancho de la parte del cuadro de lista de un cuadro combinado en un formulario:

    • En el cuadro de propiedades Ancho de lista, escriba el ancho que desee utilizando la unidad de medida actual establecida en el Panel de control de Windows. Para usar otra unidad de medida que no sea la predeterminada, incluya un indicador de medida. Por ejemplo, escriba 2 cm. Asegúrese de dejar suficiente espacio para una barra de desplazamiento. La parte del cuadro de lista del cuadro combinado puede ser más ancha que la parte del cuadro de texto, pero no puede ser más estrecha. Con la configuración predeterminada (Auto), el cuadro de lista tiene el mismo ancho que la parte del cuadro de texto del cuadro combinado.
  • Establezca el número máximo de filas que se mostrarán en un cuadro combinado de un formulario:

    • En el cuadro de la propiedad Filas en lista, escriba un número. Si el número real de filas supera el número especificado en la propiedad Filas en lista, aparece una barra de desplazamiento vertical en el cuadro combinado.
  • Limitar las entradas de cuadro combinado a los elementos de la parte de lista de un cuadro combinado de un formulario:

    • En el cuadro de propiedad Limitar a la lista , seleccione Sí.

      Nota

      • Si la primera columna mostrada en un cuadro combinado no es la columna delimitada, Access limita las entradas a la lista incluso si la propiedad Limitar a lista está establecida en No.
      • Si la propiedad Limitar a la lista está establecida como No, cuando especifica una entrada que no está en la lista, si el cuadro combinado está enlazado, la entrada se almacena en el campo subyacente, pero no se agrega a la lista. Para agregar entradas nuevas a la lista, use la propiedad Al no estar en la lista y el evento No está en la lista.

Volver al principio