Introducción a los informes en Access

Se aplica a
Access para Microsoft 365 Access 2024 Access 2021 Access 2019 Access 2016

Los informes constituyen un modo de ver, formatear y resumir la información contenida en la base de datos de Microsoft Access. Por ejemplo, se puede crear un sencillo informe de números de teléfono de todos los contactos o un informe del total de ventas en distintas regiones y períodos de tiempo.

Obtendrá información general sobre los informes de Access en este artículo. También aprenderá los conceptos básicos de cómo crear un informe, usar opciones como ordenar, agrupar y resumir los datos, y cómo obtener una vista previa e imprimir el informe.

Información general sobre los informes en Access

¿Qué se puede hacer con un informe?

Un informe es un objeto de base de datos que resulta útil para presentar la información de la base de datos con alguno de los siguientes propósitos:

  • Mostrar o distribuir un resumen de los datos.
  • Archivar instantáneas de los datos.
  • Aportar detalles sobre un registro concreto.
  • Crear etiquetas.

Partes de un informe

Aunque puede crear informes "independientes" que no muestren datos, en este artículo se supone que un informe está enlazado a un origen de datos, como una tabla o consulta. El diseño de un informe se divide en secciones que se pueden ver en la vista Diseño. Comprender cómo funciona cada sección puede ayudarle a crear mejores informes. Por ejemplo, la sección en la que eligió colocar un control calculado determina cómo calcula Access los resultados. En la lista siguiente se resumen los tipos de sección y sus usos:

Sección Cómo se muestra la sección al imprimirse Dónde se puede usar la sección
Encabezado del informe Al inicio del informe. El encabezado del informe se usa para ofrecer información que normalmente aparecería en una página de portada, como un logotipo o un título y una fecha. Cuando se coloca un control calculado que usa la función de agregado de suma en el encabezado del informe, el resultado de la suma se calcula para todo el informe. El encabezado del informe se imprime antes del encabezado de página.
Encabezado de página Al principio de cada página. El encabezado de página se usa para repetir el título del informe en todas las páginas.
Encabezado de grupo Al inicio de cada grupo de registros nuevo. El encabezado de grupo se usa para imprimir el nombre del grupo. Por ejemplo, en un informe que se agrupa por producto, use el encabezado de grupo para imprimir el nombre del producto. Cuando se coloca un control calculado que usa la función de agregado de suma en el encabezado de grupo, la suma se calcula para el grupo actual. Puede tener varias secciones de encabezado de grupo en un informe, según el número de niveles de agrupación que agregue. Para más información sobre cómo crear encabezados o pies de página de grupo, vea la sección Agregar agrupaciones, ordenaciones o totales.
Detalle Aparece una vez por cada fila del origen de registros. Aquí se colocan los controles que constituyen el cuerpo principal del informe.
Pie del grupo Al final de cada grupo de registros. El pie de grupo se usa para imprimir información de resumen de un grupo. Puede tener varias secciones de pie de grupo en un informe, según el número de niveles de agrupación que agregue.
Pie de página Al final de cada página. El pie de página se usa para imprimir números de página o información sobre cada página.
Pie del informe Al final del informe.
Nota: En la vista Diseño, el pie de página del informe aparece debajo del pie de página. Sin embargo, en las demás vistas (la vista Presentación, por ejemplo, o cuando el informe se imprime o se obtiene una vista previa del mismo) el pie de informe aparece encima del pie de página, inmediatamente después del último pie de grupo o línea de detalle en la última página.
El pie de informe se usa para imprimir totales de los informes u otra información de resumen de todo el informe.

Descubrirá que es mucho más fácil crear informes significativos cuando la base de datos tiene una estructura de tablas y relaciones bien diseñadas. Para ver una introducción a la preparación y diseño de una base de datos, vea el artículo Conceptos básicos del diseño de una base de datos .

Crear un informe en Access

Puede crear informes para la base de datos de escritorio de Access siguiendo los pasos de esta sección.

Paso 1: Elegir un origen de registros

El origen de registros de un informe puede ser una tabla, una consulta con nombre o una consulta incrustada. El origen del registro debe contener todas las filas y columnas de datos que desea mostrar en el informe.

  • Si los datos proceden de una tabla o consulta existente, selecciónela en el panel de navegación y, luego, continúe con el paso 2.

  • Si el origen del registro aún no existe, siga uno de estos procedimientos:

    • Continúe con el paso 2 y use la herramienta Informe en blanco , o
    • Cree la tabla o consulta que contiene los datos necesarios. Seleccione la tabla o consulta en el panel de navegación y continúe con el paso 2.

Paso 2: Elegir una herramienta de informe

Busque las herramientas de informe en la pestaña Crear de la cinta de opciones, en el grupo Informes . En la siguiente tabla se describen las opciones:

Herramienta Descripción
Informe Crea un informe sencillo y tabular que contiene todos los campos en el origen de registros seleccionado en el panel de navegación.
Diseño de informe Abre un informe en blanco en vista Diseño, en el que se pueden agregar los campos y controles necesarios.
Informe en blanco Abre un informe en blanco en la vista Presentación y muestra la lista de campos desde la que se pueden agregar campos al informe.
Asistente para informes Muestra un asistente de varios pasos que le permite especificar campos, niveles de agrupación y ordenación, y opciones de diseño.
Etiquetas Muestra un asistente que permite seleccionar tamaños de etiqueta personalizados o estándar, así como los campos que se van a mostrar y la forma en que se van a almacenar.

Paso 3: Crear el informe

  1. Seleccione el botón de la herramienta que quiere usar. Si se muestra un asistente, siga los pasos del asistente y seleccione Finalizar en la última página. Access muestra el informe en la vista Presentación.

  2. Dé formato al informe para conseguir el aspecto que prefiera:

    • Cambie el tamaño de los campos y las etiquetas seleccionándolos y arrastrando los bordes hasta que alcancen el tamaño que quiera.
    • Para mover un campo, selecciónelo (así como su etiqueta, si está presente) y, a continuación, arrástrelo a la nueva ubicación.
    • Haga clic con el botón secundario en un campo y use los comandos del menú contextual para combinar o dividir celdas, eliminar o seleccionar campos, así como para realizar otras tareas de formato.
      Además, use las características descritas en las secciones siguientes para que el informe sea más atractivo y legible.

Nota

A partir de Access para Microsoft 365 versión 2609 (compilación 16.0.20430.20146), un informe puede tener hasta 2000 pulgadas (5,080 cm) de ancho y cada sección del informe puede tener hasta 2,000 pulgadas de alto. La altura combinada de todas las secciones y encabezados de sección puede ser de hasta 2,100 pulgadas (5,334 cm). Las versiones anteriores de Access conservan los límites anteriores de 22,75 pulgadas (57,79 cm) para el ancho del informe y la altura de la sección individual, y 200 pulgadas (508 cm) para la altura combinada de la sección. Es posible que los informes que usan las dimensiones más grandes no sean compatibles con versiones anteriores, por lo que deberá verificar las versiones de Access que usan todos los usuarios que abren la base de datos.

Aumentar el área de diseño del informe no aumenta el área imprimible del tamaño de papel seleccionado. Use las opciones de vista previa de impresión y configuración de página para confirmar cómo se dividirá el informe en las páginas. Para obtener más información, vea Vista previa e impresión de un informe.

Agregar agrupaciones, ordenaciones o totales

La forma más rápida de agregar agrupaciones, ordenación o totales a un informe de base de datos de escritorio es hacer clic con el botón derecho en el campo donde desea aplicar el grupo, la ordenación o el total y, después, seleccionar el comando que desee en el menú contextual.

También puede agregar agrupaciones, ordenación o totales mediante el panel Agrupación, orden y total mientras el informe está abierto en las vistas Presentación o Diseño:

  1. Si el panel Agrupación, orden y total no está abierto, en la pestaña Diseño de informe , en el grupo Agrupación y totales, seleccione Agrupar &ordenar.
  2. Seleccione Agregar un grupo o Agregar un orden y, a continuación, elija el campo donde desea agrupar u ordenar.
  3. Seleccione Más en una línea de agrupación u ordenación para establecer más opciones y agregar totales.

Para obtener información más detallada sobre agrupación, ordenación y totales, vea Crear un informe agrupado o un informe de resumen.

Resaltar datos con formato condicional

Access incluye herramientas para resaltar los datos en un informe. Puede agregar reglas de formato condicional para cada control o grupo de controles y, en los informes de cliente, también puede agregar barras de datos para comparar los datos.

Para agregar formato condicional a los controles:

  1. Haga clic con el botón secundario en el informe en el panel de navegación y, después, haga clic en Vista Presentación .

  2. Seleccione los controles que quiera. En la pestaña Formato, en el grupo Formato del control, haga clic en Formato condicional.

    Recomendación

    Para seleccionar varios controles, mantenga presionada la tecla CTRL y haga clic en los que desee.

  3. En el cuadro de diálogo Administrador de reglas de formato condicionales, haga clic en Nueva regla.

  4. En el cuadro de diálogo Nueva regla de formato, seleccione un valor en Seleccionar un tipo de regla:

    • Para crear una regla que evalúe cada registro individualmente, seleccione Comprobar valores del registro actual o use una expresión.
    • Para crear una regla que compare registros entre sí mediante barras de datos, haga clic en Compare con otros registros.
  5. En Editar la descripción de la regla, especifique la regla para cuándo se aplica el formato y qué formato aplicar y, a continuación, haga clic en Aceptar.

  6. Para crear una regla más para el mismo control o conjunto de controles, repita el proceso desde el paso 4.

Personalizar el color y las fuentes

Pruebe una opción de tema de aplicación para personalizar el color y las fuentes.

  1. Abra un informe en la vista Presentación, haciendo clic con el botón derecho en él en el panel de navegación y, después, haciendo clic en Vista Presentación.
  2. En la pestaña Diseño de presentación de informe , haga clic en Temas y coloque el cursor sobre los distintos temas de la galería para obtener una vista previa de los efectos. Haga clic en un tema para seleccionarlo y guardar el informe.
  3. Use las galerías Colores o Fuentes para establecer colores o fuentes de forma independiente.

Agregar un logotipo o una imagen de fondo

Puede agregar un logotipo o una imagen de fondo a un informe. Si actualiza la imagen, Access actualiza automáticamente la imagen dondequiera que se use en la base de datos.

Para agregar o quitar una imagen de logotipo:

  1. En el panel de navegación, haga clic con el botón secundario en el informe y, a continuación, haga clic en Vista Presentación.
  2. En el informe, haga clic en la posición donde desea agregar la imagen. En la pestaña Diseño de presentación de informe , en el grupo Encabezado o pie de página , haga clic en Logotipo.
  3. Vaya a la imagen y, a continuación, haga clic en Abrir. Access la agregará al informe.
  4. Para quitar la imagen, haga clic con el botón secundario en la imagen y, a continuación, haga clic en Eliminar en el menú contextual.

Para agregar una imagen de fondo:

  1. En el panel de navegación, haga clic con el botón secundario en el informe y, a continuación, haga clic en Vista Presentación.
  2. En el grupo Fondo de la pestaña Formato, haga clic en Imagen de fondo.
  3. Seleccione una imagen de la lista Galería de imágenes o haga clic en Examinar, seleccione una imagen y, a continuación, haga clic en Aceptar.

Obtener una vista previa e imprimir un informe

Obtener una vista previa de un informe

  1. Haga clic con el botón derecho en el informe en el panel de navegación y seleccione Vista previa de impresión. Use los comandos de la pestaña Vista previa de impresión para:

    • Imprimir el informe
    • Ajustar el diseño o tamaño de la página
    • Acercar, alejar o ver varias páginas a la vez
    • Actualizar los datos del informe
    • Exportar el informe a otro formato de archivo
  2. Seleccione Cerrar vista previa de impresión.

Para imprimir un informe sin visualizarlo en la vista previa:

  • Haga clic con el botón derecho en el informe en el panel de navegación y seleccione Imprimir. El informe se envía a la impresora predeterminada.

    Nota

    Si selecciona el informe en el panel de navegación y selecciona Imprimir en la pestaña Archivo , puede seleccionar más opciones de impresión como el número de páginas y copias, y especificar una impresora.

    • Para abrir un cuadro de diálogo en el que pueda seleccionar una impresora, especificar el número de copias y mucho más, seleccione Imprimir.