¿Qué es la ventana Relaciones?

Se aplica a
Access para Microsoft 365 Access 2024 Access 2021 Access 2019 Access 2016

La ventana Relaciones permite definir la relación entre los elementos almacenados en varias tablas de Access. Está disponible haciendo clic en Relacionesde herramientas >de base de datos.

Botón Relaciones de la pestaña Herramientas de base de datos

Las relaciones son como las reglas que rigen cómo se conectan los datos en la base de datos. En una base de datos de procesamiento de pedidos bien normalizada, por ejemplo, lo más probable es que tenga información de clientes en una tabla e información de pedidos en otra tabla. Quieres asegurarte de que los clientes no se separen de sus pedidos, ¿verdad? Y no quieres que se cree una orden que no tenga un cliente válido conectado. La ventana Relaciones es donde debe establecer estas reglas para que se apliquen a toda la base de datos.

Si ha creado una consulta de Access antes, observará que la ventana Relaciones se parece mucho a la parte superior del Generador de consultas:

Ventana Relaciones personales de Access

En la ventana Relaciones, puede usar los comandos de la pestaña Diseño para agregar tablas a la vista y, a continuación, arrastrar los campos entre tablas para configurar las relaciones. En este ejemplo, la relación permite que se conecten varios pedidos a cada cliente, pero evita que se cree un pedido para un cliente que no existe. Una vez configuradas estas reglas en la ventana Relaciones, se aplicarán a toda la base de datos (por ejemplo, si crea una consulta, las combinaciones se configurarán automáticamente según las reglas de relación).

Nota

Al eliminar una tabla desde la ventana Relaciones, no se eliminará de la base de datos ni se quitarán las relaciones que ya haya establecido.

Cosas que puedes hacer

Tarea Cómo se hace
Agregar una tabla o consulta a la ventana Haga clic en Diseño>Agregar tablas (Mostrar tabla en Access), seleccione la tabla o consulta que desee y, a continuación, haga clic en Agregar.
Eliminar una tabla o consulta de la ventana Seleccione la tabla o consulta y, a continuación, presione SUPRIMIR.
Ocultar una tabla o consulta Haga clic con el botón derecho en la tabla o consulta y, después, haga clic en Ocultar tabla.
Crear una relación Arrastre un campo de una tabla o consulta al campo correspondiente de la otra tabla o consulta.
Establecer las propiedades de una relación Haga clic con el botón derecho en la línea de relación entre dos tablas (esto puede requerir varios intentos para acertar exactamente con ellos) y, a continuación, haga clic en Editar relación.
Eliminar una relación Haga clic con el botón derecho en la línea de relación entre dos tablas (esto puede requerir varios intentos para acertar exactamente) y luego haga clic en Eliminar.
Mostrar todas las relaciones Haga clic en Diseñar>todas las relaciones.
Ver las relaciones de una tabla en particular Seleccione la tabla y haga clic en Diseñar>relaciones directas.
Ver las relaciones de una tabla sin ver las relaciones de otras tablas Haga clic enHerramientas>de diseño>Borrar diseño. Agregue la tabla para la que quiera ver las relaciones (Relaciones de>diseño>Agregue tablas (Mostrar tabla en Access) y haga clic enRelaciones>de diseño>relaciones directas.
Ajustar el tamaño de una tabla para mostrar campos y relaciones adicionales.
Nota Requiere Access para Microsoft 365.
Para cambiar el tamaño de la tabla automáticamente, haga clic con el botón derecho en una tabla y seleccione Ajustar tamaño. O bien, haga doble clic en el borde de una tabla en:
  • Derecha para ajustar el tamaño horizontalmente en función de la longitud del nombre de campo.
  • Ajustar verticalmente el tamaño vertical en función del número de campos.
  • Esquina inferior derecha para ajustar automáticamente el tamaño de la tabla, tanto horizontal como verticalmente (el equivalente a Ajustar tamaño).
Seleccionar un subconjunto de tablas
Nota Requiere Access para Microsoft 365.
Para ayudarle a centrarse en determinadas tablas y sus relaciones:

  • CTRL + (seleccionar varias tablas).
  • Haga clic y arrastre un cuadro completamente alrededor del rango seleccionado.
Ambas acciones resaltan el subconjunto de tablas con un borde más grueso. Para anular la selección, haga clic fuera de la selección. Para mover la selección, haga clic y arrastre a otra ubicación.
Usar la rueda de desplazamiento del mouse
Nota Requiere Access para Microsoft 365.
Desplácese verticalmente desplazando la rueda del mouse hacia arriba o hacia abajo. Desplácese horizontalmente presionando Mayús y, a continuación, desplazándose hacia arriba o hacia abajo con la rueda del mouse.

Ahora que está al día con la ventana Relaciones, obtenga información sobre cómo crear, editar o eliminar una relación.