El Comprobador de compatibilidad encontró uno o varios problemas de compatibilidad relacionados con las tablas dinámicas.
Importante
Antes de guardar el libro en un formato de archivo anterior, debe ocuparse de los problemas que provocan una pérdida significativa de funcionalidad para evitar la pérdida permanente de datos o una funcionalidad incorrecta.
Es posible que haya problemas que causan una pérdida menor de fidelidad que deban resolverse o no antes de guardar el libro. No se perderán datos ni funcionalidad, pero es probable que el libro no tenga el mismo aspecto al abrirlo con una versión anterior de Microsoft Excel o no funcione exactamente de la misma forma.
En este artículo...
- Problemas que provocan pérdidas de funcionalidad importantes
- Problemas que producen una pérdida menor de fidelidad
Problemas que provocan pérdidas de funcionalidad importantes
| Problema | Solución |
|---|---|
| Una tabla dinámica de este libro supera los límites anteriores y se perderá si se guarda en un formato de archivo anterior. Solo las tablas dinámicas creadas en el modo de compatibilidad funcionarán en versiones anteriores de Excel. |
Qué significa En Excel 2007 y versiones posteriores, una tabla dinámica admite 1.048.576 elementos únicos por campo, pero en Excel 97-2003, solo se admiten 32.500 elementos por campo. Solución En el Comprobador de compatibilidad, haga clic en Buscar para buscar la tabla dinámica que supere los límites anteriores. Guarde el libro en formato Excel 97-2003 y, después, vuelva a crear esta tabla dinámica en modo de compatibilidad. |
| Una tabla dinámica de este libro contiene reglas de formato condicional que se aplican a las celdas en filas o columnas contraídas. Para evitar perder estas reglas en versiones anteriores de Excel, expanda las filas o columnas. |
Qué significa Las reglas de formato condicional que se aplican a las celdas de filas o columnas contraídas se pierden en Excel 97-2003. Qué hacer En el Comprobador de compatibilidad, haga clic en Buscar para localizar las filas o columnas contraídas que contienen reglas de formato condicional y, a continuación, expanda dichas filas o columnas antes de guardar el libro en un formato de archivo de una versión anterior de Excel. |
| Este libro contiene conjuntos con nombre que no están asociados a una tabla dinámica. Estos conjuntos con nombre no se guardarán. |
Qué significa Los conjuntos con nombre que no están asociados a una tabla dinámica se quitarán en Excel 97-2007. Qué hacer Para evitar este problema, asegúrese de crear una tabla dinámica mediante una conexión. |
| Una tabla dinámica de este libro tiene activado el análisis de hipótesis. Los cambios de hipótesis no publicados se perderán en las versiones anteriores de Excel. |
Qué significa Los cambios de hipótesis que no se publican en el servidor no se muestran en la versión anterior de Excel. Solución Asegúrese de publicar los cambios de análisis de hipótesis antes de abrir el libro en una versión anterior de Excel (Herramientas de tabla dinámica, pestaña Analizar , grupo Cálculos , botón Herramientas OLAP , análisis de hipótesis). |
| Una tabla dinámica de este libro contiene un eje de datos en el que aparece más de una vez la misma medida. Esta tabla dinámica no se guardará. |
Qué significa En Excel 2010 y versiones posteriores, puede duplicar una medida en una tabla dinámica conectada a un origen de datos de procesamiento analítico en línea (OLAP). La tabla dinámica no se puede mostrar en Excel 97-2007. Solución En el Comprobador de compatibilidad, haga clic en Buscar para buscar la tabla dinámica que contiene un eje de datos en el que aparece más de una medida de la misma medida y, a continuación, quite las medidas duplicadas para que solo quede una. |
| Una tabla dinámica o una conexión de datos de este libro contiene una configuración de servidor que no existe en versiones anteriores de Excel. Parte de la configuración de servidor de la tabla dinámica o la conexión de datos no se guardará. |
Qué significa Se perderán algunas opciones de configuración del servidor de conexión de datos o de tablas dinámicas que no estaban disponibles en Excel 97-2007. Solución Compruebe que la configuración del servidor que usa es compatible con versiones anteriores de Excel y, a continuación, realice los cambios necesarios (Herramientas de tabla dinámica, pestaña Analizar , grupo Datos , botón Cambiar origen de datos , comando Propiedades de conexión ). |
| Una tabla dinámica de este libro contiene datos representados mediante la característica 'Mostrar valores como'. Estas salidas personalizadas no se guardarán y se reemplazarán por los valores originales del origen de datos. |
Qué significa La característica Mostrar valores como no se admite en Excel 97-2007 y no se pueden mostrar los datos de valores personalizados especificados (como % del total de filas principales, % del total de columnas principales o % del total acumulado en). Solución En el Comprobador de compatibilidad, haga clic en Buscar para buscar las tablas dinámicas que contienen salidas de valores personalizados y, a continuación, quite esas salidas (haga clic con el botón derecho en el campo, haga clic en Mostrar valores como, sin cálculo). |
| Este libro contiene datos personalizados integrados. Estos datos no se guardarán. |
Qué significa Los datos personalizados incrustados, como los datos de Power Pivot, no se admiten en Excel 97-2007. Los datos se perderán. Solución Quite los datos de Power Pivot de un libro en el que tenga previsto trabajar en una versión anterior de Excel. |
| Este libro contiene segmentaciones de datos que pueden usarse para filtrar tablas dinámicas y funciones de cubo dentro del libro. Las segmentaciones de datos no funcionarán en versiones anteriores de Excel. |
Qué significa Las segmentaciones no estarán disponibles en Excel 97-2007, pero seguirán estando disponibles para su uso en Excel 2010 o versiones posteriores. Qué hacer En la versión anterior de Excel, puede usar filtros de tabla dinámica para filtrar datos. |
| Este libro contiene segmentaciones de datos que pueden usarse para filtrar tablas dinámicas y funciones de cubo dentro del libro. Las segmentaciones no se guardarán. Las fórmulas que hacen referencia a segmentaciones devolverán un #NAME? error. |
Qué significa Las segmentaciones no son compatibles con versiones anteriores de Excel. No se pueden mostrar y se perderán. Actualizar las conexiones con funciones OLAP que hacen referencia a las segmentaciones de datos genera errores de tipo '#¿NOMBRE?' en lugar de los resultados esperados. Qué hacer Use filtros de tabla dinámica en lugar de segmentaciones de datos para filtrar los datos. |
Problemas que producen una pérdida menor de fidelidad
| Problema | Solución |
|---|---|
| En este libro, se aplica un estilo de Tabla dinámica a una tabla dinámica. El formato de estilo de tabla dinámica no se puede mostrar en versiones anteriores de Excel. |
Qué significa Los estilos de tabla dinámica basados en un tema no están disponibles en las versiones de Excel 97-2003 y no se pueden mostrar. Solución En el Comprobador de compatibilidad, haga clic en Buscar para buscar la tabla dinámica que tiene aplicado un estilo de tabla dinámica, quite ese estilo de tabla dinámica y, después, aplique manualmente el formato de tabla dinámica compatible con las versiones anteriores de Excel. |
| Una tabla dinámica de este libro no funcionará con las versiones anteriores a Excel 2007. Solo las tablas dinámicas creadas en el modo de compatibilidad funcionarán con las versiones anteriores de Excel. |
Qué significa Una tabla dinámica que cree en Excel 2007 o posterior no se puede actualizar en Excel 97-2003. Solución En el Comprobador de compatibilidad, haga clic en Buscar para buscar la tabla dinámica creada en el formato de archivo actual. Guarde el libro en formato Excel 97-2003 y, después, vuelva a crear esta tabla dinámica en el Modo de compatibilidad para que pueda abrirla en Excel 97-2003 sin perder la funcionalidad. |
| Una tabla dinámica de este libro tiene campos en forma compacta. En versiones anteriores de Excel, este diseño se cambiará a formato tabular. |
Qué significa La forma compacta (sola o en combinación con los formatos tabular y de esquema), que se usa para evitar que los datos relacionados se salgan en sentido horizontal de la pantalla y para minimizar la necesidad de desplazarse, no está disponible en las versiones de Excel 97-2003. Los campos se mostrarán en formato tabular. Solución En el Comprobador de compatibilidad, haga clic en Buscar para buscar la tabla dinámica que tiene campos en un formato compacto y, después, cambie ese formato a formato de esquema o tabular según sea necesario desactivando la casilla Combinar y centrar celdas con etiquetas (Herramientas de tabla dinámica, pestaña analizar , grupo Tabla dinámica , comando Opciones , pestaña Diseño & formato ). |
| Una tabla dinámica de este libro contiene configuraciones que no existen en versiones anteriores de Excel. Algunas configuraciones de tabla dinámica no se guardarán. |
Qué significa Algunas opciones de configuración de tablas dinámicas no se admiten en Excel 97-2007. Esta configuración se perderá. Solución En el Comprobador de compatibilidad, haga clic en Buscar para buscar la tabla dinámica que contiene las configuraciones que no son compatibles y, a continuación, realice los cambios necesarios. |
| Determinados botones de campo de un gráfico dinámico de este libro se encuentran habilitados o deshabilitados. Todos los botones de campo se guardarán como habilitados. |
Qué significa Cuando el libro se abre y se guarda en una versión anterior de Excel, los botones de campo que no se muestran en un gráfico dinámico se guardan como habilitados. Solución Cuando vuelve a abrir un libro después de guardarlo en un formato de archivo de una versión anterior de Excel, es posible que tenga que habilitar y deshabilitar los botones de campo para mostrar los que desee (Herramientas de gráfico dinámico, pestaña Analizar , grupo Mostrar u ocultar, botón Botones decampo ). |
| Una tabla dinámica de este libro contiene uno o más conjuntos con nombre. Es posible que algunas propiedades de los conjuntos con nombre no se guarden. |
Qué significa Uno o más conjuntos con nombre tienen una configuración de propiedad no predeterminada que puede que no se guarde al guardar el libro en el formato de archivo de Excel 97-2003. Solución En el Comprobador de compatibilidad, haga clic en Buscar para buscar la tabla dinámica que contiene las propiedades del conjunto con nombre que se han cambiado y, a continuación, realice los ajustes necesarios en el cuadro de diálogo Configuración de campo . Haga clic con el botón derecho en cualquier miembro del conjunto con nombre y, a continuación, haga clic en Configuración de campo. En la pestaña Diseño & impresión , asegúrese de que la casilla Mostrar elementos de diferentes niveles en campos independientes no esté activada (la configuración predeterminada) y que la casilla de verificación Ordenar y quitar duplicados automáticamente del conjunto esté seleccionada (la configuración predeterminada). |
| Una conexión en este libro contiene uno o más conjuntos con nombre o miembros calculados. Es posible que algunas propiedades de los conjuntos con nombre o miembros calculados no se guarden. |
Qué significa Los conjuntos con nombre o los miembros calculados tienen propiedades que no se admiten en Excel 2007 ni Excel 97-2003. Estas propiedades no se pueden guardar. Solución Haga clic con el botón derecho en cualquier miembro de los conjuntos con nombre y, a continuación, haga clic en Configuración de campo o Configuración de campo de valor y, a continuación, realice los ajustes necesarios. |
| Existe un estilo de segmentación de datos en este libro que no es compatible con versiones anteriores de Excel. Este estilo de segmentación de datos no se guardará. |
Qué significa Un estilo de segmentación de datos personalizado se perderá cuando el libro se guarde en un formato de archivo de una versión anterior de Excel. Solución Dado que las segmentaciones no son compatibles con versiones anteriores de Excel, no hay nada que pueda hacer para conservar un estilo de segmentación personalizado. En la versión anterior de Excel, puede usar filtros de tabla dinámica para filtrar los datos. |
| Una tabla dinámica de este libro contiene uno o varios campos con etiquetas repetidas. Si se actualiza la tabla dinámica, estas etiquetas se perderán. |
Qué significa Las etiquetas repetidas no se admiten en Excel 97-2007 y se perderán al actualizar la tabla dinámica en la versión anterior de Excel. Qué hacer En el Comprobador de compatibilidad, haga clic en Buscar para localizar la tabla dinámica que contiene las etiquetas repetidas y, a continuación, detenga la repetición de etiquetas (Herramientas de tabla dinámica, pestaña Diseño, grupo Diseño, botón Diseño del informe, comando No repetir etiquetas de elementos). |
| En este libro, se aplica texto alternativo a una tabla dinámica. El texto alternativo en las tablas dinámicas se quitará en versiones anteriores a Excel 2007. |
Qué significa El texto alternativo no está disponible en Excel 97-2007 y no se puede mostrar en estas versiones anteriores de Excel. Solución En el Comprobador de compatibilidad, haga clic en Buscar para buscar la tabla dinámica que contiene texto alternativo. Para ver el texto alternativo en una versión de Excel anterior, copie el texto en una celda en blanco de la hoja de cálculo o bien, inserte un comentario que contenga el texto. Haga clic con el botón secundario en la tabla dinámica y seleccione Opciones de tabla dinámica. En la pestaña Texto alternativo , en el cuadro Descripción , seleccione el texto alternativo y, a continuación, presione Ctrl+C para copiarlo. |
| En este libro, se aplica texto alternativo a una tabla dinámica. El texto alternativo no se puede mostrar en Excel 2007. |
Qué significa El texto alternativo no está disponible en Excel 97-2007 y no se puede mostrar. Solución En el Comprobador de compatibilidad, haga clic en Buscar para buscar la tabla dinámica que contiene texto alternativo. Para ver el texto alternativo en una versión de Excel anterior, copie el texto en una celda en blanco de la hoja de cálculo o bien, inserte un comentario que contenga el texto. Haga clic con el botón secundario en la tabla dinámica y seleccione Opciones de tabla dinámica. En la pestaña Texto alternativo , en el cuadro Descripción , seleccione el texto alternativo y, a continuación, presione Ctrl+C para copiarlo. |