Reducir el tamaño de archivo de las hojas de cálculo de Excel

Se aplica a
Excel para Microsoft 365 Excel 2024 Excel 2021 Excel 2019 Excel 2016

Si el tamaño de archivo de la hoja de cálculo es demasiado grande, pruebe los siguientes consejos para hacerla más manejable.

 

Guardar la hoja de cálculo en formato binario (.xslb)

Puede reducir el tamaño del archivo guardando la hoja de cálculo como un libro binario (.xslb) en lugar del formato predeterminado (.xslx). El formato predeterminado está basado en XML, lo cual es importante si usa los datos con programas de terceros, ya que XML es un estándar abierto. Sin embargo, para la mayoría de los propósitos, el formato binario es suficiente y se guarda en un archivo más pequeño.

  1. Vaya a Opcionesde>archivo>guardar.

  2. En Guardar libros, en la lista Guardar archivos en este formato , seleccione Libro binario de Excel.

    Guardar en formato binario

Esta opción establece el formato binario como predeterminado. Si desea mantener el valor predeterminado de Libro de Excel (.xlsx) pero guardar el archivo actual como binario, seleccione la opción en el cuadro de diálogo Guardar como. 

Nota

Si el archivo se encuentra en una biblioteca de SharePoint, es posible que no vea la opción Guardar como. Si este es el caso, puede guardar una copia en la unidad local, guardarla como un archivo binario y, a continuación, reemplazar el archivo original por el nuevo binario.

  1. Vaya a Guardar archivo>como y, si es la primera vez que guarda el archivo, seleccione una ubicación.

  2. En la lista de tipos de archivo, seleccione Libro binario de Excel (*.xlsb).

    Guardar como libro binario de Excel

Reducir el número de hojas de cálculo

Si tiene hojas de cálculo con datos que no usa y que no contienen ninguna fórmula que esté usando, elimínelas de la hoja de cálculo. 

Cuantos más puntos de datos tenga en el libro, mayor será el tamaño del archivo. La eliminación de los datos no utilizados reducirá el tamaño del archivo.

Guardar imágenes con resoluciones más bajas

  1. Vaya a Archivo>Opciones>Avanzadas.

  2. En Tamaño y calidad de la imagen, haga lo siguiente:

    • Seleccione Descartar datos de edición. Esta opción quita los datos almacenados que se usan para restaurar la imagen a su estado original después de editarla. Tenga en cuenta que si descarta los datos de edición, no podrá restaurar la imagen.
    • Asegúrese de que no esté seleccionada la opción No comprimir imágenes en el archivo .
    • En la lista Resolución predeterminada , seleccione una resolución de 150ppp o inferior. En la mayoría de los casos, no es necesario que la resolución sea superior a esa resolución.

Opciones de tamaño y calidad de imagen

Comprimir imágenes

  1. Seleccione una imagen en el documento. La pestaña Formato de imagen aparecerá en la cinta de opciones.

  2. En la pestaña Formato de imagen , en el grupo Ajustar , seleccione Comprimir imágenes.

  3. En Opciones de compresión, haga lo siguiente:

    • Para comprimir todas las imágenes del archivo, desactive Aplicar solo a esta imagen. Si esta opción está seleccionada, los cambios que realice aquí solo afectarán a la imagen seleccionada.
    • Seleccione Eliminar las áreas recortadas de las imágenes. Esta opción quita los datos de imagen recortados, pero tenga en cuenta que no podrá restaurarlos.
  4. En Resolución, haga lo siguiente:

    • Seleccione Usar resolución predeterminada.

      Opciones de compresión de imágenes

No guarde la caché dinámica con el archivo

Si la hoja de cálculo contiene una tabla dinámica, puede reducir el tamaño del archivo si no guarda la caché de datos de origen de la tabla dinámica con el archivo y, en su lugar, la caché de datos se actualiza al abrir la hoja de cálculo.

  1. Seleccione cualquier celda de la tabla dinámica.

  2. En la pestaña Analizar tabla dinámica , en el grupo Tabla dinámica , seleccione Opciones.

  3. En el cuadro de diálogo Opciones de tabla dinámica , seleccione la pestaña Datos y haga lo siguiente:

    • Desmarque Guardar datos de origen con el archivo.

    • Seleccione Actualizar datos al abrir el archivo.

      Opciones de tabla dinámica para no guardar la caché dinámica

Consulte también

Reducir el tamaño de archivo de las presentaciones de PowerPoint

Reducir el tamaño de archivo de los documentos de Word