Trabajar con archivos de cubo sin conexión

Se aplica a
Excel para Microsoft 365 Excel 2024 Excel 2021 Excel 2019 Excel 2016

Un archivo de cubo sin conexión (.cub) almacena datos en forma de un cubo de procesamiento analítico en línea (OLAP). Estos datos pueden representar una parte de una base de datos OLAP de un servidor OLAP o pueden haberse creado independientemente de cualquier base de datos OLAP. Use un archivo de cubo sin conexión para seguir trabajando con informes de tablas dinámicas y gráficos dinámicos cuando el servidor no esté disponible o cuando esté desconectado de la red.

Nota

Tenga cuidado al usar o distribuir un archivo de cubo sin conexión que contenga información confidencial o privada. En lugar de un archivo de cubo, considere la posibilidad de mantener los datos en el libro para que pueda usar Rights Management para controlar el acceso a los datos. Para obtener más información, vea Information Rights Management en Office.

Más información sobre los cubos sin conexión

Al trabajar con un informe de tabla dinámica o gráfico dinámico que se basa en los datos de origen de un servidor OLAP, puede usar el Asistente para cubo sin conexión para copiar los datos de origen en un archivo de cubo sin conexión independiente en el equipo. Para crear estos archivos sin conexión, debe tener instalado en su equipo el proveedor de datos OLAP que admita esta funcionalidad, como MSOLAP de Microsoft SQL Server Analysis Services.

Nota

La creación y el uso de archivos de cubo sin conexión de Microsoft SQL Server Analysis Services están sujetos a los términos y licencias de la instalación de Microsoft SQL Server. Consulte la información de licencia correspondiente de su versión de SQL Server.

Uso del asistente de cubo sin conexión

Para crear el archivo de cubo sin conexión, use el Asistente para cubos sin conexión para seleccionar un subconjunto de los datos de la base de datos OLAP y guardar ese subconjunto a continuación. No es necesario que el informe incluya todos los campos que incluya en el archivo, y puede seleccionar entre cualquiera de los campos de dimensiones y datos que están disponibles en la base de datos OLAP. Para mantener el tamaño del archivo al mínimo, puede incluir solo los datos que desea mostrar en el informe. Puede omitir dimensiones enteras y, para la mayoría de los tipos de dimensiones, también puede omitir los detalles de nivel inferior y los elementos de nivel superior que no necesita mostrar. Para cualquier elemento que incluya, los campos de propiedades que están disponibles en la base de datos para esos elementos también se guardan en su archivo sin conexión.

Desconectar los datos y, a continuación, volver a ponerlos en línea

Para ello, primero cree un informe de tabla dinámica o gráfico dinámico basado en la base de datos del servidor y, a continuación, cree el archivo de cubo sin conexión a partir del informe. A continuación, puede cambiar el informe entre la base de datos del servidor y el archivo sin conexión cuando lo desee; Por ejemplo, cuando usa un equipo portátil para llevar el trabajo a casa o de viaje y, más tarde, vuelve a conectar el equipo a la red.

En el procedimiento siguiente se proporcionan los pasos básicos para desconectar los datos y, después, ponerlos de nuevo en línea.

  1. Cree o abra un informe de tabla dinámica o gráfico dinámico que se base en los datos OLAP a los que desea tener acceso sin conexión.
  2. Cree un archivo de cubo sin conexión en el equipo. Consulte la sección Creación de un archivo de cubo sin conexión a partir de una base de datos de servidor OLAP (a continuación, en este artículo).
  3. Desconéctese de la red y trabaje con el archivo de cubo sin conexión.
  4. Vuelva a conectarse a la red y vuelva a conectar el archivo de cubo de línea. Consulte la sección Reconexión de un archivo de cubo sin conexión a una base de datos de servidor OLAP (a continuación, en este artículo).
  5. Actualice el archivo de cubo sin conexión con nuevos datos y, a continuación, vuelva a crear el archivo de cubo sin conexión. Vea la sección Actualizar y volver a crear un archivo de cubo sin conexión (a continuación, en este artículo).
  6. Repita este procedimiento, empezando por el paso 3.

Crear un archivo de cubo sin conexión desde una base de datos de servidor OLAP

Nota

Si la base de datos OLAP es grande y desea que el archivo de cubo proporcione acceso a un subconjunto grande de datos, deberá proporcionar suficiente espacio en disco y descubrirá que guardar el archivo puede llevar mucho tiempo. Para mejorar el rendimiento, considere la posibilidad de crear el archivo de cubo sin conexión mediante un script MDX.

  1. Haga clic en el informe de tabla dinámica para el que desea crear un archivo de cubo sin conexión; también puede hacer clic en el informe de tabla dinámica asociado de un informe de gráfico dinámico.

  2. En la pestaña Analizar , en el grupo Cálculos , haga clic en Herramientas OLAP y, después, en OLAP sin conexión.
    Se muestra el cuadro de diálogo de configuración de OLAP sin conexión .

    Nota

    Si su proveedor OLAP no admite archivos de cubo sin conexión, el comando OLAP sin conexión no está disponible. Póngase en contacto con el proveedor de su proveedor OLAP para obtener más información.

  3. Haga clic en Crear archivo de datos sin conexión o, si ya existe un archivo de cubo sin conexión para el informe, haga clic en Editar archivo de datos sin conexión.
    Se muestra el Asistente para cubos sin conexión .

  4. En el paso 1 del asistente, haga clic en Siguiente.

  5. En el paso 2 del asistente, seleccione cada dimensión del cubo de servidor que tenga datos que desee incluir en el archivo de cubo sin conexión. Haga clic en el cuadro Más situado junto a cada una de estas dimensiones y seleccione los niveles que desea incluir.

    Nota

    • No puede omitir niveles intermedios dentro de una dimensión.
    • Para reducir el tamaño del archivo de cubo, omita los niveles inferiores que no es necesario ver en el informe.
    • Asegúrese de incluir las dimensiones en las que haya agrupado elementos, para que Microsoft Office Excel pueda mantener estas agrupaciones cuando cambie entre la base de datos del servidor y el archivo sin conexión.
    • Las dimensiones que no tienen un cuadro Más no le permiten excluir niveles. Solo puede incluir o excluir todo este tipo de dimensión.
  6. En el paso 3 del asistente, haga clic en el cuadro Más situado junto a Medidas y seleccione los campos que desee usar como campos de datos en el informe. Debe seleccionar al menos una medida; de lo contrario, las dimensiones asociadas a la medida no contendrán datos. Para cada dimensión enumerada en Medidas, haga clic en el cuadro Más situado junto a la dimensión y, a continuación, seleccione los elementos de nivel superior que desea incluir en el archivo de cubo sin conexión.

    • Para limitar el tamaño del archivo de cubo y no quedarse sin espacio en disco y para reducir la cantidad de tiempo necesario para guardar el archivo, seleccione solo los elementos que necesita ver en el informe. Todos los campos de propiedades que estén disponibles para los elementos que seleccione se incluirán automáticamente en el cubo.

    • Si faltan los elementos que desea incluir, es posible que no haya incluido la dimensión que los contiene en el paso anterior. Haga clic en Atrás en el asistente y seleccione la dimensión que falta en el paso 2, y luego vuelva al paso 3.

      Nota

      En el Asistente para cubos OLAP, las únicas funciones de resumen disponibles para los campos de datos son Suma, Contar, Mín. y Máx.

  7. En el paso 4 del asistente, escriba un nombre y una ubicación para el archivo .cub y, después, haga clic en Finalizar.
    Para cancelar el guardado del archivo, haga clic en Detener en el cuadro de diálogo Crear archivo de cubo – Progreso .

  8. Cuando Excel haya terminado de crear el archivo de cubo sin conexión, haga clic en Aceptar en el cuadro de diálogo Configuración OLAP sin conexión .

Problema: Mi equipo se quedó sin espacio en disco al guardar un cubo.

Las bases de datos OLAP están diseñadas para administrar grandes cantidades de datos detallados y, como resultado, la base de datos del servidor puede ocupar una cantidad de almacenamiento en disco mucho mayor que la que proporciona el disco duro local. Si especifica un subconjunto grande de estos datos para el archivo de cubo sin conexión, es posible que el disco duro se quede sin espacio. Las siguientes estrategias pueden ayudar a reducir el tamaño del archivo de cubo sin conexión.

Liberar espacio en disco o buscar otro disco elimine los archivos que no necesite del disco antes de guardar el archivo de cubo o guarde el archivo en una unidad de red.

Incluir menos datos en el archivo de cubo sin conexión Considere cómo puede minimizar la cantidad de datos en el archivo y seguir teniendo lo que necesita para su informe de tabla dinámica o gráfico dinámico. Pruebe lo siguiente:

  • Eliminar dimensiones En el paso 2 del Asistente para cubos sin conexión, seleccione solo las dimensiones que se muestran realmente como campos en el informe de tabla dinámica o gráfico dinámico.
  • Elimine los niveles de detalle Haga clic en la casilla Más situada junto a cada dimensión seleccionada en el paso 2 del asistente y, a continuación, desactive las casillas de los niveles inferiores a los que se muestran en el informe.
  • Eliminar campos de datos En el paso 3 del asistente, haga clic en el cuadro Más situado junto a Medidas y, después, seleccione solo los campos de datos que usa en el informe.
  • Eliminar elementos de datos Haga clic en la casilla Más situada junto a cada dimensión en el paso 3 y desactive las casillas de los elementos que no necesita ver en el informe.

Volver a conectar un archivo de cubo sin conexión a una base de datos de servidor OLAP

  1. Haga clic en el informe de tabla dinámica o en el informe de tabla dinámica asociado para obtener un informe de gráfico dinámico.
  2. En la pestaña Analizar , en el grupo Cálculos , haga clic en Herramientas OLAP y, después, en OLAP sin conexión.
  3. Haga clic en OLAP en línea y, a continuación, haga clic en Aceptar.
  4. Si se le solicita que busque el origen de datos, haga clic en Examinar para buscar el origen y, a continuación, localice el servidor OLAP en la red.

Actualizar y volver a crear un archivo de cubo sin conexión

La actualización de un archivo de cubo sin conexión, que lo vuelve a crear con los datos más recientes del cubo de servidor o del nuevo archivo de cubo sin conexión, puede ser un proceso que requiere mucho tiempo y mucho espacio en disco temporal. Inicie el proceso en un momento en el que no necesite acceso inmediato a otros archivos y asegúrese de que tiene espacio en disco suficiente para volver a guardar el archivo.

  1. Haga clic en el informe de tabla dinámica basado en el archivo de cubo sin conexión.
  2. En Excel 2016: En la pestaña Datos, en el grupo Consultas & conexiones, haga clic en la flecha situada junto a Actualizar todo y, a continuación, haga clic en Actualizar.

Problema: Los nuevos datos no aparecen en mi informe cuando lo actualizo.

Asegúrese de que la base de datos original está disponible Es posible que el archivo de cubo sin conexión no pueda conectarse con la base de datos del servidor original para recuperar nuevos datos. Compruebe que la base de datos del servidor original que proporcionó los datos para el cubo no ha cambiado de nombre ni se ha movido. Asegúrese de que el servidor está disponible y de que puede conectarse a él.

Asegúrese de que haya nuevos datos disponibles Consulte con el administrador de la base de datos para determinar si la base de datos se ha actualizado en las áreas incluidas en el informe.

Asegúrese de que la organización de la base de datos no ha cambiado Si se ha reconstruido un cubo de servidor OLAP, es posible que tenga que reorganizar el informe o crear un nuevo archivo de cubo sin conexión o un cubo del Asistente para cubo OLAP para tener acceso a los datos modificados. Póngase en contacto con el administrador de la base de datos para obtener información acerca de los cambios realizados en la base de datos.

Incluir datos diferentes en un archivo de cubo sin conexión

Guardar un archivo de cubo sin conexión revisado puede ser un proceso lento y no puede realizar otro trabajo en Excel mientras se guarda el archivo. Inicie el proceso en un momento en el que no necesite acceso inmediato a otros archivos y asegúrese de que tiene espacio en disco suficiente para volver a guardar el archivo.

  1. Asegúrese de estar conectado a la red y de que tiene acceso a la base de datos original del servidor OLAP que suministraba los datos para el archivo de cubo sin conexión.
  2. Haga clic en un informe de tabla dinámica basado en el archivo de cubo sin conexión o haga clic en el informe de tabla dinámica asociado para un informe de gráfico dinámico.
  3. En la pestaña Analizar , en el grupo Cálculos , haga clic en Herramientas OLAP y, después, en OLAP sin conexión.
  4. Haga clic en OLAP sin conexión y, a continuación, en Editar archivo de datos sin conexión.
  5. Siga los pasos del Asistente para cubos sin conexión para seleccionar diferentes datos para el archivo. En el último paso, especifique el mismo nombre y ubicación que el archivo existente que va a cambiar.

Nota

Para cancelar el guardado del archivo, haga clic en Detener en el cuadro de diálogo Crear archivo de cubo – Progreso .

Eliminar un archivo de cubo sin conexión

Advertencia

Si elimina el archivo de cubo sin conexión para un informe, ya no puede usar el informe sin conexión ni crear un nuevo archivo de cubo sin conexión para el informe.

  1. Cierre todos los libros que contengan informes que usen el archivo de cubo sin conexión o asegúrese de que se han eliminado todos esos informes.
  2. En Windows, busque y elimine el archivo de cubo sin conexión (.cub).

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community u obtener soporte técnico en Comunidades.