Dificultades al utilizar una unidad central de proceso AMD K6-2 o Athlon

Exención de responsabilidades de contenido KB retirado

Este artículo se refiere a productos para los que Microsoft ya no ofrece soporte técnico. Por tanto, el presente artículo se ofrece "tal cual" y no será actualizado.

Síntomas

Al iniciar un equipo basado en Windows 95 o en Windows 95 OEM Service Release con un procesador AMD K6/2 (a 350 MHZ o superior) o un procesador AMD Athlon (1.1GHz o superior), aparecerá alguno de los siguiente mensajes de error:
  • Error al inicializar IOS. Error de protección de Windows. Debe reiniciar su equipo.
  • Error de protección de Windows. Debe reiniciar su equipo.
  • Al inicializar el dispositivo IOS: Error de protección de Windows.
NOTA: este problema es muy intermitente en el procesador K6/2 a 350 MHz, pero ocurre con más frecuencia a velocidades superiores. Este problema también puede ocurrir al iniciar el equipo en Modo a prueba de errores.

Causa

El primer mensaje de error es un resultado de una excepción de división en Ios.vxd; el segundo es debido a un error similar dentro de Esdi_506.pdr o Scsiport.pdr.


Las versiones publicadas originales de los archivos enumerados en la sección "Resolución" de este artículo incluyen bucles de tiempos de inicialización que no se ejecutan correctamente en los procesadores indicados a velocidades de 350 MHz y superiores. Tenga en cuenta que este problema es debido a las limitaciones de los algoritmos de software y no quiere decir que exista un problema en el procesador, que funciona correctamente.

Solución

Se ha revisado la actualización AMD-K6-2 y se ha incluido en ella una versión más reciente del archivo Vfbackup.vxd. Para obtener información acerca de esta actualización, consulte el artículo siguiente en Microsoft Knowledge Base:
234259 Revision To AMD K6-2/350 Central Processing Unit Update
Existe una corrección que soluciona este problema en las versiones 2, 2.1 y 2.5 de Microsoft Windows 95 OEM Service Release y que se puede obtener de Microsoft, pero que no se ha probado completamente y sólo debe aplicarse en aquellos sistemas en los que se produzca este problema específico. Si no se ve seriamente afectado por este problema concreto, Microsoft recomienda que utilice la versión siguiente de Windows.

Vaya a la sección Service Packs y después haga clic en el vínculo para descargar Windows 95 Update for AMD-K6-2/350.

Los siguientes archivos de actualización para Windows 95 OSR 2 y OSR 2.1 solucionan este problema:

Fecha Hora Versión Tamaño Nombre de archivo
--------------------------------------------------------------
09/04/98 11:18am 4.00.1118 24,426 bytes Esdi_506.pdr
08/03/98 11:13am 4.00.1113 25,249 bytes Hsflop.pdr
09/04/98 11:12am 4.00.1112 23,158 bytes Scsiport.pdr
01/15/97 11:12am 4.00.1112 59,153 bytes Cdfs.vxd
01/15/97 11:12am 4.00.1112 18,809 bytes Disktsd.vxd
01/15/97 11:12am 4.00.1112 9,955 bytes Int13.vxd
09/04/98 11:13am 4.00.1113 68,962 bytes Ios.vxd
01/15/97 11:12am 4.00.1112 18,197 bytes Vfbackup.vxd
Además, para OSR 2.1 se requiere el siguiente archivo de actualización:

Fecha Hora Versión Tamaño Nombre de archivo
---------------------------------------------------------------
12/04/98 12:13pm 4.00.1213 111,678 bytes Ntkern.vxd
NOTA: esta corrección no soluciona el problema de la versión comercial de Windows 95. Además, las versiones de la actualización Amdk6upd.exe con fecha "09/18/98 11:00am" no sustituyen el archivo Ntkern.vxd en OSR 2.1 y OSR 2.5. Para determinar la versión de Ntkern.vxd instalada en el equipo, haga clic con el botón secundario del mouse (ratón) en el archivo Ntkern.vxd de la carpeta Windows\System\Vmm32, haga clic en Propiedades y, después, haga clic en la ficha Versión. Si el número de versión no es 4.03.1213, debe obtener e instalar una nueva versión de la actualización, tal y como se describe a continuación. La versión del archivo original Ntkern.vxd es 4.03.1212.


Para ello, siga estos pasos:
  1. Descargue el archivo Amdk6upd.exe en un disquete. Descargue el archivo desde otro equipo, si es necesario.
  2. Reinicie el equipo. Cuando vea el mensaje "Iniciando Windows 95", presione la tecla F8 y elija Modo a prueba de errores en el menú Inicio.
  3. Si el equipo se inicia en el Modo a prueba de errores, vaya al paso 6. Si no puede iniciar Windows continúe con el paso 4.
  4. Reinicie el equipo. Cuando vea el mensaje "Iniciando Windows 95", presione la tecla F8 y, en el menú Inicio, elija Sólo símbolo del sistema.
  5. En el símbolo del sistema de c:\ , escriba
    win /d:m
    para iniciar Windows en Modo a prueba de errores.
  6. Inserte el disquete que contiene el archivo Amdk6upd.exe que descargó en el paso 1 y, después. utilice el Explorador de Windows o Mi PC para hacer doble clic en el archivo.
  7. Siga las instrucciones que aparecen en pantalla para instalar la actualización.

El archivo siguiente se puede descargar desde el Centro de descarga de Microsoft:

Para obtener información adicional acerca de cómo descargar archivos de soporte técnico de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

119591 Cómo obtener archivos de soporte técnico de Microsoft desde los servicios en línea
Microsoft ha utilizado el software de detección de virus más reciente en el momento de su publicación para buscar virus en este archivo. Una vez publicado, el archivo se encuentra en servidores seguros que impiden cambios no autorizados en el archivo.




Estado

Microsoft ha confirmado que se trata de un problema de Microsoft Windows 95 y OEM Service Release 2, 2.1 y 2.5.


Este problema se resuelve en Microsoft Windows 98.
Propiedades

Id. de artículo: 192841 - Última revisión: 28 may. 2007 - Revisión: 1

Comentarios