Un cliente conectado a un conmutador Ethernet puede recibir varios mensajes de error relacionados con el inicio de sesión durante el inicio

Síntomas

En un equipo cliente que está conectado a una Ethernet modificador, puede recibir varios mensajes de error relacionados con el inicio de sesión durante el inicio.


En el registro de sucesos, puede recibir el siguiente mensaje de error:

5719 - No hay ningún controlador de dominio disponible
NOTA: el origen de este error puede ser el servicio NetLogon y cómo el servicio NetLogon configura su canal seguro.


Además, si inicia sesión en la consola antes de inicio, puede recibir uno de los siguientes mensajes de error:

  • No hay ningún controlador de dominio estaba disponible para validar el inicio de sesión.
    No se pudo contactar con un controlador de dominio para su dominio. Ha iniciado sesión utilizando información de cuenta almacenada en caché. Cambios en su perfil desde la última sesión no esté disponibles.
Puede recibir este mensaje de error sólo cuando se realiza el intento inicial de iniciar sesión en el equipo. Cuando intenta iniciar sesión en el equipo, no recibirá este mensaje de error.

Causa

Este comportamiento puede producirse porque algunos conmutadores Ethernet tienen una característica que comprueba los puertos para una condición de bucle cuando se activen los puertos (el modo de aprendizaje para la característica de algoritmo de árbol de expansión). Si se encuentra un bucle, se bloquea todo el tráfico de acceso al puerto. Este proceso de comprobación de una condición de bucle tarda aproximadamente 10 a 15 segundos durante el cual el equipo basado en Windows NT Workstation parece estar en la red, sin embargo, no hay tráfico que se va a pasar. Los paquetes de servicio NetLogon (junto con cualquier otro tráfico durante ese tiempo) se pierden.


Si tiene un concentrador al final del puerto, el concentrador ha traído ya el puerto. La conexión sólo es incorrecta cuando el equipo está conectado directamente al conmutador.

Solución

Para resolver este comportamiento, deshabilite la característica de algoritmo de árbol de expansión del conmutador Ethernet.

Para obtener información acerca de cómo deshabilitar la característica de algoritmo de árbol de expansión en un conmutador, póngase en contacto con el fabricante del switch.

Solución alternativa

Importante: esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que sigue estos pasos cuidadosamente. Para una mayor protección, haga una copia de seguridad del registro antes de modificarlo. Entonces, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo hacer copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 cómo hacer copia de seguridad y restaurar el registro en Windows


Para evitar este comportamiento, en los clientes, agregue el parámetro siguiente al registro:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netlogon\Parameters
Nombre de valor: ExpectedDialupDelay
Tipo de datos: Reg_Dword
Valor de datos es en segundos (valor predeterminado = 0)
Rango de datos está entre 0 y 600 segundos (10 minutos)

Esta solución obliga el servicio NetLogon en pausa para la cantidad especificada de tiempo antes de que el servicio intentará establecer un canal seguro.


NOTA: a menos que volver a configurar su conmutador, todavía puede experimentar los síntomas descritos en el siguiente artículo de Microsoft Knowledge Base:

168455 errores de renovación DHCP en redes conmutadas

Propiedades

Id. de artículo: 202840 - Última revisión: 8 ene. 2017 - Revisión: 1

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