El programa RemoteApp no finaliza después de que caduque el límite de tiempo de inactividad de sesión en un equipo que ejecuta Windows Server 2008 R2

Síntomas

Imagine el siguiente escenario:
  • Tiene un equipo que ejecuta Windows Server 2008 R2.
  • Unir el equipo a un dominio.
  • Instalar los servicios de rol Servicios de escritorio remoto en el equipo.
  • Habilitar a las siguientes opciones de directiva de grupo en el dominio:
    Equipo Configuración del equipo\Plantillas administrativas\Componentes Windows\Servicios Escritorio remoto\Host escritorio sesión Host\Session tiempo Limits\Set tiempo límite para sesiones de servicios de escritorio remoto activas pero no usadas

    Configuración del equipo\Plantillas administrativas\Componentes de Windows\Servicios Escritorio remoto\Host escritorio sesión Host\Session tiempo sesión\Terminar sesión cuando se alcancen los límites de tiempo del equipo
  • Establecer la configuración de límite de sesión inactiva en un valor que es mayor o igual a cinco minutos. Es la configuración de límite de sesión inactiva en la configuración de directiva de grupo establece el tiempo límite para sesiones de servicios de escritorio remoto activas pero no usadas .
  • Aplicar la configuración de directiva de grupo al equipo.
  • Ejecutar un programa de RemoteApp para iniciar una sesión de servicios de escritorio remoto en el equipo.
  • La sesión está inactiva durante un tiempo más largo que el límite de tiempo de inactividad de sesión.
  • Recibirá el siguiente mensaje en la sesión de servicios de escritorio remoto después de que la sesión está inactiva durante un tiempo más largo que el límite de tiempo de inactividad de sesión:
    Sesión ha estado inactiva superado su límite de tiempo. Se desconectará en 2 minutos. Presione cualquier tecla para continuar la sesión.

En este escenario, el programa RemoteApp no finaliza después de la sesión permanece inactiva durante otros dos minutos.

Causa

Este problema se produce porque los servicios de escritorio remoto trata incorrectamente algunos eventos generados automáticamente y los mensajes como entrada del usuario. Por lo tanto, los servicios de escritorio remoto no finalizará el programa RemoteApp.

Nota: Estos eventos generan automáticamente y los mensajes son de la utilidad de conexión a Escritorio remoto.

Solución

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para aplicar esta revisión, debe estar ejecutando Windows Server 2008 R2. Además, los servicios de rol Servicios de escritorio remoto deben estar instalados.

Información del registro

Para utilizar la revisión de este paquete, no es necesario realizar ningún cambio en el registro.

Requisito de reinicio

Tendrá que reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Esta revisión no sustituye a ninguna revisión publicada previamente.

Información de archivo

La versión en inglés (Estados Unidos) de esta revisión instala archivos que tienen los atributos enumerados en las tablas siguientes. Las fechas y las horas de estos archivos se muestran en la hora Universal coordinada (UTC). Las fechas y las horas de estos archivos en el equipo local se muestran en horario local junto con la diferencia de horario de verano (DST) actual. Además, las fechas y las horas pueden cambiar cuando realiza determinadas operaciones en los archivos.
Notas sobre la información de archivo de Windows Server 2008 R2
Importante: Correcciones urgentes de Windows 7 y Windows Server 2008 R2 se incluyen en los mismos paquetes. Sin embargo, las revisiones en la página solicitud de revisión se enumeran en ambos sistemas operativos. Para solicitar el paquete de revisiones que se aplica a uno o ambos sistemas operativos, seleccione la revisión que aparece bajo "Windows 7/Windows Server 2008 R2" en la página. Siempre consulte la sección "Aplicable a" de los artículos para determinar el sistema operativo real a la que se aplica cada revisión.
  • Los archivos MANIFEST (.manifest) y los MUM archivos (.mum) que se instalan para cada entorno están enumerados por separado en la sección "Información para Windows Server 2008 R2 de archivo adicional". MUM y los archivos de manifiesto y los archivos de catálogo (.cat) de seguridad asociados, son extremadamente importantes para mantener el estado de los componentes actualizados. Los archivos de catálogo de seguridad, para los cuales no se muestran los atributos, están firmados con una firma digital de Microsoft.
Para todas las versiones basadas en x64 compatibles de Windows Server 2008 R2
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Termsrv.dll6.1.7600.20757711,68017-Jul-201008:06x64

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Información adicional de archivos

Información adicional de archivos para Windows Server 2008 R2

Archivos adicionales para todas las versiones compatibles basadas en x64 de Windows Server 2008 R2
Nombre del archivoAmd64_microsoft-windows-t..teconnectionmanager_31bf3856ad364e35_6.1.7600.20757_none_eb40464486f89423.manifest
Versión del archivoNo aplicable
Tamaño de archivo29,203
Fecha (UTC)17-Jul-2010
Hora (UTC)08:52
PlataformaNo aplicable
Nombre del archivoUpdate.mum
Versión del archivoNo aplicable
Tamaño de archivo24,725
Fecha (UTC)17-Jul-2010
Hora (UTC)14:45
PlataformaNo aplicable
Nombre del archivoWow64_microsoft-windows-t..teconnectionmanager_31bf3856ad364e35_6.1.7600.20757_none_f594f096bb59561e.manifest
Versión del archivoNo aplicable
Tamaño de archivo10,688
Fecha (UTC)17-Jul-2010
Hora (UTC)07:59
PlataformaNo aplicable
Propiedades

Id. de artículo: 2287493 - Última revisión: 23 ene. 2017 - Revisión: 1

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