Recibe un error de secuencia de comandos y no puede imprimir desde Internet Explorer 9

Se aplica a: Internet Explorer 9

Resumen


Puede recibir un error de secuencia de comandos similar al siguiente al intentar imprimir una página Web desde Internet Explorer 9. Nota: Número de línea puede ser diferente.
Se ha producido un error en el script de esta página. Línea: 2053 Char: 1 Error: argumento o llamada a procedimiento no válidos. Código: 0 dirección URL: res/ieframe.dll/preview.js.
Si tiene problemas al imprimir en Internet Explorer y no está recibiendo un error de script, consulte no se puede imprimir o ver la vista preliminar de una página Web en Internet Explorer.

Causa


Este error puede aparecer si el controlador de impresora está dañado, anticuado o incompatible. Para solucionar este problema, siga los pasos de la sección resolución.

Solución


Para solucionar este problema, descargue e instale a los controladores más recientes para su impresora. Hay tres maneras de buscar e instalar al controlador de impresora más reciente. Utilice los pasos siguientes, comenzando por el primer paso. Si ese paso no funciona, vaya al paso siguiente.

Desconecte y vuelva a conectar la impresora a su PC

  1. Desenchufe el cable USB de la impresora de su PC. Nota: Para las impresoras inalámbricas, apague la impresora.
  2. Abrir dispositivos e impresoras, haga clic en el botón Inicio Picture of the Start button y a continuación, en el menú Inicio, haga clic en dispositivos e impresoras.
  3. Haga clic en el icono Impresoras y seleccione quitar el dispositivo.
  4. Vuelva a conectar la impresora a su PC mediante un cable USB. Nota: Para las impresoras inalámbricas, consulte la información suministrada con la impresora para obtener instrucciones de instalación.
Si desconectar y volver a conectar la impresora no se soluciona el problema, continúe con el paso siguiente.

Actualizar los controladores de impresora mediante Windows Update

Deberá configurar Windows Update para descargar e instalar las actualizaciones recomendadas automáticamente. Instalar todas las actualizaciones importantes, recomendadas y opcionales puede actualizar las características del sistema y otro software que puede ayudarle a solucionar los problemas de la impresora. Para actualizar el controlador de impresora más reciente para su impresora mediante Windows Update, haga clic en el vínculo específico para su versión de Windows y siga los pasos en el que artículo: Buscar e instalar controladores de impresora en Windows 7Buscar e instalar controladores de impresora en Windows Vistasi actualizar el controlador de impresora mediante Windows Update, no se soluciona el problema, continúe con el paso siguiente.

Actualizar los controladores de impresora del fabricante del dispositivo

Si la impresora incluía un disco, que el disco puede contener software que instala a un controlador para su impresora. Si la impresora no incluye con el software, puede ser necesario ir al sitio Web del fabricante para buscar, descargar e instalar al controlador de impresora más reciente para su impresora.

Solución alternativa


Si todos los métodos en la sección "Resolución" todavía no pueden resolver el problema, pruebe los métodos siguientes de solución.

Método 1 imprimir utilizando Internet Explorer 9 (32 bits) en lugar de Internet Explorer 9(64bit)

  1. Haga clic en el botón Inicio Picture of the Start button , escriba Internet Explorer en Buscar programas y archivosy, a continuación, elija Explorador de Internet.
  2. Intente imprimir de nuevo.

Método 2 imprimir mediante Ejecutar como administrador para Internet Explorer

  1. Haga clic en el botón Inicio Picture of the Start button , escriba Internet Explorer en Buscar programas y archivos.
  2. Haga clic con el botón secundario del mouse en Internet Explorer en los programas y haga clic en Ejecutar como administrador.
  3. Intente imprimir de nuevo.

Más información


Para obtener información acerca de cómo solucionar otros errores de secuencia de comandos en Internet Explorer, vea cómo solucionar errores de secuencia de comandos en Internet Explorer en equipos basados en Windows