Uso intensivo de la CPU en un servidor de archivos que está ejecutando Windows Vista, Windows 7, Windows Server 2008 o Windows Server 2008 R2 con ABE habilitado

Síntomas

Imagine el siguiente escenario:
  • Crear una carpeta que contiene muchas subcarpetas en un servidor de archivo que se está ejecutando uno de los siguientes sistemas operativos:
    • Windows Vista
    • Windows Server 2008
    • Windows 7
    • Windows Server 2008 R2
  • Comparta la carpeta.
  • Habilita la enumeración basada en acceso (ABE) en la carpeta compartida.
En este escenario, experimenta elevado uso de CPU en el servidor de archivos. Además, los usuarios que intenten vaya a la carpeta compartida tener retrasos.

Causa

Este problema se produce porque hay que muchas solicitudes de verificación de acceso cuando ABE enumera una carpeta que contiene muchas subcarpetas.

Solución

Información de la revisión

Importante: Esta revisión se ha vuelto a publicar para tratar un problema en el que la firma digital en archivos producidos y firmados por Microsoft va a caducar antes de tiempo, como se describe en Microsoft Security Advisory 2749655.

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para aplicar esta revisión, debe estar ejecutando uno de los siguientes sistemas operativos:
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008 Service Pack 2 (SP2)
  • Service Pack 1 (SP1) de Windows 7
  • Windows Server 2008 R2 Service Pack 1 (SP1)
Para obtener más información acerca de cómo obtener un service pack de Windows Vista, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

935791 cómo obtener el service pack más reciente para Windows Vista

Para obtener más información acerca de cómo obtener un service pack de Windows Server 2008, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

968849 cómo obtener el service pack más reciente para Windows Server 2008

Para obtener más información acerca de cómo obtener un service pack de Windows 7 o Windows Server 2008 R2, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

976932 información acerca de Service Pack 1 para Windows 7 y Windows Server 2008 R2

Información del registro

Después de instalar el hotfix, debe crear una nueva entrada del registro. Para que podamos crear la entrada del registro para usted, vaya a la sección de "arreglarlo para mí". Si prefiere crear manualmente la entrada del registro, vaya a la sección "permítame corregirlo yo mismo".

Solucionarlo en mi lugar



Para crear automáticamente la entrada del registro, haga clic en el botón corregirlo o vínculo. A continuación, haga clic en Ejecutar en el cuadro de diálogo Descarga de archivos y siga los pasos del Asistente para corregirlo.




Notas:
  • Cuando siga la corrección, Asistente, debe especificar un valor de ABELevel . El valor ABELevel especifica el nivel máximo de las carpetas en la que está habilitada la característica ABE.
  • Este asistente puede estar solo en inglés. Sin embargo, la corrección automática también funciona para otras versiones de idioma de Windows.
  • Si no está en el equipo que tiene el problema, guarde la solución Fix it una unidad flash o un CD y a continuación, ejecútela en el equipo que tiene el problema.

A continuación, vaya a la sección "¿Ha solucionado esto el problema?"



Solucionarlo por mí mismo



¿Esto ha solucionado el problema?

  • Compruebe si el problema se solucionó. Si se solucionó el problema, ha terminado con esta sección. Si no se solucionó el problema, puede ponerse en contacto con el soporte técnico.
  • Le agradeceríamos sus comentarios. Para proporcionar comentarios o informen de cualquier problema con esta solución, por favor deje un comentario en el blog "corregirlo por mí" o envíenos un correo electrónico.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Esta revisión no sustituye a ninguna revisión publicada previamente.
Información de archivo

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Información adicional de archivos
Propiedades

Id. de artículo: 2732618 - Última revisión: 9 ene. 2017 - Revisión: 1

Comentarios