No se puede encontrar al cliente cuando usa la búsqueda del cliente para buscar a un cliente para una transacción en Microsoft Dynamics AX for Retail POS de 2012

En este artículo se aplica a Microsoft Dynamics AX for Retail 2012 para todas las regiones.

Síntomas

Se supone que usa la búsqueda del cliente para buscar a un cliente para una transacción en Microsoft Dynamics AX for Retail POS de 2012. Sin embargo, no se encuentra al cliente. Por ejemplo, tiene un cliente que recibe el nombre AAK. En Danish_norweigan_CI_AS, es el mismo que ÅK. Cuando el formulario ordena en inglés, la letra no existe.

Causa

Este problema se produce porque el resultado de la búsqueda se muestra en la cuadrícula es una copia del resultado y el resultado original se ordena por base de datos de acuerdo con la intercalación de la base de datos. Sin embargo, la cuadrícula siempre ordena el resultado de copiar automáticamente según SQL_Latin1_General_CP1_CI_AS las reglas de ordenación sin afectar al resultado original. Si las reglas de ordenación de intercalación difiere de las reglas de ordenación SQL_Latin1_General_CP1_CI_AS, las copias de los resultados no son consistentes. El elemento seleccionado se obtiene por error desde el resultado original índice del resultado de copia.

Solución

Información de la revisión

Existe un hotfix disponible desde Microsoft. Hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si tiene un problema al descargar, instalar esta revisión, o si tiene otras preguntas de soporte técnico, póngase en contacto con su socio o si está inscrito en un plan de soporte directamente con Microsoft, puede ponerse en contacto con soporte técnico para Microsoft Dynamics y crear una nueva solicitud de soporte técnico. Para ello, visite el siguiente sitio Web de Microsoft:También puede comunicarse con soporte técnico para Microsoft Dynamics por teléfono mediante estos vínculos para números de teléfono específico del país. Para ello, visite uno de los siguientes sitios Web de Microsoft:

Asociados de negociosClientesEn casos especiales, los costos derivados normalmente de las llamadas pueden cancelarse si un profesional de soporte técnico de Microsoft Dynamics y productos relacionados de soporte determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión.

Información sobre la instalación

Si se ha personalizado para uno o varios de los métodos o las tablas que resultan afectadas por este hotfix, debe seguir estos pasos:
  1. Revise los cambios documentados en el archivo .xpo.
  2. Aplique estos cambios en un entorno de prueba antes de aplicar el hotfix en un entorno de producción.


Para obtener más información acerca de cómo instalar este hotfix, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
893082 cómo instalar una revisión de Microsoft Dynamics AX

Requisitos previos

Debe tener Microsoft Dynamics AX for Retail 2012 instalado para poder aplicar este hotfix.

Requisito de reinicio

Debe reiniciar el servicio de Application Object Server (AOS) después de aplicar el hotfix.
Información de archivo

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".
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Propiedades

Id. de artículo: 2798600 - Última revisión: 17 feb. 2017 - Revisión: 2

Microsoft Dynamics AX 2012, Microsoft Dynamics AX for Retail

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