Una solicitud de certificado que utiliza una nueva plantilla es incorrecta

IMPORTANTE: este artículo contiene información acerca de cómo modificar el registro. Antes de modificar el registro, asegúrese de realizar una copia de seguridad y asegúrese de que sabe cómo restaurarlo si ocurre algún problema. Para obtener información acerca de cómo hacer copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

Síntomas

Cuando intenta inscribir un certificado contra una entidad emisora de certificados (CA) de empresa, puede recibir uno de los siguientes mensajes de error:

Inscripción Web:
Solicitud de certificado denegada

Se denegó la solicitud de certificado.

Para obtener más información, póngase en contacto con el administrador.

Asistente para solicitud de certificados:
La entidad de certificación denegó su solicitud. Error no especificado.

Causa

Este comportamiento puede producirse si la solicitud de inscripción de certificados utiliza una plantilla de certificado recientemente creado. Cuando se agrega una nueva plantilla a la entidad emisora, la caché HKEY_CURRENT_USER se actualiza inmediatamente pero no se actualiza inmediatamente la caché HKEY_LOCAL_MACHINE . Si la entidad emisora o el controlador de dominio está en el mismo equipo y en los siguientes 10 minutos si la entidad emisora o el controlador de dominio está en una configuración distribuida, se actualiza la caché HKEY_LOCAL_ MACHINE en los próximos 15 minutos.

Solución

Advertencia: Si utiliza incorrectamente el Editor del registro puede provocar problemas graves que conlleven la reinstalación del sistema operativo. Microsoft no puede garantizar que pueda solucionar los problemas derivados del uso incorrecto del Editor del registro. Utilice el Editor del registro bajo su propio riesgo.

Para resolver este comportamiento, si no se puede esperar el intervalo aplicable de tiempo, puede actualizar manualmente la caché de plantillas de certificado. La caché de certificados de equipo es de
HKEY_LOCAL_MACHINE y la caché de certificados de usuario se encuentra en HKEY_CURRENT_USER.
  • Para forzar la actualización de la caché para una solicitud de certificado de usuario, elimine el siguiente valor del registro del cliente:
    HKEY_CURRENT_USER\Software\Microsoft\Cryptography\CertificateTemplateCache\Timestamp
Para forzar la actualización de la caché para una solicitud de certificado de equipo:
  1. Elimine el siguiente valor del registro del cliente:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\CertificateTemplateCache\Timestamp
  2. Elimine el siguiente valor del registro de la entidad emisora de certificados:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\CertificateTemplateCache\Timestamp
  3. Reinicie los servicios de certificado en la entidad emisora.

Más información

Además el mensaje de error anterior, la entidad emisora registra el siguiente mensaje de suceso en el registro del programa:
Propiedades

Id. de artículo: 281260 - Última revisión: 9 ene. 2017 - Revisión: 1

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