No se detecta el dispositivo USB conectado en Windows

Se aplica a: Windows 8.1Windows 8.1 EnterpriseWindows 8.1 Pro

Importante: Esta revisión sólo es aplicable a Windows 8 y Windows Server 2012. Sin embargo, el resto de la información de este artículo es aplicable a Windows 8.1, R2 de Windows Server 2012, Windows 8 y Windows Server 2012.

Síntomas


Imagine el siguiente escenario:
  • Tiene un concentrador USB conectado a un equipo que ejecuta Windows 8.1, Windows Server 2012 R2, Windows 8 o Windows Server 2012.
  • Tiene un dispositivo USB conectado a un puerto USB en el concentrador.
  • Quita el dispositivo USB del puerto USB.
  • Vuelve a conectar el mismo dispositivo USB o un dispositivo USB diferente al mismo puerto USB en el concentrador.
En este escenario, el equipo no detecta el dispositivo USB.

Nota: Este problema afecta a los componentes de USB 2.0 en concentradores USB 3.0 y concentradores USB 2.0.

Causa


Este problema se produce porque el puerto USB se deshabilita después de retirar el dispositivo del puerto.

Solución


Para resolver este problema, instale el paquete acumulativo de actualizaciones 2845533 de Windows RT, Windows 8 y Windows Server 2012 o instale la revisión que se describe en este artículo.

Además, debe establecer la clave del registro que se describe en la sección "Información del registro" para habilitar esta actualización o hotfix.

Información de actualización

Para obtener más información acerca de cómo obtener este paquete acumulativo de actualizaciones, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
2845533 Windows Server 2012, Windows 8 y Windows RT acumulativo: junio de 2013

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico.

Si la revisión está disponible para su descarga, entonces podrá ver una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, envíe una solicitud al servicio de atención al cliente y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de revisión disponible" muestra los idiomas para los que la revisión está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para aplicar esta revisión, debe ejecutar Windows 8 o Windows Server 2012.
 

Información del registro

Importante: esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que sigue estos pasos cuidadosamente. Para una mayor protección, haga una copia de seguridad del registro antes de modificarlo. Entonces, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo hacer copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 cómo hacer copia de seguridad y restaurar el registro en Windows

Importante:  Debe aplicar los cambios del registro siguientes para resolver este problema en Windows Server 2012, Windows 8, Windows Server 2012 R2 o Windows 8.1.

Nota en Windows 8 y Windows Server 2012, debe crear la clave del registro antes de reiniciar el equipo (después de aplicar este hotfix).

Para habilitar la actualización para un dispositivo específico, siga estos pasos:
  1. Deslice desde el borde derecho de la pantalla y, a continuación, pulse Buscar. O bien, si utiliza un mouse, elija la esquina inferior derecha de la pantalla y, a continuación, haga clic en Buscar.
  2. En el cuadro de búsqueda, escriba regedit y, a continuación, puntee o haga clic en regedit.
    Icono de aviso
    Si se le pide que introduzca una contraseña de administrador, escriba la contraseña. Si se le pide que proporcione una confirmación, proporcione una confirmación.
  3. Busque y, a continuación, puntee o haga clic en la subclave del registro siguiente:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\UsbFlags
  4. En el menú Edición , seleccione Nuevo y, a continuación, puntee o haga clic en Clave.
  5. Escriba un nombre para la nueva clave con el formato siguiente:
    vvvvpppprrrr
    Notas:
    1. "vvvv" representa un número hexadecimal de cuatro dígitos que identifica el ID de proveedor del dispositivo.
    2. "pppp" representa un número hexadecimal de 4 dígitos que identifica el identificador de producto del dispositivo.
    3. "rrrr" representa un número de 4 dígitos decimal codificado en binario que contiene el número de revisión del dispositivo.
  6. En el menú Edición , seleccione nuevo y, a continuación, puntee o haga clic en Valor DWORD (32 bits).
  7. Escriba DisableOnSoftRemove.
  8. Mantenga presionado DisableOnSoftRemove o haga clic en él con el botón derecho del ratón y, a continuación, puntee o haga clic en Modificar.
  9. En el cuadro información del valor , escriba 0 y, a continuación, puntee o haga clic en Aceptar.
  10. Salga del Editor del Registro.
Para habilitar la actualización para todos los dispositivos USB que se enumeran en el equipo, siga estos pasos:
 
  1. Deslice desde el borde derecho de la pantalla y, a continuación, pulse Buscar. O bien, si utiliza un mouse, elija la esquina inferior derecha de la pantalla y, a continuación, haga clic en Buscar.
  2. En el cuadro de búsqueda, escriba regedit y, a continuación, puntee o haga clic en regedit.
    Icono de aviso
    Si se le pide que introduzca una contraseña de administrador, escriba la contraseña. Si se le pide que proporcione una confirmación, proporcione una confirmación.
  3. Busque y, a continuación, puntee o haga clic en la subclave del registro siguiente:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\usbhub
  4. En el menú Edición , seleccione Nuevo y, a continuación, puntee o haga clic en Clave.
  5. Escriba HubG.
  6. En el menú Edición , seleccione nuevo y, a continuación, puntee o haga clic en Valor DWORD (32 bits).
  7. Escriba DisableOnSoftRemove.
  8. Mantenga presionado DisableOnSoftRemove o haga clic en él con el botón derecho del ratón y, a continuación, puntee o haga clic en Modificar.
  9. En el cuadro información del valor , escriba 0 y, a continuación, puntee o haga clic en Aceptar.
  10. Salga del Editor del Registro.
Nota: Cuando se establece el valor de la entrada del registro DisableOnSoftRemove en 0, el sistema no hace nada cuando se quita un dispositivo USB. Cuando se establece el valor de la entrada del registro DisableOnSoftRemove en 1, el sistema deshabilita el puerto desde el que se quita un dispositivo USB.
 

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix o el cambio del registro.

Información de reemplazo de revisión

Esta revisión no sustituye a ninguna revisión publicada previamente.

Estado


Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información


Para obtener más información acerca de la entrada de registro DisableOnSoftRemove y los efectos de habilitar o deshabilitar no un puerto USB en quitar software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
2401954 puerto USB permanece activo para el dispositivo USB deshabilitado o quitado de forma segura

Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft
Para obtener más información acerca de cómo buscar los identificadores de Hardware para dispositivos específicos, consulte las Entradas de registro del dispositivo USB.

Información adicional de archivos

Información adicional de archivos para Windows 8 y Windows Server 2012

Archivos adicionales para todas las versiones compatibles basadas en x86 de Windows 8
Nombre del archivo Update-bf.mum
Versión del archivo No aplicable
Tamaño de archivo 1.763
Fecha (UTC) 03-May-2013
Hora (UTC) 15:04
Plataforma No aplicable
 
Nombre del archivo X86_usbhub3.inf_31bf3856ad364e35_6.2.9200.16603_none_f2e110b11e2c8fc0.manifest
Versión del archivo No aplicable
Tamaño de archivo 2.104
Fecha (UTC) 03-May-2013
Hora (UTC) 03:54
Plataforma No aplicable
 
Nombre del archivo X86_usbhub3.inf_31bf3856ad364e35_6.2.9200.20707_none_f36eaea4374694e6.manifest
Versión del archivo No aplicable
Tamaño de archivo 2.104
Fecha (UTC) 03-May-2013
Hora (UTC) 04:42
Plataforma No aplicable
 
Archivos adicionales para todas las versiones basadas en x64 compatibles de Windows 8 y de Windows Server 2012
Nombre del archivo Amd64_usbhub3.inf_31bf3856ad364e35_6.2.9200.16603_none_4effac34d68a00f6.manifest
Versión del archivo No aplicable
Tamaño de archivo 2.108
Fecha (UTC) 03-May-2013
Hora (UTC) 07:10
Plataforma No aplicable
 
Nombre del archivo Amd64_usbhub3.inf_31bf3856ad364e35_6.2.9200.20707_none_4f8d4a27efa4061c.manifest
Versión del archivo No aplicable
Tamaño de archivo 2.108
Fecha (UTC) 03-May-2013
Hora (UTC) 07:05
Plataforma No aplicable
 
Nombre del archivo Update-bf.mum
Versión del archivo No aplicable
Tamaño de archivo 1.989
Fecha (UTC) 03-May-2013
Hora (UTC) 15:05
Plataforma No aplicable