Outlook no puede conectarse a la carpeta pública de Exchange 2013 o al buzón asignado automáticamente

Se aplica a: Microsoft Office Outlook 2007Microsoft Outlook 2010Outlook 2013

Síntomas


Cuando usa Microsoft Office Outlook 2007, Microsoft Outlook 2010 o Microsoft Outlook 2013 para conectarse a una carpeta pública de Microsoft Exchange Server 2013 o a un buzón asignado automáticamente, verá el siguiente error:
No se puede expandir la carpeta. Microsoft Exchange no está disponible. Hay problemas de red o el servidor de Exchange está inactivo por mantenimiento.
Además, puede ver un mensaje de credenciales si el administrador de Exchange Server establece ExternalAuthentication en Basic.

Causa


Exchange Server 2013 introdujo una configuración de cliente interna y externa independiente para la conectividad de Outlook en cualquier lugar. Outlook usa el espacio de nombres externo para conectarse a buzones alternativos, aunque Outlook se encuentra en la red interna. Los buzones alternativos incluyen buzones asignados automáticamente y carpetas públicas.

Resolución


Para Outlook 2013, este problema se corrige en el paquete de revisiones del 13 de agosto de 2013. Para obtener más información acerca de cómo obtener el paquete de hotfix, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
2817347 Descripción del paquete de revisiones de Outlook 2013 (Outlook-x-none.msp; Outlookintl-en-us.msp): 13 de agosto de 2013
N.o de error: 3357654 (Office15)Para Outlook 2010, este problema se corrige en el paquete de revisiones del 11 de junio de 2013. Para obtener más información acerca de cómo obtener el paquete de hotfix, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
2817371 Descripción del paquete de revisiones de Outlook 2010 (Outlook-x-none.msp): 11 de junio de 2013
N.o de error: 892756 (Office14)Para Outlook 2007, este problema se corrige en el paquete de revisiones del 13 de agosto de 2013. Para obtener más información acerca de cómo obtener este paquete de hotfix, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
2768023 Descripción de la actualización de Outlook 2007: 13 de agosto de 2013
N.o de error: 856778 (Office12)

Más información


Para obtener más información acerca del servicio Detección automática, consulte el siguiente artículo de Microsoft TechNet:La parte interna de la respuesta Detección automática suele tener el siguiente aspecto:
<Type>EXHTTP</Type><Server>exch1.contoso.com</Server><SSL>Off</SSL><AuthPackage>NTLM</AuthPackage><ASUrl>https://exch1.contoso.com/EWS/Exchange.asmx</ASUrl><EwsUrl>https://exch1.contoso.com/EWS/Exchange.asmx</EwsUrl><OOFUrl>https://exch1.contoso.com/EWS/Exchange.asmx</OOFUrl><OABUrl>https://exch1.contoso.com/OAB/9f2dd03f-064b-4356-b0d0-6789c44ebf29/</OABUrl></Protocol>
La parte externa de la respuesta Detección automática suele tener el siguiente aspecto:
<Protocol><Type>EXHTTP</Type><Server>mail.contoso.com</Server><SSL>On</SSL><AuthPackage>Ntlm</AuthPackage><ASUrl>https://mail.contoso.com/EWS/Exchange.asmx</ASUrl><EwsUrl>https://mail.contoso.com/EWS/Exchange.asmx</EwsUrl><OOFUrl>https://mail.contoso.com/EWS/Exchange.asmx</OOFUrl></Protocol>
En este ejemplo, la primera entrada representa InternalHostname y se establece en exch1.contoso.com. La segunda entrada representa ExternalHostname y se establece en mail.contoso.com. Outlook generalmente intenta conectarse con el primer bloque EXHTTP. Si se produce un error en esa conexión, Outlook intenta conectarse mediante el segundo bloque EXHTTP. De forma predeterminada, Outlook usa esta lógica para el buzón principal. Sin embargo, salta incorrectamente al segundo bloque EXHTTP para conexiones de buzón alternativas.