REVISIÓN: Se produce un error "Acceso denegado" en algunos equipos de grupo de trabajo iniciadas por el origen de la suscripción en Windows 7 o Windows Server 2008 R2

Se aplica a: Windows 7 EnterpriseWindows 7 ProfessionalWindows Server 2008 R2 Datacenter

Síntomas


Imagine el siguiente escenario:
  • Configurar una suscripción iniciada por el origen para varios equipos de grupo de trabajo de origen no unidos a un dominio.
  • Configurar un equipo recopilador de eventos que se ejecuta Windows 7 o Windows Server 2008 R2.
  • Utilice una configuración de directiva de grupo para reenviar eventos al mismo equipo recolector de eventos.

En este escenario, el equipo de solo origen es correcta en conexión con el equipo del recopilador de eventos. En los equipos de origen, recibirá el siguiente mensaje de error WSManFault:

Acceso denegado.

Además, se graba el suceso siguiente:

Nombre de registro: Microsoft-Windows-reenvío/operacionales
Fuente: Reenvío de Windows de Microsoft
Id. de suceso: 105
Nivel: Error
Usuario: Servicio de red
Equipo: workgroup_computer_name
Descripción:
El reenviador está teniendo un problema al comunicarse con el gerente de suscripción en la dirección HTTPS://URL:puerto/wsman/SubscriptionManager/WEC

Causa


En el equipo del recopilador de eventos, sólo el primer valor de la propiedad asuntos permitidos para la suscripción se analiza mientras se procesa la propiedad. Por lo tanto, sólo el primer equipo nombre que se especifica en la propiedad asuntos permitidos puede conectarse correctamente.

Nota: El valor de la propiedad asuntos permitidos se recupera desde la siguiente ubicación del registro:

HKEY_LOCAL_MACHINE\Software\Windows\Currentversion\EventCollector\Subsciption\server_name

Solución


Para resolver este problema, aplique la revisión que se menciona en este artículo sólo el equipo recolector de eventos.

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe tener Service Pack 1 para Windows 7 o Windows Server 2008 R2 instalado.

Requisito de reinicio

No es necesario que reinicie el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Esta revisión no sustituye cualquier revisión lanzada anteriormente.

Estado


Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".