Se produce un error en una operación de copia de archivo cuando los archivos o carpetas tienen rutas de acceso largas en el Explorador de Windows

Se aplica a: Windows Server 2012 R2 DatacenterWindows Server 2012 R2 EssentialsWindows Server 2012 R2 Foundation

Síntomas


Imagine el siguiente escenario:
  • Tiene un equipo que está ejecutando Windows 8.1, R2 de Windows Server 2012, Windows 8, Windows Server 2012, Windows 7 Service Pack 1 (SP1) o Service Pack 1 (SP1) de Windows Server 2008 R2.
  • Utilice el Explorador de Windows para intentar copiar archivos o carpetas para pegarlos en otra carpeta.
  • Los archivos o carpetas que copie tienen rutas de acceso que superan la longitud máxima permitida.

En este escenario, el comportamiento de la operación de copia es poco confiable y se produce un error debido a la longitud de la ruta de acceso del archivo o carpeta. Además, puede experimentar alguno de los síntomas siguientes:
  • La operación de copia falla y genera un mensaje que indica que la ruta de acceso (nombre de archivo) es demasiado largo. El mensaje también sugiere que Acorte el nombre del archivo e inténtelo de volver a copiar.
  • No se inicia la operación de copia. En este caso, no se genera ningún mensaje.
  • La operación de copia comienza, copia algunos archivos o carpetas y, a continuación, se produce un error sin que se genere un mensaje.

Este problema puede impedir que algunos archivos o carpetas se copian. Quizás no lo note el problema si no recibe un mensaje de error. Pueden producirse síntomas diferentes, dependiendo de cómo se seleccionan los archivos para copiar.

Nota: Este problema también puede producirse cuando intenta copiar archivos o carpetas de instantáneas de Volume Shadow Copy Service si la longitud de archivo o la carpeta en la instantánea supera la longitud máxima.

Causa


Este problema se produce debido a un problema en la manera en que Windows trata los errores de la ruta de acceso larga.

Solución


Para resolver este problema para Windows 8.1, R2 de Windows Server 2012, Windows 8, y Windows Server 2012, instale el paquete acumulativo de actualizaciones.
Para resolver este problema para Windows 7 y Windows Server 2008 R2, instale la revisión que se describe en este artículo.

Información de actualización para Windows Server 2012, 2012 R2 de Windows Server, Windows 8 y Windows 8.1

Para resolver este problema, instale el paquete acumulativo con fecha de abril de 2012 o noviembre de 2014.

Información de hotfix para Windows 7 y Windows Server 2008 R2

Hay una revisión compatible de Microsoft Support. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe tener Service Pack 1 para Windows 7 o Windows Server 2008 R2 instalado.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Esta revisión no sustituye cualquier revisión lanzada anteriormente.

Estado


Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Referencias


Aprender acerca de la terminología que utiliza Microsoft para describir las actualizaciones de software.