Qué hacer si su Word para Mac tiene un virus de macro

Resumen

Este artículo describe qué son los virus de macro, qué debe hacer si piensa que su equipo tenga un virus de macro de Word y cómo asegurarse de que los documentos no infectarse con un virus de macro.

Más información

El primer virus de macro se descubrió en el verano de 1995. Desde entonces, han aparecido otros virus de macro.

Un virus de macro es un programa malintencionado que se escribe utilizando el lenguaje de macros de un programa como Word. El virus se propaga entre archivos de datos y puede dañar sus archivos o el sistema operativo de su equipo.

Virus de macro de Word no viajan libremente por Internet o cualquier otro medio; sólo se pueden transferir cuando un usuario abre un documento o plantilla que contiene el virus de macro.

No se puede transferir el virus por correo electrónico, a menos que un documento infectado esté incrustado en el mensaje de correo electrónico y el destinatario abre el documento.

Síntomas de un Virus de Macro

Los siguientes son algunos síntomas de virus de macro de Word que se sabe que afectan a Word y Word documentos:
  • Cuando intenta guardar un documento, Word sólo permite guardar el documento como una plantilla.

    - o -
  • El icono del archivo parece una plantilla en lugar de un documento.

    - o -
  • Cuando abre un documento, aparece un cuadro de diálogo que muestra el número 1.

    - o -
  • Ya no aparecen los comandos de Macro y Personalizar en el menú Herramientas .

    - o -
  • Aparecen nuevas macros en la lista de macros. También pueden aparecer las macros AutoOpen y FileSaveAs; Si ya tenía macros con estos nombres, su contenido puede modificarse por los virus de macro.

    - o -
  • Mensajes extraños o inesperados aparecen cuando se abre un documento de Word o plantilla.
Notas:
  • Word no buscar virus de macro o quitar cualquier virus de macros de los documentos y plantillas existentes. Sólo le advierte si el documento que está abriendo contiene macros. A continuación, puede abrir el documento con las macros activas o abrirlo con las macros deshabilitadas. No debe abrir un documento con las macros activas, a menos que esté absolutamente seguro de que el documento no contiene macros dañinos virus.
  • Los programas antivirus de otros fabricantes deben actualizarse con frecuencia para mantener su eficacia. Póngase en contacto con el proveedor para obtener información de actualización.

Instalar un programa antivirus

Para obtener una solución a largo plazo a los virus de macro, instale software antivirus diseñado específicamente para detectar virus de macro. Para obtener información adicional acerca de los proveedores de software antivirus, además de software capaz de detectar y evitar virus de macro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

49500 lista de proveedores de software antivirus

Microsoft proporciona información de contacto de terceros para ayudarle a encontrar soporte técnico. Esta información de contacto puede cambiar sin previo aviso. Microsoft no garantiza la exactitud de esta información de contacto de terceros.

Qué hacer cuando piensa que su equipo tenga un virus de macro

Utilice los métodos siguientes como soluciones temporales sólo cuando piensa que su equipo tenga un virus de macro.

Método 1: Deshabilitar las macros y copie el texto en un documento nuevo

Si no experimenta los síntomas descritos anteriormente en este artículo, pero no desea ser afectado por un virus de macro, mantenga presionada la tecla MAYÚS cuando abra un archivo que pueda estar infectado por un virus de macro. Presiona la tecla MAYÚS impide que las macros automáticas de Word de ejecución; Si hay un virus de macro, no se carga.

Método 2: Eliminar la macro y recuperar el documento

Si experimenta los síntomas descritos anteriormente en este artículo, o si sospecha que tiene un virus de macro que no se describen en este artículo, siga estos pasos para eliminar la macro sospechosa y corregir los documentos afectados.

Nota: Esto es sólo una solución temporal; Dado que se crean nuevas macros, estos pasos no funcionen en nuevas macros.

  1. En el menú, haga clic en Word, a continuación, haga clic en salir. Mueva el archivo Normal al escritorio. Para hacer esto:
    1. Cierre todos los programas de Microsoft.
    2. En el menú Finder, haga clic en Ir select principal .
    3. Abra la carpeta de la biblioteca .
    4. Abra la carpeta Application Support .
    5. Abra la carpeta Microsoft .
    6. Abra la carpeta Office .
    7. Abra la carpeta de Plantillas de usuario .
    8. Haga clic en archivo Normal. Haga clic en Editar, a continuación, elija Copiar "Normal.dotm".

  2. Abra Word. En el menú archivo , haga clic en Abrir.
  3. Desplácese hasta la carpeta que contiene el archivo afectado.
  4. Haga clic para seleccionar el archivo afectado. Inmediatamente presione y mantenga presionada la tecla MAYÚS y, a continuación, haga clic en Abrir. Continúe manteniendo la tecla MAYÚS hasta que se abra en Word el archivo afectado.

    Nota: Mantenga la tecla MAYÚS mientras abre un archivo, impide la ejecución las macros automáticas de Word.
  5. Para eliminar una macro sospechosa, utilice los pasos siguientes:
    1. En el menú Herramientas, señale Macro y, a continuación, haga clic en Macros.
    2. En el menú emergente Macros en , seleccione todas las plantillas activas y documentos.
    3. Seleccione la macro sospechosa y haga clic en Eliminar. Haga clic en cuando se le pregunte si desea eliminar la macro.
    4. Repita el paso c para todas las macros sospechosas.
    5. Haga clic en Cancelar para cerrar el cuadro de diálogo Macro .
  6. Para recuperar el texto de un documento infectado, siga estos pasos:
    1. Seleccione todo el documento presionando COMANDO+A o haciendo clic en Seleccionar todo en el menú Edición .
    2. Eliminar la última marca de párrafo del documento desde la selección presionando MAYÚS+FLECHA izquierda.
    3. En el menú Edición, haga clic en Copiar.
    4. En el menú archivo , haga clic en nuevo. Seleccione la plantilla que desea utilizar y, a continuación, haga clic en Aceptar.
    5. En el menú Edición, haga clic en Pegar.
    6. Repita el paso 7 para asegurarse de que no se ha replicado la macro que contiene el virus.
    7. Guarde el documento.
  7. Repita estos pasos con cualquier documento que cree que podría contener un virus de macro.
Nota: Si el método 2 no funciona, pruebe el método 3.

Método 3: Utilizar el Organizador para limpiar temporalmente los virus de macro

Utilizar el Organizador para limpiar los virus de macro. Tenga en cuenta que si abre otros archivos después de abrir el archivo infectado, estos archivos probablemente están infectados también.

Para quitar el virus de la plantilla Normal, siga estos pasos:
  1. Cierre todos los documentos. Si está abierto un documento infectado, puede volver a infectar fácilmente la plantilla Normal.
  2. En el menú Herramientas , haga clic en plantillas y complementosy, a continuación, haga clic en el botón Organizador .
  3. Haga clic en la ficha Elementos del proyecto Macro y cambiar el nombre o eliminar todas las macros siguientes:
    • NewMacros
    • AutoClose
    • AutoExec
    • AutoOpen
    • FileExit
    • FileNew
    • FileOpen
    • (Save As)
    • FileSaveAs
    • Macros
    • ToolsMacro
  4. Haga clic en Cerrar.
  5. Presione y mantenga presionada la tecla MAYÚS mientras hace clic en Guardar todo en el menú archivo para guardar la plantilla.
Para quitar un virus de macro de un documento infectado:

Si un archivo está infectado, utilice el mismo método que en los pasos 1 a 5, pero quite las macros de la plantilla Normal y también desde el documento infectado (plantilla) mientras en el organizador. Cuando haya terminado, presione y mantenga presionada MAYÚS mientras haga clic en Guardar todo en el menú archivo y, a continuación, mueva el archivo siguiente. Tenga en cuenta que cada vez que abra un archivo infectado, infecta su plantilla Normal, por lo que debe quitar repetidamente las macros de la plantilla Normal.

Método 4: Insertar el archivo infectado en un documento nuevo

Este método es particularmente útil con los virus de macro "CAP", que quitan Macro y Personalizar en el menú Herramientas .

Nota: En esta situación, las plantillas y complementos del menú Herramientas no funcionen.

  1. En el menú, haga clic en Word, a continuación, haga clic en salir. Mueva la plantilla Normal al escritorio. Para hacer esto:
    1. Cierre todos los programas de Microsoft.
    2. En el menú Finder, haga clic en Ir select principal .
    3. Abra la carpeta de la biblioteca .
    4. Abra la carpeta Application Support .
    5. Abra la carpeta Microsoft .
    6. Abra la carpeta Office .
    7. Abra la carpeta de Plantillas de usuario .
    8. Haga clic en archivo Normal. Haga clic en Editar, a continuación, elija Copiar "Normal.dotm".

  2. Abra Word y compruebe que Macro y personalizar aparecen en el menú Herramientas .
  3. Abra un documento nuevo. En el menú Insertar, haga clic en archivo.
  4. Desplácese hasta la carpeta que contiene el archivo afectado.
  5. Haga clic para seleccionar el archivo afectado.
  6. Presione y mantenga presionada la tecla MAYÚS y, a continuación, haga clic en Abrir. Continuar mantenga presionada la tecla MAYÚS hasta que se abra en Word el archivo afectado.
    Nota: Mantenga la tecla MAYÚS mientras abre un archivo, impide la ejecución macros automáticas de Word.
  7. Para comprobar si existe alguna macro en el nuevo documento (ninguno debe enumerarse), elija Macro en el menú Herramientas y, a continuación, haga clic en Macros. En la lista emergente Macros en , haga clic en todas las plantillas y documentos activos. En Nombre de la Macro, no debe aparecer ninguna macro. Haga clic en Cancelar.
  8. Guarde el archivo con un nombre de archivo diferente.
  9. Eliminar el archivo infectado.

Método 5: Usar la solución RTF

A. eliminar el archivo Normal (plantilla Global).

Se trata de un problema con una macro que se va a guardar la plantilla Normal.

Los pasos siguientes quitan la plantilla Normal. Tenga en cuenta que se eliminará cualquier conjunto de formato especial en la plantilla Normal, y la plantilla se restablecerá la configuración predeterminada.
  1. Cierre todos los programas de Microsoft.
  2. En el menú Finder, haga clic en Ir select principal .
  3. Abra la carpeta de la biblioteca .
  4. Abra la carpeta Application Support .
  5. Abra la carpeta Microsoft .
  6. Abra la carpeta Office .
  7. Abra la carpeta de Plantillas de usuario .
  8. Busque el archivo que se denomina Normal. Haga clic en archivo y haga clic en mover a la Papelera.

B. deshabilitar las macros.

Abra los archivos de virus y, a continuación, deshabilitar las macros en cada archivo a medida que recibe la advertencia de macros. Si no recibe una advertencia, debe activar las advertencias de macros. Para ello, siga estos pasos:
  1. En el menú de Word y haga clic en Preferencias.
  2. En el panel de exploración, haga clic en seguridad y a continuación, seleccione la casilla de verificación Avisar antes de abrir un archivo que contenga macros .

C. vuelva a guardar los archivos existentes.

  1. En el menú archivo , haga clic en Guardar como .
  2. En la lista formato , haga clic en Formato de texto enriquecido (RTF).
  3. Haga clic en Guardar.

Después de guardar el archivo como un archivo RTF, guardar de nuevo el documento en el formato Word (.doc) sobrescribir el archivo con el virus de Macro o guardar el documento como un archivo nuevo y, a continuación, eliminar el antiguo archivo que contiene el virus. Después de guardar el nuevo archivo en formato .doc, puede eliminar el archivo RTF. Tenga en cuenta que algunos elementos de formato no se conserva en la transición desde el formato Word (.doc) a RTF.


Propiedades

Id. de artículo: 291824 - Última revisión: 21 ene. 2017 - Revisión: 1

Comentarios