Trabajos de impresión se pierden o se bloquea una aplicación en Microsoft Enterprise Desktop Virtualization 2.0 en Windows

Se aplica a: Windows 8.1 EnterpriseWindows 8.1Windows 8.1 Pro

Síntomas


Problema 1

Imagine el siguiente escenario:
  • Dispone de un servidor basado en Windows Server 2012 R2, basado en Windows Server 2012 o basado en Windows Server 2008 R2 que está ejecutando servicios de escritorio remoto.
  • Tiene un cliente que está ejecutando Windows 8.1, Windows 8 o Windows 7.
  • Instalar un controlador de impresora XPS para imprimir en una impresora XPS local en el cliente Windows 8.1, Windows 8 o Windows 7.
  • Deshabilita a la configuración de escritorio fácil imprimir grupo Directiva remoto en el servidor de servicios de escritorio remoto y, a continuación, instalar al controlador de impresora basados en XPS.
  • Redirigir la impresión a la impresora XPS local en el cliente.
  • Se conecta al servidor de servicios de escritorio remoto que utiliza la impresora redirigida y confirmar que la impresora redirigida en el servidor está utilizando el controlador de impresora XPS en lugar del controlador de impresora Easy Print de escritorio remoto.
  • Intenta imprimir un trabajo.

En este escenario, el trabajo de impresión se pierde y no se imprime nada.

Problema 2

Cuando ejecuta una aplicación en Microsoft Enterprise Desktop Virtualization (MED-V) 2.0 en Windows 7, se bloquea la aplicación.

Causa


Este problema se produce porque los datos que se envían desde el servidor que ejecuta Servicios de escritorio remoto al cliente inesperadamente se descartan.

Solución


Para resolver este problema en Windows 8.1 o 2012 R2 de Windows Server, instale la actualización 2919355.

Para resolver este problema en Windows 8 o Windows Server 2012, instale el paquete acumulativo de actualizaciones 2928678 o instale el hotfix que se describe en este artículo.

Para resolver estos problemas en Windows 7, instale la revisión que se describe en este artículo.

Actualizar la información de Windows 8.1 y Windows Server R2 de 2012

Para obtener más información acerca de cómo obtener la actualización de 2919355, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
Abril de actualización R2 Windows Server 2012, 2014, Windows 8.1 y Windows RT 8.1 2919355


Actualizar información de Windows 8 y Windows Server 2012

Para obtener más información acerca de cómo obtener el paquete acumulativo de actualizaciones 2928678, haga clic en el número de artículo siguiente para ir al artículo de Microsoft Knowledge Base:
2928678 Windows Server 2012, Windows 8 y Windows RT acumulativo: marzo de 2014

Revisión de información para Windows 8, Windows Server 2012, Windows 7 y Windows Server 2008 R2

Hay una revisión compatible de Microsoft Support. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe tener Windows 8, Windows Server 2012, o instalar Windows 7.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Esta revisión no sustituye cualquier revisión lanzada anteriormente.

Estado


Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Referencias


Obtenga información acerca de la terminología que utiliza Microsoft para describir las actualizaciones de software.