STS: Mensaje de Error después de cambiar contraseña: ADO 80040E4D Error: error de inicio de sesión para usuario 'sa'

Importante: este artículo contiene información acerca de cómo modificar el registro. Antes de modificar el registro, asegúrese de realizar una copia de seguridad y asegúrese de que sabe cómo restaurarlo si ocurre algún problema. Para obtener información acerca de cómo hacer copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

Síntomas

Después de cambiar la contraseña de conexión de base de datos para el sitio Web del grupo de SharePoint, no puede utilizar los sitios Web basados en extensiones de servidor de Microsoft Office 2000 para discusiones o colaboraciones.

Al ver el registro de aplicación de Visor de sucesos, verá el siguiente mensaje de error de servidor Web de Office:

Error ADO 80040E4D: error de inicio de sesión para usuario 'sa'

Causa

Este comportamiento se produce porque los servidores virtuales basados en extensiones de servidor de Office 2000 ya no pueden tener acceso a Microsoft SQL Server 2000 Desktop Engine.



Nota: la versión anterior de Microsoft SQL Server 2000 Desktop Engine se denomina Microsoft Data Engine (MSDE).


Cuando utiliza la utilidad Owsadm.exe para cambiar la contraseña de conexión de base de datos, la instalación de extensiones de servidor de Office 2000 no está configurada con la nueva contraseña.

Solución alternativa

Para evitar este problema, configure las extensiones de servidor de Office 2000 para utilizar la nueva contraseña de conexión de base de datos. Para ello, siga estos pasos:

  1. Inicie el administrador OSE (HTML). Si aparece un cuadro de diálogo Escribir contraseña de red , escriba su nombre de usuario, contraseña y dominio en los cuadros correspondientes y, a continuación, haga clic en Aceptar.
  2. En la página principal del Administrador de extensiones de servidor de Microsoft Office, haga clic en Configuración de la base de datos.
  3. En la página Configuración de la base de datos, haga clic en Cambiar base de datos de Office.
  4. En los cuadros correspondientes, escriba el nombre de SQL Server y el nombre de la base de datos.

    Si no conoce esta información, siga estos pasos para obtenerla desde el registro de Windows de Microsoft:Advertencia: Si utiliza incorrectamente el Editor del registro, puede provocar problemas graves que conlleven la reinstalación del sistema operativo. Microsoft no puede garantizar que pueda solucionar los problemas derivados del uso incorrecto del Editor del registro. Utilice el Editor del registro bajo su propio riesgo.

    1. Haga clic en Inicio y, a continuación, haga clic en Ejecutar.
    2. En el cuadro Abrir, escriba regedit y, a continuación, haga clic en Aceptar.
    3. En el Editor del registro, expanda la siguiente subclave:
      MDStore1 de HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Web Server\OWS Stores\SQL de metadatos
    4. En el panel derecho, anote el valor de datos que corresponde a la entrada DNS . Por ejemplo:
      Proveedor = sqloledb; Server =nombreDeServidor; base de datos = Default_Web_Site_Collab
    5. Salga del Editor del registro.
    6. En la página Configuración de base de datos de extensiones de servidor de Office, escriba el nombre del servidor que anotó en el paso d en el cuadro SQL Server .
    7. En el cuadro Nombre de base de datos , escriba el nombre de la base de datos que anotó en el paso d.
  5. En el cuadro de Id de usuario , escriba sa.
  6. En el cuadro contraseña , escriba la nueva contraseña de conexión de base de datos y, a continuación, haga clic en Enviar.
  7. Reinicie el equipo servidor.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados al principio de este artículo.

Más información

Para obtener información adicional acerca de cómo configurar las contraseñas de base de datos SQL, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

222828 mensaje de error: proveedor Microsoft OLE DB para ODBC Drivers Error '80040E4D ' en
Propiedades

Id. de artículo: 292644 - Última revisión: 21 ene. 2017 - Revisión: 1

Comentarios