Outlook 2010, 2013, 2016 o Outlook para Microsoft 365 no conecta Exchange mediante MAPI a través de HTTP según lo previsto

Número de KB original: 2937684

Síntomas

Imagine la siguiente situación:

  • Usa Microsoft Outlook 2010, Outlook 2013 Service Pack 1 (SP1) o una versión posterior.
  • Está conectado a un buzón de Microsoft Exchange Server 2013 SP1 o Exchange Server 2016.
  • Los servidores de buzón de Exchange y acceso de cliente (CAS) a los que se va a conectar tienen Exchange Server 2013 SP1 o una versión posterior instalada o Exchange Server 2016.
  • La configuración del servidor necesaria para establecer conexiones MapiHttp está configurada correctamente.

En el escenario anterior, la columna Protocolo del cuadro de diálogo Estado de conexión de Outlook muestra que Outlook 2013 está conectado al servidor Exchange mediante un mecanismo de conexión distinto de MAPI/HTTP. Por ejemplo, en la ilustración siguiente se muestra una conexión mediante RPC/HTTP.

Captura de pantalla del cuadro de diálogo estado de conexión de Outlook, que muestra la columna Protocolo como RPC/HTTP.

Nota:

Las conexiones MAPI/HTTP se designan en la columna Protocolo mediante la cadena HTTP.

Además, si MAPI/HTTP está deshabilitado, los usuarios de Microsoft 365 reciben un mensaje de autenticación básica en lugar de un símbolo del sistema de autenticación moderna.

Causa

Este problema puede producirse si la característica MapiHttp está deshabilitada en el cliente de Outlook mediante el siguiente valor del Registro:

Key: HKEY_CURRENT_USER\Software\Microsoft\Exchange
DWORD: MapiHttpDisabled
Value: 1

Solución

Para resolver este problema, cambie el valor de MapiHttpDisabled a 0 (cero) o elimine el valor de DWORD MapiHttpDisabled . Estos datos del Registro solo están diseñados para fines de prueba.

  1. Cierre Outlook.

  2. Abra registry Editor mediante uno de los procedimientos siguientes, según corresponda para su versión de Windows:

    • Windows 10, Windows 8.1 y Windows 8:: presione la tecla Windows + R para abrir un cuadro de diálogo Ejecutar. Escriba regedit.exe y presione Aceptar.
    • Windows 7: haga clic en Inicio, escriba regedit.exe en el cuadro de búsqueda y presione Entrar.
  3. Busque y seleccione la siguiente clave del Registro:

    HKEY_CURRENT_USER\Software\Microsoft\Exchange
    
  4. Haga clic con el botón derecho en MapiHttpDisabled y, a continuación, haga clic en Modificar.

  5. Cambie los datos de valor a 0 y, a continuación, haga clic en Aceptar.

  6. Cierre el Editor del Registro.

  7. Inicie Outlook.

Más información

Para obtener más información sobre los requisitos para conexiones MAPI a través de HTTP, vea MAPI a través de HTTP.