Cómo diseñar y configurar una lista de direcciones de combinación de correspondencia en Word

Para una versión de Microsoft Word 2000 de este artículo, consulte
212322 .

Resumen

En este artículo se describe los formatos aceptables para obtener una lista de direcciones de combinar correspondencia e incluye sugerencias y preguntas que son útiles para preguntarse a sí mismo como crear una lista de direcciones.

Diseño de un origen de datos

En Microsoft Word, puede crear una nueva lista de direcciones en el Asistente para combinar correspondencia. Cuando se elige "Paso 3: seleccione los destinatarios" en el asistente, está disponible la opción de escribir una lista nueva . Esta opción genera la lista de direcciones.

Es otra forma de crear una lista de direcciones de una tabla de Word. También puede utilizar cualquier formato tipo base de datos, como un archivo de texto en el que los campos están separados por comas o tabulaciones y los registros están separados por marcas de párrafo.

En una lista de direcciones, cada categoría de información, como apellido, se denomina campo. El conjunto de campos que constituyen información acerca de una persona se denomina registro.

Lo que debe considerar cuando se diseña un origen de datos

Antes de crear una lista de direcciones, decida qué información desea incluir y cómo desea utilizar esa información y, a continuación, diseñar la base de datos. Esto le ahorra tiempo y trabajo más adelante.

¿Algunos registros tienen más información que otros?

Algunos de los registros de datos pueden tener más información que otros registros. Por ejemplo, algunas entradas pueden tener un nombre de empresa, nombre del departamento y tres líneas para la dirección. Otras entradas pueden tener sólo un nombre, una dirección de una línea y una tercera línea con la ciudad, estado y código postal.

En la lista de direcciones, cada registro de datos debe tener el mismo número de campos de datos. Diseñar la lista de direcciones que tiene suficientes campos de datos que se correspondan con el registro con la mayoría de los campos. No es necesario rellenar todos los campos en el registro de datos; puede dejar algunos campos en blanco. Word suprime automáticamente registros en blanco.

¿Piensa ordenar los datos?

Si va a ordenar los datos, debe organizar por lo que se pueden ordenar los datos según algunos criterios. Por ejemplo, la ciudad, estado y código postal suelen imprimirse en la misma línea de una etiqueta postal, por lo que puede que desee incluir toda esta información en el mismo campo. Si toda esta información se incluye en el mismo campo, no se puede ordenar los registros basados en el estado o el código postal. En este caso, debe separar cada pieza de información en un campo independiente.

Lo mismo es cierto si desea ordenar los datos por los últimos nombres de los destinatarios. En este caso, se deben separar los apellidos y los nombres en campos separados.

¿Utilizará la información en un campo concreto de maneras diferentes?

En una carta modelo, la primera línea del interior dirección normalmente contiene un tratamiento de cortesía y nombre completo del destinatario. El saludo puede contener únicamente el tratamiento de cortesía y apellido o sólo el nombre. Si coloca el título, el nombre y los apellidos en distintos campos, puede utilizar el mismo campo para imprimir el apellido en la dirección y el saludo. Como alternativa, puede utilizar un campo para el título completo y el nombre en el interior dirección y un segundo campo para el título y el apellido en el saludo.

¿Va a utilizar la lista de direcciones para varios documentos de combinación?

Puede combinar una sola lista de direcciones con cualquier tipo y el número de documentos principales. En la configuración de una lista de direcciones para imprimir cartas modelo, planear la información del destinatario para que puedan utilizar el mismo origen de datos para imprimir las direcciones en etiquetas postales o sobres.

¿Cuántos campos (fragmentos de información) tiene para cada registro (la colección de los fragmentos de información)?

Si tiene algunos tipos de información para cada registro, puede utilizar al Asistente para combinar correspondencia (en el menú Herramientas ) en Word. Esto le permite tener acceso al cuadro de diálogo Destinatarios de combinar correspondencia para configurar la lista de direcciones.

Hay una limitación de 255 campos en el cuadro de diálogo Destinatarios de combinar correspondencia . Si el número de campos supera este valor, no utilice Combinar correspondencia. En su lugar, utilice uno de los siguientes:
  • Utilizar Microsoft Excel como origen de datos. El número máximo de campos de datos en una hoja de cálculo de Excel es 256.
  • Utilice una base de datos de Microsoft Access como origen de datos.
  • Utilizar un archivo de texto delimitado por tabulaciones o un archivo de texto delimitado por comas como origen de datos.
Rendimiento de correspondencia se degrada como el número de campos en los aumentos de la fila de encabezado. La configuración de su equipo y la memoria disponible también puede limitar el número de campos que puede insertar en el documento de datos.

El registro de encabezado (fila) no puede contener espacios. Cada campo de encabezado se limita a 40 caracteres y debe comenzar con una letra. Cada carácter subsiguiente debe ser una letra, un número o el carácter de subrayado. Deben rellenar todos los campos de encabezado. Observe que las restricciones descritas aquí son diferentes de algunas versiones de Word.

Organizar los datos en tablas o párrafos

Al organizar los datos en una tabla, la tabla debe contener una columna para cada nombre de campo que desea utilizar. La primera fila de la tabla es la fila de encabezado; cada fila subsiguiente contiene la información de un registro de datos.

Aunque puede ajustar el texto en cada celda, se imprimirá correctamente. La siguiente es una lista de elementos a tener en cuenta al utilizar una lista existente de direcciones como un origen de datos:
  • A menos que utilice un origen de registro inicial independiente, asegúrese de que el registro de encabezado es el primer registro (fila de celdas) en la lista de direcciones. Asegúrese de que no hay ningún espacios, texto o líneas en blanco antes del registro de encabezado. El registro de encabezado no puede contener espacios. Cada campo de encabezado se limita a 40 caracteres y debe comenzar con una letra. Cada carácter subsiguiente debe ser una letra, un número o el carácter de subrayado. Deben rellenar todos los campos de encabezado.
  • Asegúrese de que el número de campos de datos en cada registro de datos es igual al número de nombres de campo en el registro de encabezado. Si un registro no tiene información para un determinado campo, deje la celda para ese campo en blanco.
  • Organice la información en los registros de datos en el mismo orden, de izquierda a derecha, como los nombres de campo correspondiente en el registro de encabezado. El orden de las columnas en la lista de direcciones no es importante, ya que se controla la ubicación de los datos en el documento principal de combinación de correo.

Diseñar una lista de direcciones que contiene muchos campos

El cuadro de diálogo Destinatarios de combinar correspondencia crea una lista de direcciones (.mdb) para el archivo de datos. En Microsoft Word, el número máximo de campos para el cuadro de diálogo Destinatarios de combinar correspondencia es 255. para crear una nueva base de datos desde el cuadro de diálogo Destinatarios de combinar correspondencia , siga estos pasos:
  1. Microsoft Word 2002

    En el menú Herramientas , seleccione cartas y correspondenciay, a continuación, haga clic en Asistente para combinar correspondencia.



    Microsoft Office Word 2003

    En el menú Herramientas , haga clic en cartas y correspondenciay, a continuación, haga clic en Combinar correspondencia.


    Microsoft Office Word 2007 y Word 2010

    En la ficha correspondencia, haga clic en Iniciar Combinar correspondencia y, a continuación, haga clic en Asistente para combinar correspondencia paso a paso.


    Siga los pasos del Asistente para combinar correspondencia a "paso 3: seleccionar destinatarios." Esto es donde se configura la lista de direcciones.
  2. Haga clic en escribir una lista nueva.
  3. Haga clic en crear. Aparecerá el cuadro de diálogo Nueva lista de direcciones . En este cuadro de diálogo, escriba la información de dirección para cada registro. Si no hay ninguna información para un determinado campo, deje la casilla en blanco. De forma predeterminada, Word omite los campos vacíos, por lo que la combinación no se ve afectada si son entradas en blanco en el formulario de datos. El conjunto de información de cada formulario constituye un registro de datos.
  4. Después de escribir la información de un registro, haga clic en Nueva entrada para moverse al siguiente registro. Para eliminar un registro, haga clic en Delete Entry. Para buscar un registro específico, haga clic en Buscar entrada. Para filtrar u ordenar los registros, haga clic en filtrar y ordenar.

    Nota: Si desea personalizar la lista de direcciones, haga clic en Personalizar. En el cuadro de diálogo Personalizar lista de direcciones , puede agregar, eliminar, cambiar el nombre y volver a ordenar los campos de combinación.
  5. En el cuadro de diálogo Nueva lista de direcciones , haga clic en Cerrar.
  6. En el cuadro de diálogo Guardar lista de direcciones en el cuadro nombre de archivo , escriba el nombre que desea asignar el origen de datos y, a continuación, haga clic en Guardar.
  7. En el cuadro de diálogo Destinatarios de combinar correspondencia , realice los cambios que desee y, a continuación, haga clic en Aceptar.
Ahora ha creado una nueva dirección y está preparado para ir al siguiente paso en el Asistente para combinar correspondencia. Este paso consiste en escribir la carta.

Para obtener más información acerca de cómo crear una carta modelo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

294683 cómo utilizar Combinar correspondencia para crear cartas modelo en Word 2002 y en versiones posteriores de Word

Si necesita más de 255 campos de datos en la lista de direcciones, Word no puede organizar los datos del cuadro de diálogo Destinatarios de combinar correspondencia . En su lugar, puede configurar la información como párrafos independientes en una palabra documento. El registro de encabezado y cada registro de datos deben finalizar con una marca de párrafo, que es el delimitador de registro de datos. Cada nombre de campo en el registro de encabezado y cada campo en el registro de datos deben estar separados por un carácter de tabulación o comas, que es el delimitador de campo de datos. Si cualquiera de los campos de datos está vacía, debe incluir el delimitador de campo para identificar el campo vacío.

Si está utilizando una lista de direcciones desde un programa de hoja de cálculo o base de datos, puede exportarlos a formato de texto ASCII, separado por comas o tabulaciones. O bien, puede adjuntar la base de datos mediante ODBC, DDE o un convertidor. Si exporta los datos a un formato ASCII y Word no reconoce automáticamente el campo y los delimitadores de registro, Word le pedirá que seleccione los delimitadores de cuando se utiliza en primer lugar la lista de direcciones. Cuando configura una lista de direcciones en este formato en Word, debe utilizar una marca de párrafo como el delimitador de registro de datos y un carácter de tabulación o una coma como delimitador de campo de datos.

Además de las reglas generales para organizar una lista de direcciones, las siguientes reglas se aplican también a las listas de direcciones que se configuran como texto normal:
  • Presione ENTRAR para finalizar cada registro de datos con una marca de párrafo. Asegúrese de que no hay ninguna marca de párrafo extra entre o después de los registros de datos. Word interpreta los párrafos vacíos (líneas en blanco) como registros vacíos.
  • Utilizar el mismo delimitador de campo en el registro inicial y el registro de datos. Por ejemplo, no puede utilizar caracteres de tabulación en el registro de encabezado y comas en los registros de datos. Dado que el texto de los campos de datos puede incluir comas, es preferible utilizar caracteres de tabulación.
  • Si un registro de datos no incluye información de un campo de datos específicos, insertar dos caracteres de tabulación o dos comas para indicar el campo vacío. No inserte un segundo delimitador de campo, si el campo de datos es el último registro de datos.
  • Escriba el campo de datos entre comillas si el campo de datos contiene uno de los siguientes caracteres:
    • Un carácter de tabulación o una coma, si utiliza ese mismo carácter para separar los campos
    • Un salto de línea o una marca de párrafo
    • Un carácter especificado como separador de lista en la sección internacional del Panel de Control de Microsoft Windows
  • Si la información de un campo de datos contiene comillas (""), escriba dos veces los caracteres ("" ""). Cuando se combina la información del campo de datos, se imprimirá sólo un par de comillas.

Decidir cuándo utilizar un origen de registro inicial independiente

En la mayoría de los casos, es conveniente para el nombre del campo para cada campo de datos en la primera fila o registro de la lista de direcciones de la lista. Sin embargo, desea enumerar los nombres de campo de un origen de registro inicial independiente por las siguientes razones:
  • Puede utilizar la misma fila de encabezado y nombres de campo para combinar datos de varios orígenes sin tener que repetir o cambiar la fila de encabezado en cada lista de direcciones o cambian los nombres de campo de combinación en el documento principal.
  • A veces, una lista de direcciones de otro programa no incluye un registro de encabezado, o nombres de campo en el registro de encabezado no coinciden con los nombres de campo de combinación en el documento principal. Si no se puede modificar o agregar un registro de encabezado en la lista de direcciones (por ejemplo, porque la lista de direcciones es de sólo lectura) puede utilizar un origen de registro inicial independiente que contiene los nombres de campo que especifique.

Agregar el botón "Combinar correspondencia Abrir origen de encabezado"

Si utiliza un origen de registro inicial independiente, debe especificar el origen del encabezado y la lista de direcciones para poder combinar el documento principal con la lista de direcciones.

Para utilizar un origen de encabezado en una combinación de correspondencia de Word, debe agregar el botón Combinar correspondencia Abrir origen de encabezado a la barra de herramientas Combinar correspondencia . Para ello, siga los pasos según corresponda para la versión de Word que esté ejecutando.
Word 2002 o Word 2003
  1. En el menú Ver , elija barras de herramientasy, a continuación, haga clic en Combinar correspondencia. Aparece la barra de herramientas Combinar correspondencia .
  2. En el menú Herramientas , haga clic en Personalizar.
  3. En la ficha comandos , seleccione Todos los comandos en la lista categoría .
  4. En la lista comandos , seleccione y arrastre MailMergeOpenHeaderSource a la barra de herramientas Combinar correspondencia .
  5. Haga clic en Cerrar para cerrar el cuadro de diálogo Personalizar .
Word 2007
Para utilizar un origen de encabezado de correspondencia de Word en Word 2007, debe agregar el botón Combinar correspondencia Abrir origen de encabezado a la barra de herramientas de acceso rápido.
  1. En Word, haga clic en el Botón de Microsoft Office.
  2. Haga clic en Opciones de Word.
  3. Haga clic en personalización.
  4. En el cuadro de diálogo comandos disponibles en , haga clic en Todos los comandos.
  5. Haga clic en Combinar correspondencia Abrir origen de encabezadoy, a continuación, haga clic en Agregar.
  6. Haga clic en Aceptar.
Word 2010


Para utilizar un origen de encabezado en una palabra de correspondencia en Word 2007, agregue el botón Combinar correspondencia Abrir origen de encabezado a la barra de herramientas de acceso rápido.

  1. En la pestaña archivo , elija Opciones .
  2. Elija Personalizar cinta de opciones.
  3. En comandos disponibles en, reemplazar Comandos más utilizados por Todos los comandos.
  4. Haga clic en Combinar correspondencia Abrir origen de encabezadoy, a continuación, haga clic en Agregar.
    Nota: puede que necesite agregar una ficha nueva antes de agregar el comando a la cinta de opciones.
  5. Haga clic en Aceptar.


Diseño de un origen de encabezado

Cuando se especifica un origen de encabezado, recuerde las siguientes reglas:
  • El número de nombres de campo en el origen del encabezado debe ser igual al número de campos de datos en la lista de direcciones.
  • Nombres de campo en el origen del encabezado deben aparecer en el mismo orden que la información correspondiente en la lista de direcciones.
  • Utilizar el mismo delimitador de campo (un carácter de tabulación o una coma) para el origen del encabezado y la lista de direcciones.
  • Si el documento principal ya contiene campos de combinación, utilice los mismos campos de combinación en el origen de encabezado. Si no lo hace, deberá reemplazar los campos de combinación en el documento principal para que coincidan con los nombres de campo en el origen del encabezado. Después de especificar un origen de encabezado, se puede modificar al igual que editar la lista de direcciones.

Con un registro de encabezado de otra lista de direcciones

Si tiene una lista de direcciones que contiene un registro de encabezado, se puede utilizar como un origen de encabezado. Por ejemplo, si rompió la lista de direcciones en varios documentos, puede especificar los nombres de campo en el registro del encabezado de la primera lista de direcciones. Al combinar desde otras listas de direcciones que no tienen un registro de encabezado, especifique la primera lista de direcciones como origen. A continuación, especifique cada una de las listas de direcciones restantes a su vez.

Word pasa por alto los registros de datos de la primera lista de direcciones y utiliza únicamente el registro inicial.

Tipos de datos que puede utilizar con Combinar correspondencia

Puede combinar prácticamente cualquier tipo de información desde un origen de datos de combinación de correo, incluidos los siguientes:
  • Cualquier texto o números
  • Gráficos para el que tiene instalado un filtro gráfico


    Nota: Si los gráficos están incluidos en una lista de direcciones desde un programa distinto a Word, deberá convertir el archivo utilizando un convertidor de formato de archivo.
  • Objetos creados en programas que admiten la vinculación e incrustación de objetos (OLE), como el Editor de ecuaciones
  • Campos de Word que muestran el resultado, como un campo {=} (fórmula)
Para agregar información que no sea texto o números a una lista de direcciones que creó en Word, debe mostrar la lista de direcciones en una ventana de documento utilizando el comando Abrir del menú archivo . O bien, abra la lista de direcciones en el programa original que creó el documento. A continuación, inserte la información en la columna apropiada y la fila de la tabla de lista de direcciones.

Tipos de datos que no puede utilizar

No se puede combinar texto o gráficos que están contenidos en un marco en la lista de direcciones. Sin embargo, puede colocar campos de combinación dentro de marcos. Al combinar los documentos, el texto y los gráficos de la lista de direcciones se colocan en el fotograma.
Propiedades

Id. de artículo: 294688 - Última revisión: 22 ene. 2017 - Revisión: 1

Microsoft Word 2010, Microsoft Office Word 2007, Microsoft Office Word 2003, Microsoft Word 2002 Standard Edition

Comentarios