Cómo solucionar problemas actualizando la instalación de Office desde el sitio Web de Office Update

Si se le ha dirigido a este artículo para resolver un problema mediante la utilidad Cleanup de Windows Installer, póngase en contacto con el fabricante del software para el soporte de instalación en el producto o consulte el siguiente artículo de Microsoft Knowledge Base para conocer los pasos solucionar problemas de desinstalación de productos que usan a Windows Installer:

Importante: este artículo contiene información que muestra cómo reducir la configuración de seguridad o desactivar las características de seguridad en un equipo. Puede realizar estos cambios para solucionar un problema específico. Antes de realizar estos cambios, le recomendamos que evalúe los riesgos asociados con la implementación de esta solución en su entorno concreto. Si decide implementar esta solución alternativa, tome las medidas adicionales oportunas para ayudar a proteger su sistema.

Resumen

Este artículo describe cómo solucionar problemas en el proceso de instalación de la actualización de Office desde el sitio Web de Office Update.

INTRODUCCIÓN

En este artículo paso a paso se describe cómo solucionar problemas que puede experimentar cuando utiliza el sitio Web de Office Update. La siguiente es una lista de síntomas que puede experimentar cuando utiliza el sitio Web de Office Update:
  • Cuando haga clic en Buscar actualizaciones y, a continuación, siga las instrucciones para instalar las actualizaciones, el proceso de actualización comienza y se cierra inesperadamente.
La siguiente es una lista de mensajes de error que puede experimentar cuando utiliza el sitio Web de Office Update:
  • El sitio Office Update tiene algunos problemas técnicos y no puede buscar actualizaciones.
  • ¡Error! No se puede mostrar el catálogo.
  • Instalación incorrecta.
  • No se puede mostrar el catálogo Office Update.
  • El sitio Office Update es incapaz de comprobar si hay actualizaciones en este equipo.
  • Error 0x80070641
  • Error 0x51F
  • Error 0x530
  • Error 80070643
El sitio Web de Office Update ofrece actualizaciones que mejoran la estabilidad y la seguridad de Microsoft Office. Para obtener actualizaciones para Office, visite el siguiente sitio Web de Microsoft:

Más información

Para solucionar problemas en el proceso de actualización de Office desde el sitio Web de Office Update, utilice los métodos siguientes en el orden que se presentan. Después de completar cada método, pruebe a actualizar Microsoft Office desde el sitio Web de Office Update.

Nota: Cuando tiene acceso al sitio Web de Office Update con determinados exploradores de otros fabricantes o determinados navegadores que son proporcionados por un proveedor de servicios Internet (ISP), el sitio Web de Office Update no funcionen correctamente. O bien, el explorador puede requerir una configuración especial para tener acceso correctamente al sitio Web de Office Update. Si Internet Explorer está disponible en el equipo, conectar a Internet mediante la conexión del ISP. A continuación, tener acceso al sitio Web de Office Update mediante Internet Explorer.

Método 1: Eliminar el contenido de la carpeta de caché de Microsoft Internet Explorer, cookies, historial y la carpeta temporal del sistema operativo

Si la carpeta temporal de caché de Internet Explorer empieza a quedarse sin espacio de disco asignado, es posible que no se descarga el control de Office Update. Espacio libre en disco mediante la eliminación de la caché de archivos temporales de Internet.

Para ello, siga estos pasos:
  1. Inicie Internet Explorer.
  2. En el menú Herramientas, haga clic en Opciones de Internet.
  3. Haga clic en la ficha General y, a continuación, haga clic en Eliminar archivos en
    Archivos temporales de Internet.
  4. Haga clic para desactivar la casilla de verificación Eliminar todo el contenido sin conexión y, a continuación, haga clic en Aceptar.
  5. Haga clic en Eliminar Cookiesy, a continuación, haga clic en Aceptar cuando se le pida confirmación.
  6. En Archivos temporales de Internet, haga clic en Configuración.
  7. En el cuadro de diálogo configuración , haga clic en Ver objetos.
  8. En la ventana del explorador de Microsoft Windows que aparecerá, haga clic en Detalles en el menú Ver .
  9. Si el estado de algún objeto mostrado está dañado, elimine el objeto.
  10. Cierre la ventana del explorador de Windows y, a continuación, haga clic en Aceptar en el cuadro de diálogo de configuración .
  11. En historial, haga clic en Borrar historialy, a continuación, haga clic en cuando se le pida confirmación.
  12. En el cuadro de diálogo Opciones de Internet , haga clic en Aceptar.
  13. Habilitar las cookies. Para ello, siga estos pasos:
    1. En el Panel de Control, haga doble clic en el icono Opciones de Internet .
    2. Haga clic en la ficha privacidad y, a continuación, haga clic en predeterminado.
    3. Haga clic en Aceptar.
  14. Haga clic en Inicio, haga clic en Ejecutar , escriba % temp %y, a continuación, haga clic en Aceptar.
  15. En la ventana del explorador que aparece, elimine el contenido de esta carpeta Temp. Nota: Cualquier archivo que no se puede eliminar probablemente está siendo utilizado. Asegúrese de que ha cerrado todas las aplicaciones que se estaban ejecutando. A continuación, intente eliminar de nuevo el contenido de esta carpeta. Si no puede eliminar un archivo concreto, elimine todos los archivos que puede eliminar.

Método 2: Instalar Microsoft Windows Script 5.6 para Windows 2000 y XP

Instale Windows Script 5.6. Para obtener Windows Script 5.6, visite el siguiente sitio Web de Microsoft:
Una vez instalada esta herramienta de secuencias de comandos, intente instalar actualizaciones desde el sitio Web de Office Update.

Método 3: Eliminar la carpeta de detección de Office Update

Elimine la carpeta de detección de Office Update si existe en el disco duro. Esta carpeta contiene el catálogo de detección y los archivos de actualización descargados utilizados por el sitio de Office Update.

Para eliminar la carpeta de detección de Office Update, siga estos pasos.

Nota: como hay varias versiones de Microsoft Windows, los pasos siguientes pueden ser diferentes en su equipo. Si es así, consulte la documentación del producto para completar estos pasos.
  1. Haga clic en Inicio, seleccione Todos los programas, haga clic en Accesoriosy, a continuación, haga clic en
    El Explorador de Windows.
  2. En el Explorador de Windows, busque la carpeta OfficeUpdate11 u OfficeUpdate12 . De forma predeterminada, la carpeta está en la ubicación siguiente:
    C:\Program Files\OfficeUpdate11
    o
    C:\Program Files\OfficeUpdate12
  3. Haga clic en la carpeta OfficeUpdate11 u OfficeUpdate12 y, a continuación, haga clic en Eliminar.

    Cuando se le pida que confirme la eliminación, haga clic en
    .
  4. Cierre el Explorador de Windows.
Nota: Después de actualizar la actualización de Office desde el sitio Web de Office Update, se elimina la carpeta C:\program programa\OfficeUpdate11. En su lugar, se crea la carpeta OfficeUPdate12 en la ruta de acceso local % appdata %. Para la última actualización de Office, se usa la carpeta OfficeUpdate12.

Método 4: Eliminar el control ActiveX de Office Update

El control ActiveX de Office Update puede dañarse. Por lo tanto, tendrá que quitar y volver a instalar el control ActiveX de Office Update.

Para quitar y volver a instalar el control ActiveX de Office Update, siga estos pasos.

Nota: como hay varias versiones de Microsoft Windows, los pasos siguientes pueden ser diferentes en su equipo. Si es así, consulte la documentación del producto para completar estos pasos.
  1. Salga de Internet Explorer.
  2. Haga clic en Inicioy, a continuación, haga clic en
    Búsqueda.
  3. En el panel de Resultados de la búsqueda , haga clic en
    Todos los archivos y carpetas del Asistente para búsqueda.
  4. En el cuadro todo o parte del nombre de archivo , escriba opuc.dlly, a continuación, haga clic en Buscar.
  5. En la lista de archivos, haga opuc.dlly, a continuación, haga clic en Eliminar.

    Cuando se le pida que confirme la eliminación, haga clic en .
Nota: Si hay varias copias del archivo opuc.dll, elimínelas todas.

Método 5: Desactivar cortafuegos personales temporalmente, descargue los administradores, los bloqueadores de elementos emergentes y los productos de aceleración Web

Si está utilizando uno de los siguientes productos, desactívelo temporalmente y pruebe a utilizar el sitio Office Update:
  • Servidores de seguridad personales como Norton Personal Firewall, McAfee Personal Firewalls o Zone Labs
  • Administradores de descargas como Get Right
  • Aceleradores Web como Download Accelerator
  • Bloqueadores de elementos emergentes
Advertencia: Esta solución puede hacer que su equipo o su red sean más vulnerables a los ataques de usuarios malintencionados o de software malintencionado, como virus. No recomendamos esta solución, pero proporcionamos esta información para que puede implementar esta solución temporal a su propia discreción. Utilice esta solución bajo su propia responsabilidad.

Para desactivar temporalmente uno de estos productos, siga estos pasos:
  1. Desactivar el servidor de seguridad personal, Administrador de descargas, el bloqueador de elementos emergente o programa de aceleración Web. Para obtener más información acerca de cómo hacerlo, vea la documentación de personal firewall, Administrador de descargas, Bloqueador de elementos emergente o programa de aceleración Web.
  2. Pruebe a utilizar el sitio de Office Update. Para ello, visite el siguiente sitio Web de Microsoft y, a continuación, haga clic en Buscar actualizaciones:
  3. Tan pronto como se complete el proceso de actualización del sitio Web de Office Update, active el firewall personal, Administrador de descargas, el bloqueador de elementos emergente o programa de aceleración Web que desactivó en el paso 1.

Método 6: Configurar opciones de seguridad de Internet Explorer y agregue http://office.microsoft.com a la lista de sitios de confianza

Configurar opciones de seguridad de Internet Explorer para permitir que Internet Explorer registre controles ActiveX firmados.

Importante: Estos pasos pueden aumentar su riesgo de seguridad. Estos pasos también pueden hacer que su equipo o su red sean más vulnerables a los ataques de usuarios malintencionados o de software malintencionado, como virus. Recomendamos el proceso que se describe en este artículo para permitir que los programas funcionen como están diseñados o para implementar determinadas funciones del programa. Antes de realizarlos, recomendamos que evalúe los riesgos asociados con la implementación de este proceso en su entorno particular. Si decide implementar este proceso, tome las medidas adicionales oportunas para ayudar a proteger su sistema. Se recomienda que utilice este proceso sólo si realmente lo necesita este proceso.

Para permitir que Internet Explorer registre controles ActiveX firmados, siga estos pasos:
  1. Inicie Internet Explorer.
  2. En el menú Herramientas, haga clic en Opciones de Internet.
  3. Haga clic en la ficha seguridad y, a continuación, haga clic en
    Internet.
  4. Haga clic en Nivel predeterminadoy, a continuación, haga clic en
    OK.
Agregue http://office.microsoft.com a la lista de sitios de confianza de Internet Explorer para que el control ActiveX de Office Update pueda cargarse correctamente.

Para ello, siga estos pasos:
  1. Inicie Internet Explorer.
  2. En el menú Herramientas, haga clic en Opciones de Internet.
  3. Haga clic en la ficha seguridad , haga clic en
    Sitios de confianzay, a continuación, haga clic en
    Sitios.
  4. Borrar el Requerir comprobación del servidor (https:) para todos los sitios de esta zona casilla de verificación.
  5. En el cuadro Agregar este sitio Web a esta zona, escriba http://office.microsoft.comy, a continuación, haga clic en
    Agregar.
  6. Haga clic en Aceptar dos veces.

Método 7: Identifique y corrija las instalaciones de Office dañadas

La detección puede fallar si hay instalaciones dañadas de productos de Microsoft Office en el equipo. Los productos de Office son programas basados en Microsoft Windows Installer. Si la base de datos de Windows Installer en el equipo no funciona correctamente o si faltan archivos MSP en caché, la detección puede fallar. Puede identificar y corregir las instalaciones de Office dañadas. Para ello, siga estos pasos:
  1. Quitar los programas de Office que ya no desea instalados en el equipo utilizando Agregar o quitar programas en Panel de Control.

    Nota: Cuando vea Agregar o quitar programas, busque los programas de Office que cree que se hubiera quitado pueden estar aún presentes en el equipo. Si encuentra algún programa que cumpla este criterio, quítelo.
  2. Abra un producto de Office, haga clic en Ayuday, a continuación, haga clic en detectar y reparar.
Repita este proceso para todos los programas de Office. Si se produce un error de proceso de detectar y reparar, su origen/caché de instalación de Office puede estar dañada. Si éste es el caso, ejecute el FixIt en el siguiente artículo. Si sigue sin funcionar el proceso detectar y reparar y el proceso de desinstalación, debe quitar manualmente la oficina instalaciones - póngase en contacto con Microsoft Support como se indicó anteriormente:

Cómo solucionar problemas de daños de registro de actualización de software MSI

Además de instalaciones de Office dañadas, es posible que con las instalaciones de Office 2003, los archivos de origen de instalación Local se han eliminado. Normalmente, se le pedirá el medio de instalación cuando se produce este comportamiento y cuando se necesitan archivos de código fuente. Sin embargo, esto no siempre es posible. Puede recibir un mensaje de error que indica que el programa de instalación no puede encontrar uno de los archivos de instalación. Para obtener más información acerca de errores relacionados con el origen de instalación Local cuando intenta realizar la actualización desde el sitio Web de Office Update, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

875556 "Error de instalación: archivo no encontrado" mensaje de error cuando intenta actualizar los programas de Office 2003 desde el sitio Web de Office Update

Método 8: Deshabilitar a la configuración de secuencia de comandos o de proxy

Para ello, siga estos pasos:
  1. En el Panel de Control, haga doble clic en el icono Opciones de Internet .
  2. Haga clic en la ficha conexiones y, a continuación, haga clic en Configuración de LAN.
  3. Haga clic para desactivar la casilla de verificación usar scripts de configuración automática y, a continuación, haga clic para desactivar la casilla de verificación utilizar un servidor proxy .
  4. Asegúrese de que está activada la casilla de verificación detectar la configuración automáticamente .
  5. Haga clic en Aceptar dos veces para cerrar el cuadro de diálogo Propiedades de Internet .

Método 9: Realizar un inicio limpio del equipo, según el sistema operativo

Intente actualizar desde el sitio Web de Office Update después de iniciar el equipo utilizando el método de inicio limpio apropiado mencionado en los siguientes artículos de Microsoft Knowledge Base: para obtener más información acerca de cómo realizar una limpieza, arranque Windows XP y en Windows Server 2003, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base :

310353 cómo realizar un inicio limpio en Windows XP

Para obtener más información acerca de cómo realizar un inicio limpio en Windows 2000, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

281770 cómo realizar la solución de problemas de inicio limpio para Windows 2000

Para obtener más información acerca de cómo realizar un inicio limpio en Windows Millennium Edition, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

267288 cómo realizar un inicio limpio en Windows Millennium Edition

Para obtener más información acerca de cómo realizar un inicio limpio en Windows 98, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

192926 cómo realizar la solución de problemas de inicio limpio de Windows 98

Método 10: Solucionar problemas de conexión de red

Error de detección puede deberse a problemas de conexión de red.

Si tiene un segundo equipo conectado a Internet, intente utilizar otro equipo para tener acceso al sitio Web de Office Update.

Si no puede utilizar el proceso de instalación de Office Update porque su equipo está detrás de un servidor proxy y el servidor proxy impide que el proceso de instalación de Office Update funciona correctamente, tendrá que ponerse en contacto con su administrador de red o su proveedor de servicios Internet (ISP) para obtener ayuda para eludir o configurar el servidor proxy.

Método 11: Descargue e instale la actualización manualmente

Puede instalar manualmente cada actualización. Para ello, siga estos pasos:
  1. Busque el siguiente sitio Web de Microsoft:
  2. En Examinar descargas, haga clic en la versión de Office que desee descargar actualizaciones para y, a continuación, seleccione el producto de Office que desea descargar una actualización para.
  3. Seleccione el tipo de descarga que desea instalar y, a continuación, seleccione la descarga específica. La siguiente página que verá es la página de descarga para la actualización.
  4. Haga clic en Descargar.
  5. En el cuadro de diálogo Descarga de archivos , haga clic en Guardar.
  6. Busque la carpeta donde desea guardar el archivo y, a continuación, haga clic en Guardar.
  7. Una vez finalizada la descarga, haga doble clic en el archivo descargado para instalarlo. Repita estos pasos para cada actualización que desee instalar.

Método 12: Cambiar el tipo de inicio para Windows Installer manual

Para cambiar el Tipo de inicio para Windows Installer, siga estos pasos:
  1. Haga clic en Inicio, haga clic en Ejecutar, escriba services.msc y, a continuación, haga clic en Aceptar.
  2. Haga clic en Windows Installer y, a continuación, haga clic en Propiedades.
  3. En la ficha General , haga clic en Manual en la lista tipo de inicio y, a continuación, haga clic en Aceptar.

Método 13: Deshabilitar y volver a habilitar el origen de instalación Local utilizando la herramienta Local Installation Source

  1. Cierre todos los programas de Office.
  2. Busque el siguiente sitio Web de Microsoft:
  3. Haga clic en Descargar.
  4. En el cuadro de diálogo Descarga de archivos , haga clic en Guardar.
  5. Busque la carpeta donde desea guardar el archivo LISTool.exe y, a continuación, haga clic en Guardar.
  6. Abra la carpeta donde guardó la herramienta Local Installation Source y, a continuación, haga doble clic en LISTool.exe.
  7. Haga clic en eliminar y deshabilitar LISy, a continuación, haga clic en siguiente.
  8. Acepte los términos de licencia del Software de Microsoft y, a continuación, haga clic en siguiente.
  9. Haga clic para activar la casilla de verificación del programa para el que desea deshabilitar el origen de instalación Local, haga clic en siguientey, a continuación, haga clic en Eliminar.
  10. Haga clic en Aceptar cuando reciba el mensaje siguiente:
    Origen de instalación Local de Microsoft Office se elimina correctamente y deshabilitado.
  11. Ejecutar detectar y reparar para el producto que se deshabilitó mediante LISTools.
  12. Una vez completada la actualización, ejecute de nuevo LisTool.exe y seleccione la opción Enable LIS .
  13. Acepte los términos de licencia del Software de Microsoft y, a continuación, haga clic en siguiente.
  14. Haga clic para activar la casilla de verificación del programa para el que desea habilitar el origen de instalación Local y, a continuación, haga clic en siguiente.
  15. Haga clic en Habilitar.
  16. Haga clic en Aceptar cuando reciba el mensaje siguiente:
    Origen de instalación Local de Microsoft Office se ha habilitado correctamente.
Propiedades

Id. de artículo: 304498 - Última revisión: 22 ene. 2017 - Revisión: 1

Microsoft Office Professional Edition 2003, Microsoft Office Small Business Edition 2003, Microsoft Office Basic Edition 2003, Microsoft Office XP Professional Edition, Microsoft Office XP Small Business Edition, Microsoft Office XP Standard Edition, Microsoft Office XP Developer Edition, Microsoft Office 2000 Premium Edition, Microsoft Office 2000 Professional Edition, Microsoft Office 2000 Standard Edition, Microsoft Office 2000 Small Business Edition, Microsoft Office 2000 Developer Edition

Comentarios