Mensajes de error cuando intenta tener acceso a un volumen NTFS

En este artículo se aplica a Windows 2000. De soporte técnico para Windows 2000 finaliza el 13 de julio de 2010. El Centro de soluciones de fin de soporte de Windows 2000 es un punto de partida para planear la estrategia de migración desde Windows 2000. Para obtener más información, consulte la Directiva de ciclo de vida de soporte técnico de Microsoft.

Síntomas

Cuando intenta tener acceso a un volumen de sistema de archivos NTFS, puede recibir uno de los mensajes de error siguientes en el símbolo del sistema o en Microsoft Internet Explorer.
  • Símbolo del sistema

    Mensaje 1
    C:\ > F:
    La estructura del disco está dañado y es ilegible.
    Mensaje 2
    C:\ > F:
    No hay suficiente espacio en el disco.
  • Internet Explorer

    Mensaje 1
    F:\is no está accesible.
    La estructura del disco está dañado y es ilegible.
    Mensaje 2
    F:\is no está accesible.
    No hay suficiente espacio en el disco.
Si el volumen está dañado es también el volumen de sistema o de inicio, también puede recibir el siguiente mensaje de error al iniciar el equipo (donde el segundo parámetro es 0xC0000032 DISK_CORRUPTION_ERROR):
Stop 0x0000007B (0 x 00000000, 0xC0000032, 0 x 00000000, 0 x 00000000)
Inaccessible_boot_device
Cuando intenta instalar Windows 2000 en el volumen NTFS, puede recibir el siguiente mensaje:
Windows 2000 reconoce la partición elegida, pero la partición sin formato o está dañada. Para instalar Windows 2000 en esta partición, el programa de instalación debe formatearlo.
Si iniciar la consola de recuperación de Windows 2000 e intenta utilizar el comando dir para ver el contenido del volumen, puede recibir el siguiente mensaje de error:
Directorio de F:\
Se ha producido un error durante la enumeración de directorios.
Al ejecutar la herramienta Chkdsk en el volumen, el procedimiento finaliza, no se detectan errores y no se realizan correcciones. Sin embargo, no podrá tener acceso a o inicio del volumen y recibe el mensaje de error. Además, si ejecuta el chkdsk
volume_drive_letter: /p comandos de la consola de recuperación con ese volumen (donde
volume_drive_letter es la letra de unidad de volumen), no se detectan errores.

Causa

Este problema se produce porque el volumen NTFS tiene un no válido o dañado el registro en el archivo $UsnJrnl o el archivo $LogFile. Ambos de estos archivos son archivos internos que utilizan sólo NTFS; CHKDSK no comprueba la integridad de estos dos archivos. CHKDSK sólo garantiza que la tabla maestra de archivos (MFT) tiene entradas para estos archivos y que las entradas son entradas válidas.

Solución

Para resolver este problema si recibe un mensaje de error "stop 0x0000007b" al iniciar el equipo, utilice uno de los métodos siguientes.

Método 1

Utilice la consola de recuperación de Microsoft Windows Server 2003 o de Microsoft Windows XP para reparar el archivo $UsnJrnl. Windows XP y Windows Server 2003 contienen cambios Ntfs.sys que omita las entradas dañadas en el archivo $UsnJrnl y montar automáticamente y corregir archivos de secuencia de datos dañado durante el montaje.
  1. Reinicie el equipo basado en Windows 2000 para la consola de recuperación mediante un CD del sistema operativo Windows Server 2003 o Windows XP. Asegúrese de que carga el controlador de dispositivo de almacenamiento masivo de terceros correcto.
    Para obtener más información acerca de cómo obtener los discos de instalación de Windows XP para reiniciar la consola de recuperación, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

    Cómo 310994 obtener discos de inicio de instalación de Windows XP

  2. Haga clic en Inicio, haga clic en Ejecutar, escriba Chkdsk.exe /r y, a continuación, haga clic en Aceptar.
  3. Reinicie el equipo basado en Windows 2000.

Método 2

Utilice la herramienta Fsutil.exe desde un CD-ROM de Windows XP para eliminar el diario USN/cambiar:
  1. Copie el archivo Fsutil.exe desde un CD-ROM de Windows XP en el equipo que desea eliminar el diario USN/cambiar en.
  2. Haga clic en Inicio, haga clic en Ejecutar, escriba cmd y, a continuación, haga clic en Aceptar.
  3. Cambie al directorio que ha copiado el archivo Fsutil.exe en el paso 1. Por ejemplo, si copió el archivo Fsutil.exe en la carpeta raíz de la unidad C, escriba cd c:\y, a continuación, presione ENTRAR.
  4. En el símbolo del sistema, escriba fsutil usn deletejournal /D letra de unidady, a continuación, presione ENTRAR, donde letra de unidad es la unidad que contiene el diario USN o cambio que desee eliminar.
  5. Si desea crear un nuevo diario USN/cambiar, ejecutar el
    comando chkdsk /f en la unidad que se ha eliminado el diario desde.

Método 3

Mover esa unidad a otro equipo que ejecuta Windows 2000 para realizar reparaciones.

También puede utilizar Chkdsk para volver a inicializar el archivo $LogFile pero no el archivo $UsnJrnl porque no todos los volúmenes NTFS contienen un archivo $UsnJrnl. Sólo cuando un programa que utiliza el archivo realiza la primera solicitud de escritura, se crea un archivo $UsnJrnl en un volumen.

CHKDSK se sólo volver a inicializar el archivo $LogFile cuando cambia el tamaño del archivo de registro mediante el de chkdsk volume_drive_letter: /l:new_size/f comando. Por ejemplo, si escribe chkdsk f: /f /l:65536.

Si el problema persiste después de cambiar el tamaño del archivo $LogFile, póngase en contacto con los servicios de soporte técnico de Microsoft para obtener más ayuda con este problema. Para obtener una lista completa de números de teléfono de servicios de soporte técnico de Microsoft e información acerca de los costos de soporte técnico, visite el siguiente sitio Web de Microsoft:

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Si Chkdsk se ejecuta y no encontró problemas pero recibe un mensaje de error "acceso denegado" cuando intenta tener acceso al volumen, hay permisos NTFS incorrectos. Puede utilizar el comando siguiente cuando inicia sesión como un administrador para conceder todos "Control total" de la carpeta raíz y las subcarpetas. Esto también permite que el volumen sea accesible.
c:\>cacls  volume_drive_letter :\ /g everyone:F /c /t 
Propiedades

Id. de artículo: 311724 - Última revisión: 9 ene. 2017 - Revisión: 1

Comentarios