"Se necesita el archivo 'Asms' en CD-ROM de Windows XP Professional" error mensaje al instalar Windows XP

Síntomas

Al instalar Microsoft Windows XP, puede recibir el siguiente mensaje de error:
[Se necesitan archivos]

Se necesita el archivo 'Asms' en CD-ROM de Windows XP Professional. Escriba la ruta de acceso donde se encuentra el archivo y, a continuación, haga clic en Aceptar.

Causa

Este problema puede producirse si el programa de instalación no puede comunicarse con la unidad de CD-ROM.

Solución

Para resolver este problema, utilice el método apropiado para su equipo.

Disco duro formateado con el sistema de archivos FAT o FAT32

Si el disco duro está formateado con el sistema de archivos FAT o con el sistema de archivos FAT32, siga estos pasos:
  1. Utilice un disco de inicio de Microsoft Windows Millennium Edition (Me) o Microsoft Windows 98 Segunda edición con controladores de CD-ROM para reiniciar el equipo.
  2. Copie la herramienta Xcopy.exe desde el CD-ROM de Windows 98 Segunda edición, el CD-ROM de Windows Millennium Edition (Me) o el disco duro en el disco de inicio de Windows. Para ello, utilice el método apropiado.

    CD-ROM de Windows 98 Segunda edición

    Insertar el Windows 98 Second Edition CD-ROM en la unidad de CD-ROM o DVD-ROM y, a continuación, en el comando del sistema, escriba las líneas siguientes, presionando ENTRAR después de escribir cada línea, donde
    CD-ROM es la letra de unidad de la unidad de CD-ROM o DVD-ROM:
    c:
    copiar CD-ROM: \win98\smartdrv.exe
    copiar CD-ROM: \tools\oldmsdos\xcopy*.*

    Windows Millennium Edition (Me) CD-ROM

    Insertar el Windows Millenium CD-ROM en la unidad de CD-ROM o DVD-ROM, en el símbolo del sistema escriba las líneas siguientes donde
    CD-ROM es la letra de unidad de la unidad de CD-ROM o DVD-ROM y, a continuación, presione ENTRAR después de escribir cada línea:
    c:
    copiar CD-ROM: \win9x\smartdrv.exe
    Extraiga el CD-ROM: \win9x\win_17.cab xcopy.exe /L c:\ xcopy.exe
    Extraiga el CD-ROM: \win9x\win_17.cab xcopy32.exe /L c:\ xcopy32.exe
    Extraiga el CD-ROM: \win9x\win_19.cab xcopy32.mod /L c:\ xcopy32.mod

    Disco duro

    En el símbolo del sistema, escriba las líneas siguientes donde
    unidad es la letra de unidad del disco duro donde está instalado Windows y, a continuación, presione ENTRAR después de escribir cada línea:
    c:
    copiar unidad: \windows\smartdrv.*
    copiar unidad: \windows\xcopy*.*
  3. Expulse el Windows 98 o Windows Millennium Edition (Me) CD-ROM y, a continuación, inserte el CD-ROM de Windows XP Professional.
  4. Copie la carpeta I386 y todas sus subcarpetas en el disco duro. Para ello, escriba las líneas siguientes en el símbolo del sistema donde
    CD-ROM es la letra de unidad de la unidad de CD-ROM, y
    unidad es la letra de unidad del disco duro y, a continuación, presione ENTRAR después de escribir cada línea:
    Smartdrv
    xcopy CD-ROM: \i386 unidad: \i386 /e
  5. Reinicie el equipo y, a continuación, inicie de nuevo el programa de instalación.
  6. Cuando reciba el mensaje de error, haga clic en Examinary, a continuación, escriba la ruta de acceso de la carpeta I386 en el disco duro.


    Nota: Le pedirá varias veces para la ubicación de esta carpeta. Si Buscar no está disponible, consulte la sección "disco duro formateado con el sistema de archivos NTFS".

Disco duro formateado con el sistema de archivos NTFS

Si el disco duro está formateado con el sistema de archivos NTFS y está actualizando una versión anterior de Windows, utilice uno de los métodos siguientes.

Método 1

Importante: esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que sigue estos pasos cuidadosamente. Para una mayor protección, haga una copia de seguridad del registro antes de modificarlo. Entonces, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo hacer copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 cómo hacer copia de seguridad y restaurar el registro en Windows
  1. Cuando reciba el mensaje de error, presione MAYÚS+F10 para iniciar una sesión de comandos.
  2. Escriba regedit.exey, a continuación, presione ENTRAR.
  3. Haga clic en HKEY_LOCAL_MACHINE.
  4. En el menú archivo , haga clic en Cargar subárboly, a continuación, cargue % Windir%\System32\Config\System.sav.
  5. Cuando se le pida que especifique un nombre, escriba
    Prueba.
  6. Busque y, a continuación, haga clic en la clave siguiente:
    HKEY_LOCAL_MACHINE\Test\ControlSet1\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}
  7. Elimine las claves del registro UPPERFILTERS y LOWERFILTERS .
  8. Repita los pasos 6 y 7 para las otras claves ControlSet# debajo del subárbol Test.
  9. Haga clic en archivoy, a continuación, haga clic en
    Exit para salir del Editor del registro.
  10. Si la ruta de acceso en el mensaje de error es la letra de unidad correcta para la unidad de CD-ROM, haga clic en Aceptar para continuar con el programa de instalación.
  11. Si recibe el mensaje de error, el programa de instalación no puede leer correctamente desde la unidad de CD-ROM o la información de ruta de acceso es incorrecta. En este caso, reinicie el equipo y deje que el programa de instalación a reanudar.

Método 2

Si no puede iniciar Regedit.exe en el símbolo del sistema y hay otra partición disponible donde puede instalar Windows en el disco duro, siga estos pasos:
  1. Instale Windows en la otra partición.
  2. Inicie la nueva instalación de Windows y, a continuación, inicie Regedit.exe.
  3. Siga los pasos del método 1, pero cargue la sección System.sav desde la carpeta original de Windows.

Método 3

Si no está utilizando un CD-ROM de Windows XP comercial con un holograma (por ejemplo, si está utilizando un CD-ROM grabado), intente ejecutar el programa de instalación desde un CD-ROM de comercial con un holograma. Para comprobarlo, inicie el equipo mediante la consola de recuperación y, a continuación, compruebe la carpeta C:\$win_nt$.~ls. Busque la carpeta Asms. Si falta la carpeta o los archivos que contiene son cero bytes, el CD-ROM no se grabó correctamente.

Para obtener información adicional acerca de cómo utilizar la consola de recuperación, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
307654 HOW TO: instalar y usar la consola de recuperación en Windows XP

Propiedades

Id. de artículo: 311755 - Última revisión: 22 ene. 2017 - Revisión: 2

Comentarios