Conexión SSL no funciona en Windows XP

Síntomas

Cuando se conecta a un servidor Web utilizando un certificado de servidor autofirmado a través de una conexión Secure Sockets Layer (SSL), Microsoft Internet Explorer puede generar un mensaje de error que indica que no se pudo encontrar el servidor e Internet Explorer, a continuación, no pueden conectarse.

Causa

Este problema puede deberse si el archivo Crypt32.dll determina incorrectamente que el certificado del servidor no es válido. Además, también pueden surgir este problema si tiene uno de los siguientes programas de firewall instalados en el equipo:
  • Firewall de libertad
  • Zone Alarm por Zonelabs
  • McAffee VirusScan y Firewall
  • Norton Personal Firewall de Symantec
  • BlackICE PC Protection

Solución

Información del Service pack

Para resolver este problema, obtenga el service pack más reciente para Windows XP. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389 cómo obtener el service pack más reciente para Windows XP

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en la herramienta fecha y hora del Panel de Control.
   Date         Time   Version        Size     File name
-------------------------------------------------------
19-Dec-2001 09:53 5.131.2600.24 544,256 Crypt32.dll

Solución alternativa

Si instala la revisión enumerada en la sección resolución y sigue experimentando el problema que se describe en la sección síntomas, deshabilitar cualquiera de los productos de servidor de seguridad que se enumeran en la sección causa que están instalados en el equipo. Para ello, siga estos pasos:
  1. Haga clic en Inicio, haga clic en Ejecutar, en el cuadro Abrir , escriba msconfigy, a continuación, presione ENTRAR.
  2. Haga clic en la ficha Servicios.
  3. Bajo servicio, desplácese por la lista para encontrar el servicio que corresponde al programa de firewall que está instalado en el equipo.
  4. Haga clic para desactivar la casilla de verificación situada junto al nombre del servicio de servidor de seguridad que encontró en el paso 3 y, a continuación, haga clic en
    Aplicar.
  5. Reinicie el equipo.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a". Este problema se corrigió primero en Windows XP Service Pack 1.
Propiedades

Id. de artículo: 314864 - Última revisión: 22 ene. 2017 - Revisión: 1

Comentarios