Programa abre un archivo como de sólo lectura o devuelve una infracción mensaje "acceso denegado" cuando abre desde o guarda en una carpeta de red

Síntomas

Si abre una carpeta de red en el Explorador de Windows y, a continuación, intente abrir un archivo desde o guarda un archivo en esa carpeta, el programa asociado puede informar sobre una infracción de uso compartida, devolver un mensaje de "error acceso denegado" o abra el documento como de sólo lectura. Normalmente, este problema se produce cuando se abre una carpeta de red y, a continuación, haga doble clic para abrir un archivo de Microsoft Word o Microsoft Excel. El documento se abre como de sólo lectura.

Causa

Este problema puede producirse cuando el controlador de columnas de Shell de Microsoft Windows XP lee el contenido del archivo en la carpeta de red para obtener información adicional, como el autor o el asunto, al mismo tiempo que el programa asociado intenta abrir o guardar el archivo.

Solución

Información del Service pack

Para resolver este problema, obtenga el service pack más reciente para Microsoft Windows XP. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389 cómo obtener el service pack más reciente para Windows XP

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma. La versión en inglés de esta revisión tiene los atributos de archivo (o posterior) que figuran en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en la herramienta fecha y hora del Panel de Control.
   Date         Time   Version        Size       File name
-------------------------------------------------------------------------
15-Jan-2003 13:00 6.0.2800.1157 8,240,128 Shell32.dll


Nota: Se trata de una corrección de cliente que debe estar instalada en el equipo que tiene acceso el recurso compartido remoto.

Solución alternativa

Para evitar este problema, realice lo siguiente:
  1. En el Explorador de Windows, abra la carpeta de red que contiene el archivo que intenta abrir o guardar.
  2. En el menú Herramientas, haga clic en Opciones de carpeta.
  3. Haga clic en las carpetas clásicas de usar Windowsy, a continuación, haga clic en Aceptar.
Con fines de prueba, puede cambiar la siguiente clave del registro. Esto evita que el shell de abrir el archivo y extraer la información de columna opcionales. Cambiar la clave de esta clave:
HKEY_CLASSES_ROOT\Folder\Shellex\ColumnHandlers\{24F14F01-7B1C-11d1-838f-0000F80461CF}
Utilice en su lugar la siguiente clave:
HKEY_CLASSES_ROOT\Folder\Shellex\ColumnHandlers\{24F14F01-7B1C-11D1-838f-0000F80461CF}-Disable

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a". Este problema se corrigió primero en Microsoft Windows XP Service Pack 2.

Más información

De forma predeterminada, después de instalar el hotfix, el shell de Windows XP ya no intentará leer todo el archivo para extraer archivo atributos si el archivo se encuentra en un recurso compartido UNC, pero todo el archivo aún se puede lee si los datos están en una unidad asignada. Las descripciones emergentes para carpetas y elementos del escritorio se mostrará el tipo, tamaño y fecha de modificación de los archivos que se encuentran en la red.

Para mostrar la información de columna adicional, siga estos pasos:
  1. En el menú Ver , haga clic en
    Detalles.
  2. Haga clic en el encabezado de columna y, a continuación, haga clic para colocar una marca de verificación junto a los atributos adicionales que desee que aparezca.
Si se muestran las columnas adicionales, hay posibilidades de ese problema que se describe en este artículo puede producirse si el programa intenta abrir el archivo exclusivamente al mismo tiempo que el Explorador de Windows está extrayendo datos de la columna. Para evitar el problema, no muestran información de columna adicional.

Este hotfix también resuelve problemas de rendimiento de red de baja velocidad en una red de área extensa (WAN) o red saturada. Explorer ya no abre el archivo de forma remota, el tráfico de red se reduce considerablemente.

Para obtener información adicional acerca de cómo resolver este problema en las unidades asignadas, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
816627 impresión de puerto TCP/IP puede ser lenta en Windows 2000
Propiedades

Id. de artículo: 328170 - Última revisión: 17 feb. 2017 - Revisión: 2

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