Rendimiento lento y uso elevado de CPU en Microsoft Entra agente de supervisión de Connect Health for Sync en un sistema que ha instalado .NET Framework

En este artículo se describe un problema que provoca un rendimiento lento y un uso elevado de la CPU en Microsoft Entra agente de supervisión de Connect Health for Sync en un sistema que ha instalado .NET Framework 4.7.2 o las actualizaciones de julio de 2018 para .NET Framework 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1 o 4.7.2.

Versión del producto original: Microsoft Entra ID
Número de KB original: 4457331

Síntomas

Supongamos que ejecuta el agente de supervisión de Microsoft Entra Connect Health for Sync en un sistema que ha instalado .NET Framework 4.7.2 o las actualizaciones de julio de 2018 para .NET Framework 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1 o 4.7.2. En este escenario, el sistema puede experimentar un rendimiento lento y un uso elevado de la CPU.

Para ver el uso elevado de CPU, inicie el Administrador de tareas y vea el uso de CPU del proceso MIcrosoft.Online.Reporting.MonitoringAgent.Startup en la pestaña Procesos .

Causa

Este problema se produce porque el agente de supervisión de connect health for Sync de Microsoft Entra no admite completamente .NET Framework 4.7.2 ni las actualizaciones de julio de 2018 para .NET Framework 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1 o 4.7.2. Las siguientes actualizaciones pueden provocar un uso elevado de cpu del agente de supervisión.

Actualizaciónde .NET Framework Versión del servidor Tipo de actualización
KB 4340007 Windows Server 2008 Seguridad
KB 4340556 Windows Server 2008 R2 Seguridad
KB 4340004 Windows Server 2008 R2 Seguridad
KB 4340557 Windows Server 2012 Seguridad
KB 4340005 Windows Server 2012 Seguridad
KB 4340558 Windows Server 2012 R2 Seguridad
KB 4340006 Windows Server 2012 R2 Seguridad
KB 4054542 Windows Server 2012 No seguridad
KB 4054566 Windows Server 2012 R2 No seguridad
KB 4054590 Windows Server 2016 No seguridad
KB 4338814 Windows Server 2016 (compilación 14393.2363) No seguridad
KB 4345418 Windows Server 2016 (compilación 14393.2368) No seguridad

Solución

Para resolver este problema, instale la actualización adecuada para su entorno.

  • Para Connect Health para AD DS y AD FS

    Instale el Microsoft Entra Connect Health Agent, versión 3.1.7.0 publicada en julio de 2018. Esta actualización está disponible para [descargar aquí]/azure/active-directory/hybrid/how-to-connect-health-agent-install#download-and-install-the-azure-ad-connect-health-agent).

  • Para Microsoft Entra Conectar

    Instale la versión más reciente de Microsoft Entra Connect que contiene la corrección de este problema de uso elevado de la CPU. Esta versión está disponible para su descarga aquí.

    Nota:

    Si ha habilitado la característica de actualización automática en el servidor de Microsoft Entra Connect, la versión más reciente se instalará automáticamente.

Notificación de examen de virus

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