Se produce un error en Ks.sys en los equipos con CPU Hyper-Threading de Intel

Síntomas

KS.sys puede bloquearse si varias veces iniciar y detener un gráfico Hauppauge para la reproducción en un equipo con una CPU de Intel que utiliza tecnología Hyper-Threading.

Causa

Paquetes de solicitud de E/S (IRP) se completan en las colas pendientes sin que se llama de nuevo. La rutina de deshacer la preparación de la solicitud. Que provoca la pérdida de recursos. La dirección del búfer de datos para datos SRB no se restaura en la dirección correcta de la dirección asignada. Por lo tanto, la rutina FreeFrame llama a dirección errónea cuando se liberan los fotogramas desde el asignador.

Solución

Información del Service pack

Para resolver este problema, obtenga el service pack más reciente para Microsoft Windows XP. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389 cómo obtener el service pack más reciente para Windows XP

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

La versión en inglés de esta revisión tiene los atributos de archivo (o posterior) que figuran en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en la herramienta fecha y hora del Panel de Control.
   Date         Time   Version        Size    File name
--------------------------------------------------------
30-Jan-2003 17:55 5.3.2600.1164 45,056 Stream.sys

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a". Este problema se corrigió primero en Microsoft Windows XP Service Pack 2.

Más información

Esta revisión sólo funciona en equipos que ejecutan Windows XP Service Pack 1 (SP1) o Service Pack 1a (SP1a).
Propiedades

Id. de artículo: 812035 - Última revisión: 17 ene. 2017 - Revisión: 1

Comentarios