Los discos IDE ATA y ATAPI usan el modo PIO después de producen varios errores CRC o tiempo de espera

Síntomas

Después de suspender y reanudar el equipo varias veces, puede reducirse el rendimiento del disco duro. Si utiliza el Administrador de dispositivos para ver las propiedades de la canal IDE al que está conectada la unidad, puede mostrar la ficha Configuración avanzada que el modo de transferencia actual de la unidad es "Modo PIO".

Causa

Después de que el controlador del puerto IDE/ATAPI de Windows (Atapi.sys) recibe un total acumulado de tiempo de espera de seis o comprobación de redundancia cíclica comprobar errores (CRC), el controlador reduce la velocidad de las comunicaciones (el modo de transferencia) desde el modo de acceso directo a memoria (DMA) más alto para reducir los modos DMA en pasos. Si el controlador continúa recibiendo errores de CRC o de tiempo de espera, el controlador finalmente reduce el modo de transferencia para el más lento (modo PIO).

Solución

Windows Server 2003

Información de la revisión

Está disponible en Microsoft una característica compatible que modifica el comportamiento predeterminado del producto. Sin embargo, esta característica está diseñada para modificar sólo el comportamiento que se describe en este artículo. Aplíquela sólo a sistemas que la requieran. Esta característica podría ser sometida a comprobaciones adicionales. Por lo tanto, si el sistema no se ve muy afectado por la falta de esta característica, le recomendamos que espere a la próxima actualización de software que contiene esta función.

Si la característica está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la característica.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califica para esta característica específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de revisión disponible" muestra los idiomas para los que la característica está disponible. Si no ve su idioma, es porque la característica no está disponible para ese idioma.
Requisitos previos
Requerida ningún service pack.
Requisito de reinicio
Debe reiniciar el equipo después de aplicar este hotfix.
Información de reemplazo de revisión
Este hotfix no sustituye a otras revisiones.
Información de archivo
La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en la herramienta fecha y hora del Panel de Control.

Nota: Después de aplicar este hotfix, debe modificar el registro como se describe en la sección "Más información" de este artículo para cambiar este comportamiento. Si no modifica el registro, el hotfix no cambia el comportamiento.

Windows XP

Información del Service pack

Para resolver este problema, obtenga el service pack más reciente para Windows XP. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389 cómo obtener el service pack más reciente para Windows XP

Información de la revisión

Está disponible en Microsoft una característica compatible que modifica el comportamiento predeterminado del producto. Sin embargo, esta característica está diseñada para modificar sólo el comportamiento que se describe en este artículo. Aplíquela sólo a sistemas que la requieran. Esta característica podría ser sometida a comprobaciones adicionales. Por lo tanto, si el sistema no se ve muy afectado por la falta de esta característica, le recomendamos que espere a la próxima actualización de software que contiene esta función.

Si la característica está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la característica.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califica para esta característica específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de revisión disponible" muestra los idiomas para los que la característica está disponible. Si no ve su idioma, es porque la característica no está disponible para ese idioma.
Requisitos previos
Windows XP Service Pack 1
Requisito de reinicio
Debe reiniciar el equipo después de aplicar este hotfix.
Información de reemplazo de revisión
Este hotfix reemplaza el hotfix 331958 y 331895 .
Información de archivo
La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en la herramienta fecha y hora del Panel de Control.

Nota: Después de aplicar este hotfix, debe modificar el registro como se describe en la sección "Más información" de este artículo para cambiar este comportamiento. Si no modifica el registro, el hotfix no cambia el comportamiento.

Windows 2000

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, envíe una solicitud al servicio de atención al cliente y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.
Requisitos previos
Windows 2000 Service Pack 2
Requisito de reinicio
Debe reiniciar el equipo después de aplicar este hotfix.
Información de reemplazo de revisión
Este hotfix reemplaza el hotfix 813908 , 323153 , 314695 , 305176 , 305098 , 304912 , 304572 y 298505 .
Información de archivo
La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en la herramienta fecha y hora del Panel de Control.

Nota: Después de aplicar este hotfix, debe modificar el registro como se describe en la sección "Más información" de este artículo para cambiar este comportamiento. Si no modifica el registro, el hotfix no cambia el comportamiento.

Solución alternativa

Para volver a habilitar el modo de transferencia típico, o más rápido, de un dispositivo afectado:
  1. Haga doble clic en Herramientas administrativasy, a continuación, haga clic en Administración de equipos.
  2. Haga clic en Herramientas del sistemay, a continuación, haga clic en Administrador de dispositivos.
  3. Expanda el nodo Controladores IDE ATA/ATAPI .
  4. Haga doble clic en el controlador para el que desea restaurar el modo de transferencia típico DMA.
  5. Haga clic en la pestaña Controlador .
  6. Haga clic en Desinstalar.
  7. Cuando el proceso finalice, reinicie el equipo. Cuando se reinicia Windows, el controlador de disco duro se vuelven a numerar y el modo de transferencia se restablece al valor predeterminado para cada dispositivo que esté conectado a la controladora.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Windows XP

Este problema se corrigió primero en Microsoft Windows XP Service Pack 2.

Más información

La revisión que se describe en este artículo realiza los cambios siguientes:
  • En Windows 2000 a veces se emiten solicitudes de lectura, sólo a discos ATA con un valor de tiempo de espera de 4 segundos. Esto ocurre cuando el equipo se reactive. Esto puede provocar un tiempo de espera del disco porque las unidades suelen tardar más de 4 segundos en Girar. Este valor de tiempo de espera se cambió a 10 segundos.

    En Windows XP y Windows Server 2003, este valor de tiempo de espera siempre es 10 segundos.
  • Una directiva alternativa, menos dura se implementa para reducir el modo de transferencia (de los modos DMA más lento, rápido y, finalmente, al modo PIO) en errores de CRC y tiempo de espera. El comportamiento actual es que el controlador del puerto IDE/ATAPI (Atapi.sys) reduce el modo de transferencia después de cualquier tiempo de espera o errores de CRC 6. Cuando esta corrección implementa la nueva directiva, Atapi.sys reduce el modo de transferencia después de 6 errores CRC o espera consecutivo. Esta nueva directiva sólo se implementa si está presente el valor del registro que se describe más adelante en este artículo.
Para implementar el comportamiento alternativo (reducir el modo de transferencia después de seis consecutivo tiempo de espera o errores CRC, en lugar de después de seis errores CRC o tiempo de espera acumulado), debe modificar el registro como se describe a continuación después de aplicar el hotfix.

Para que podamos modificar el registro para usted, vaya a la sección de "arreglarlo para mí". Si prefiere modificar el registro manualmente, vaya a la sección "permítame corregirlo yo mismo".

Solucionarlo en mi lugar



Para corregir este problema automáticamente, haga clic en el botón o vínculo Fix it. En el cuadro de diálogo Descarga de archivos, haga clic en Ejecutar y, a continuación, siga los pasos del Asistente Fix it.




Notas:
  • Este asistente puede estar solo en inglés. Sin embargo, la corrección automática también funciona para otras versiones de idioma de Windows.
  • Si no está en el equipo que tiene el problema, guarde la solución Fix it una unidad flash o un CD, y, a continuación, ejecútela en el equipo que tiene el problema.

A continuación, vaya a la sección "¿Ha solucionado esto el problema?"



Solucionarlo por mí mismo

Importante: esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que sigue estos pasos cuidadosamente. Para una mayor protección, haga una copia de seguridad del registro antes de modificarlo. Entonces, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo hacer copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 cómo hacer copia de seguridad y restaurar el registro en Windows


Siga estos pasos y después salga del Editor del registro:
  1. Haga clic en Inicio, haga clic en Ejecutar, escriba regedit y, a continuación, haga clic en Aceptar.
  2. Busque y, a continuación, haga clic en la siguiente clave del registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0001
  3. En el menú Edición , seleccione Nuevo y, a continuación, haga clic en Valor DWORD.
  4. Escriba ResetErrorCountersOnSuccessy, a continuación, presione ENTRAR.
  5. En el menú Edición , haga clic en Modificar.
  6. Escriba 1 y, a continuación, haga clic en Aceptar.
Siga estos pasos y después salga del Editor del registro:
  1. Haga clic en Inicio, haga clic en Ejecutar, escriba regedit y, a continuación, haga clic en Aceptar.
  2. Busque y, a continuación, haga clic en la siguiente clave del registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0002
  3. En el menú Edición , seleccione Nuevo y, a continuación, haga clic en Valor DWORD.
  4. Escriba ResetErrorCountersOnSuccessy, a continuación, presione ENTRAR.
  5. En el menú Edición , haga clic en Modificar.
  6. Escriba 1 y, a continuación, haga clic en Aceptar.
Nota: Las subclaves numeradas que se enumeran anteriormente corresponden a los canales IDE principal y secundario en un equipo que contiene una única controladora IDE. Si su equipo contiene dos controladoras IDE, las subclaves numeradas para los canales IDE principales y secundarios para cada una de las dos controladoras pueden ser:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0002

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0003

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0004

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0005
Para comprobar que ha encontrado la subclave correcta, compruebe que el valor DriverDesc la subclave contiene la cadena valor "Primary IDE Channel" o la cadena valor "Secondary IDE Channel."
Propiedades

Id. de artículo: 817472 - Última revisión: 17 feb. 2017 - Revisión: 2

Microsoft Windows Server 2003, Web Edition, Microsoft Windows Server 2003, Standard Edition (32-bit x86), Microsoft Windows Server 2003, Enterprise Edition (32-bit x86), Microsoft Windows Server 2003, Enterprise x64 Edition, Microsoft Windows XP Professional, Microsoft Windows XP Home Edition, Microsoft Windows 2000 Server, Microsoft Windows 2000 Professional Edition, Microsoft Windows Small Business Server 2003 Premium Edition, Microsoft Windows Small Business Server 2003 Standard Edition, Microsoft Windows XP Tablet PC Edition

Comentarios