Message Queue Server no puede enviar mensajes a una cola de destino después de los cambios de dirección IP

Importante: Este artículo contiene información acerca de cómo modificar el registro. Asegúrese de hacer copia de seguridad del registro antes de modificarlo. Asegúrese de que sabe cómo restaurarlo si ocurre algún problema. Para obtener más información acerca de cómo hacer copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 cómo hacer copia de seguridad y restaurar el registro en Windows

Síntomas

Microsoft Message Queuing (también conocido como MSMQ) no puede enviar correctamente mensajes a una cola de destino si se cumplen las dos condiciones siguientes:
  • Ha cambiado la dirección IP del equipo receptor.
  • Otro equipo ha asumido la dirección IP que era propiedad del equipo receptor.

Causa

Este problema se produce porque el remitente no vuelva a intentar la resolución de nombres.

Solución

Microsoft Windows 2000

Información sobre la actualización de seguridad

Para resolver este problema, aplique la actualización de seguridad que se describe en el siguiente artículo de Microsoft Knowledge Base:
892944 MS05-017: una vulnerabilidad en MSMQ podría permitir la ejecución de código

Información del registro
Debe realizar cambios en el registro después de aplicar esta actualización de seguridad. Para obtener más información, consulte la sección "Más información".

Microsoft Windows XP

Información del Service pack

Para resolver este problema, obtenga el service pack más reciente para Windows XP. Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:
322389 cómo obtener el service pack más reciente para Windows XP
Información del registro
Debe realizar cambios en el registro después de aplicar este service pack. Para obtener más información, consulte la sección "Más información".

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.
Requisitos previos
No hay requisitos previos.
Requisito de reinicio
Debe reiniciar el equipo después de aplicar este hotfix.
Información del registro
Debe realizar cambios en el registro después de aplicar este hotfix. Para obtener más información, consulte la sección "Más información".
Información de archivo
La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.
   Date         Time   Version     Size     File name   -------------------------------------------------------------------------------
15-Dec-2003 17:31 5.1.0.1041 67,456 Mqac.sys
15-Dec-2003 20:37 5.1.0.1041 130,048 Mqad.dll
15-Dec-2003 20:37 5.1.0.1041 14,848 Mqise.dll
15-Dec-2003 20:37 5.1.0.1041 608,256 Mqqm.dll
15-Dec-2003 20:37 5.1.0.1041 165,888 Mqrt.dll
15-Dec-2003 20:37 5.1.0.1041 88,576 Mqsec.dll
15-Dec-2003 17:31 5.1.0.1041 98,816 Mqtgsvc.exe
15-Dec-2003 20:37 5.1.0.1041 467,456 Mqutil.dll
15-Dec-2003 19:01 5.4.1.0 429,336 Windowsxp-kb833512-x86-enu-symbols.exe
15-Dec-2003 19:01 5.4.1.0 799,000 Windowsxp-kb833512-x86-enu.exe

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Este problema se corrigió en el Service Pack 2 de Windows XP.


Este problema se corrigió en Windows Server 2003 Service Pack 1.

Más información

En este escenario, hay un remitente y dos receptores (receptor A y B del receptor). Receptor se conecta a una red mediante una conexión de red privada virtual (VPN). El remitente envía mensajes correctamente. Receptor se desconecta de la red. Receptor B se conecta a la red y obtiene la dirección IP que se usó previamente por el receptor A. Receptor también puede volver a conectar y obtener una nueva dirección IP. El remitente sigue enviar mensajes que están pensados para el receptor a la dirección IP que ya está siendo utilizada por el receptor B. El remitente no vuelva a intentar la resolución de nombres porque se almacena en caché el resultado anterior. Receptor B rechaza los mensajes, pero el remitente sigue enviando mensajes al receptor B. Debe reiniciar el servicio de Message Queue Server en el equipo del remitente para resolver el problema.

Cambios en el registro

Advertencia: pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o mediante cualquier otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar que estos problemas puedan resolverse. Modifique el registro bajo su propio riesgo.

Además de aplicar la actualización adecuada, debe establecer los parámetros del registro del receptor y del remitente. El siguiente cambio del registro se requiere en el lado del receptor para que el receptor lanzará una sesión si recibe un mensaje de una cola no locales. Este cambio significa que el receptor no devolverá que un acuse de recibo de la sesión y el remitente se cerrarán la sesión a corto plazo. Es el estándar en el lado del remitente para cerrar una sesión si no se recibe una confirmación en un período de tiempo de espera especificado. A continuación, el remitente intenta establecer una sesión. Siga estos pasos y después salga del Editor del registro:
  1. Haga clic en Inicio, haga clic en Ejecutar, escriba regedit y, a continuación, haga clic en Aceptar.
  2. Busque y, a continuación, haga clic en la siguiente clave del registro:
    HKEY_LOCAL_MACHINE\Software\Microsoft\MSMQ\Parameters
  3. En el menú Edición , seleccione nuevoy, a continuación, haga clic en REG_DWORD.
  4. Escriba CloseSessionOnNonLocaly, a continuación, presione ENTRAR.
  5. En el menú Edición , haga clic en Modificar.
  6. Escriba 1 y, a continuación, haga clic en Aceptar.
Debe cambiar la siguiente entrada del registro para forzar el remitente para omitir su caché de dirección y realizar siempre la resolución de nombres antes de que se establecerá una sesión. Siga estos pasos y después salga del Editor del registro:
  1. Haga clic en Inicio, haga clic en Ejecutar, escriba regedit y, a continuación, haga clic en Aceptar.
  2. Busque y, a continuación, haga clic en la siguiente clave del registro:
    HKEY_LOCAL_MACHINE\Software\Microsoft\MSMQ\Parameters
  3. En el menú Edición , seleccione nuevoy, a continuación, haga clic en REG_DWORD.
  4. Escriba ForceNameResolutionDirecty, a continuación, presione ENTRAR.
  5. En el menú Edición , haga clic en Modificar.
  6. Escriba 1 y, a continuación, haga clic en Aceptar.
Esta corrección también agrega el código de resolución de nombre de registro. Este cambio se habilita agregando el siguiente valor del registro. Siga estos pasos y después salga del Editor del registro:
  1. Haga clic en Inicio, haga clic en Ejecutar, escriba regedit y, a continuación, haga clic en Aceptar.
  2. Busque y, a continuación, haga clic en la siguiente clave del registro:
    HKEY_LOCAL_MACHINE\Software\Microsoft\MSMQ\Parameters\Debug
  3. En el menú Edición , seleccione nuevoy, a continuación, haga clic en REG_DWORD.
  4. Escriba QMLoggingy, a continuación, presione ENTRAR.
  5. En el menú Edición , haga clic en Modificar.
  6. Escriba 0 x 20y, a continuación, haga clic en Aceptar.
Nota: El valor de QMLogging es específico para Windows 2000. Los valores CloseSessionOnNonLocal y ForceNameResolutionDirect son para Windows 2000 y Windows Server 2003.

Los siguientes parámetros del registro también son necesarios para vaciar el DNS y almacena en la caché de resolución de nombres NetBIOS. De lo contrario, una dirección IP en la memoria caché puede pertenecer a un equipo diferente:
  • HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netbt\Parameters\CacheTimeout = (DWORD) 0
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dnscache\Parameters\MaxCacheEntryTtlLimit = (DWORD) 1
Nota: La clave del registro MaxCacheEntryTtlLimit es específica de Windows 2000. En Windows Server 2003, esta clave del registro se llama MaxCacheTtl. Para obtener más información acerca de la clave de registro MaxCacheTtl, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

318803 cómo deshabilitar la caché del cliente DNS en Windows XP y Windows Server 2003

Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 833512 - Última revisión: 9 ene. 2017 - Revisión: 1

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