Varios procesos huérfanos Csrss.exe causan problemas de rendimiento en un servidor terminal server que ejecuta Windows 2000 o Windows Server 2003

Síntomas

En un equipo basado en Microsoft Windows 2000 Server o el equipo basado en Microsoft Windows Server 2003 que ejecuta Servicios de Terminal Server, puede experimentar los síntomas siguientes:
  • El servidor se vuelve lento y no responda. Finalmente, no puede establecer nuevas sesiones de servicios de Terminal Server.
  • Si utiliza el Administrador de tareas para ver los procesos en ejecución, verá que hay varios procesos huérfanos Csrss.exe. No hay ninguna sesión de cliente servicios de Terminal Server correspondiente al ver las sesiones de Terminal Services Manager.
  • No se puede detener los procesos huérfanos Csrss.exe para liberar los recursos del servidor. Por lo tanto, pueden seguir los procesos Csrss.exe se acumulan hasta que es necesario reiniciar el servidor para liberar memoria y recursos de la CPU.
Si aplica la revisión que se describe en el artículo de Microsoft Knowledge Base 827350, esto puede ayudar a reducir el número de procesos Csrss.exe, pero el problema persiste.
827350 clientes no pueden conectarse a un servidor terminal server cuando Csrss.exe y Termsrv.exe llegue al 100% de uso de CPU

Causa

El problema se produce debido a una regresión introducida en Windows 2000 Service Pack 3 (SP3). Windows 2000 SP3 incluye una revisión que presenta un objeto winstation temporal en el proceso Csrss.exe. Esta revisión se describe en el siguiente artículo de Microsoft Knowledge Base:
261322 stop 0x0000001E mensaje de error cuando imprime desde un cliente de servicios de Terminal Server de Windows 2000

Si los objetos temporales winstation no se liberan correctamente, puede experimentar los síntomas que se describen anteriormente en este artículo.

Solución

Información de la revisión

Windows Server 2003

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

No hay requisitos previos.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de hotfix

Este hotfix no sustituye a otras revisiones.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en la herramienta fecha y hora del Panel de Control.
Windows Server 2003, versiones basadas en x86
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Winsrv.dll5.2.3790.170291,84004-May-200423:28x86

Windows Server 2003, versiones basadas en Itanium
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Winsrv.dll5.2.3790.170764,92804-May-200408:22IA-64

Windows 2000

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para instalar este hotfix, debe tener Windows 2000 Service Pack 3 (SP3) instalado en el equipo.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Este hotfix no sustituye a otras revisiones.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataformaTipo de servicio
Basesrv.dll5.0.2195.682442.25624-Mar-200402:17x86No aplicable
Cmd.exe5.0.2195.6824236,30421-Sep-200300:45x86No aplicable
Gdi32.dll5.0.2195.6660233,74419-Jun-200320:05x86No aplicable
Kernel32.dll5.0.2195.6897742,16024-Mar-200402:17x86No aplicable
Mpr.dll5.0.2195.682454,54424-Mar-200402:17x86No aplicable
Msgina.dll5.0.2195.6958335,12013-Jul-200421:25x86No aplicable
Rdpwd.sys5.0.2195.689290,26424-Mar-200402:17x86No aplicable
Sp3res.dll5.0.2195.69355,887,48804-Jun-200423:13x86No aplicable
User32.dll5.0.2195.6897403,21624-Mar-200402:17x86No aplicable
Userenv.dll5.0.2195.6794385.80805-Aug-200322:14x86No aplicable
Win32k.sys5.0.2195.69581,631,76010-Jul-200405:36x86No aplicable
Winlogon.exe5.0.2195.6898181,52011-Mar-200402:37x86No aplicable
Winsrv.dll5.0.2195.6958244,49613-Jul-200421:25x86No aplicable
Kernel32.dll5.0.2195.6897742,16024-Mar-200402:17x86UNIPROC
Win32k.sys5.0.2195.69581,631,76010-Jul-200405:36x86UNIPROC
Winsrv.dll5.0.2195.6958244,49613-Jul-200421:25x86UNIPROC

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Esta característica se incluyó primero en Windows Server 2003 Service Pack 1.

Más información

Para obtener más información acerca de cómo se denominan los paquetes de revisiones, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:

816915 nuevo esquema de nomenclatura para los paquetes de revisiones de Microsoft Windows

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Soporte técnico para las versiones basadas en x 64 de Microsoft Windows

Si su hardware venía con una edición de Microsoft Windows x64 ya instalada, su fabricante de hardware proporciona soporte técnico y asistencia para la edición de Windows x64. En este caso, el fabricante del hardware proporciona soporte técnico porque un Windows x64 edition se incluyó con su hardware. Su fabricante de hardware podría haber personalizado la instalación de Windows x64 edition con componentes exclusivos. Componentes exclusivos podrían incluir controladores de dispositivo específicos o configuraciones opcionales para maximizar el rendimiento del hardware. Si necesita ayuda técnica para una edición de Windows x64, Microsoft ofrecerá asistencia de esfuerzo razonable. Sin embargo, tendrá que ponerse en contacto directamente con el fabricante. El fabricante es el mejor cualificado para admitir el software que instaló el fabricante del hardware. Si ha adquirido una edición de Windows x64, como Microsoft Windows Server 2003 x64 por separado, póngase en contacto con Microsoft para obtener soporte técnico.

Para obtener información sobre x64 de Microsoft Windows XP Professional Edition, visite el siguiente sitio Web de Microsoft:Para obtener información acerca de las versiones basadas en x64 de Microsoft Windows Server 2003, visite el siguiente sitio Web de Microsoft:
Propiedades

Id. de artículo: 837585 - Última revisión: 17 ene. 2017 - Revisión: 1

Comentarios