Aparece el mensaje de error "no se encontró la versión esperada del producto en el sistema" al instalar Office XP Service Pack 3

Resumen

Cuando intenta actualizar Microsoft Office XP para Microsoft Office XP Service Pack 3 (SP3), recibirá un mensaje de error que indica que no se encontró la versión esperada. Para resolver este problema, instale la versión completa del Service Pack 3 de Office XP.

Síntomas

Cuando usted (como administrador de red) o uno de sus usuarios intenta instalar Office XP SP3, puede recibir el siguiente mensaje de error:
No se encontró la versión esperada del producto en el sistema.

Causa

Este problema puede producirse cuando se cumplen las condiciones siguientes:

Solución

Para resolver este problema, utilice uno de los métodos siguientes.

Método 1: Usar la actualización de archivo completo de Office XP Service Pack 3

Puede utilizar el archivo completo de Office XP Service Pack 3 update para actualizar su punto de instalación administrativa o un solo equipo (cliente) que tiene instalado Office XP.

Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
Descripción de 832671 de Microsoft Office XP Service Pack 3

Método 2: Utilice un nuevo punto de instalación administrativa nivel base de RTM

Si, como el Administrador de la red, ya no desea mantener su punto de instalación administrativa de Office XP con los service Pack y actualizaciones, crear un nuevo punto de instalación de Office XP en la base de RTM de Office XP nivel.

Después de instalar Office XP en un equipo cliente desde su punto de instalación administrativa de Office XP RTM-base nueva, puede utilizar luego utilice la actualización binaria de uno de los sitios Web de Microsoft que se enumeran en la sección "Causa" de este artículo.

Para obtener información adicional acerca de cómo crear un nuevo punto de instalación administrativa, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
304953 HOW TO: cómo implementar Office XP a través de una red

Más información

Actualizaciones de cliente, como Office XP Service Pack 2 y versiones anteriores, podrían estar instaladas correctamente en una instalación de cliente de Office XP si la actualización administrativa de archivo completo haya sido instalada en el punto de instalación administrativa y el equipo cliente se había actualizado desde el punto de instalación administrativa.

Con Microsoft Office XP Service Pack 3, Microsoft cambió la forma en que se creó la actualización binaria para que instale la actualización de cliente (binario) de Office XP Service Pack 3 directamente a través de la versión RTM nivel (10.0.2627) de Office XP.

Debido a este cambio, la actualización binaria de Office XP Service Pack 3 no instalará correctamente en un equipo que tiene Office XP Service Pack 1 (SP1) o en Office XP Service Pack 2 (SP2) instalado desde un punto de instalación administrativa y poner en el equipo local (cliente). Este problema se produce porque Office XP Service Pack 3 debe tener la versión 10.0.2627 (nivel RTM) de Office XP instalada.

Nota: La actualización de archivo completo de Office XP Service Pack 3 (SP3) se instalará correctamente sobre un nivel RTM de Office XP, Office XP Service Pack 1 (SP1) y Office XP Service Pack 2 (SP2) cuando se aplica el SP3 de Office a un punto de instalación administrativa.

Solucionar problemas de notas

El registro detallado de Ohotfix siguiente muestra un error de 2749 con código de error de 1642 al final de la entrada del registro:
MSI (s) (F8:64): Looking for storage transform: 7TTo7U
MSI (s) (F8:64): Validating transform '7TTo7U' with validation bits 0x122
MSI (s) (F8:64): Note: 1: 2749 2: 7TTo7U 3: C:\WINDOWS\Installer\3b569.msi 4: 10.0.2627.01 5: 10.0.4330.0
MSI (s) (F8:64): 1: 2749 2: 7TTo7U 3: C:\WINDOWS\Installer\3b569.msi 4: 10.0.2627.01 5: 10.0.4330.0
(Expected version is 10.0.2627, version found is 10.0.4330.0.)

La siguiente entrada de registro Ohotfix muestra el código de error 1642 al final del registro:
The upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded 
may be missing, or the upgrade patch may update a different version of the program. Verify that the program
to be upgraded exists on your computer and that you have the correct upgrade patch.
C:\DOCUME~1\username.NOR\LOCALS~1\Temp\IXP000.TMP\MAINSP3op.msp
MSI (s) (F8:64): Attempting to delete file C:\WINDOWS\Installer\22879.msp
MSI (s) (F8:64): MainEngineThread is returning 1642
MSI (c) (50:40): Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.
Counter after decrement: -1
MSI (c) (50:40): MainEngineThread is returning 1642

Para obtener información adicional acerca de cómo utilizar los archivos de registro de instalación de Microsoft Office XP para solucionar problemas de instalación de Office, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
296603 cómo utilizar un archivo de registro de instalación de Office XP para solucionar problemas de instalación en Office XP

Referencias

Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
325671 OFFXP: información general sobre Office XP Service Pack 2


307843 OFFXP: información general sobre Office XP Service Pack 1


283686 OFFXP: modificadores de línea de comandos de instalación de Office XP

Propiedades

Id. de artículo: 837826 - Última revisión: 17 ene. 2017 - Revisión: 1

Microsoft Office XP Professional Edition, Microsoft Office XP Small Business Edition, Microsoft Office XP Standard Edition, Microsoft Office XP Developer Edition, Microsoft Access 2002 Standard Edition, Microsoft Excel 2002 Standard Edition, Microsoft FrontPage 2002 Standard Edition, Microsoft Outlook 2002 Standard, Microsoft PowerPoint 2002 Standard Edition, Microsoft Word 2002 Standard Edition

Comentarios