Recibe un mensaje de error "el proceso no puede tener acceso al archivo" cuando abre un archivo de informe de una copia de seguridad que se realizó mientras se ejecuta el servicio inteligente en segundo plano (BITS)

Síntomas

Hacer copia de seguridad de unidad: \Documents and carpeta de Settings\All Users cuando se ejecuta el servicio de transferencia inteligente en segundo plano (BITS). Después copia de la carpeta, si se abre el informe de la actividad de copia de seguridad, puede observar el mensaje de error siguiente:

Advertencia: No se puede abrir "unidad: \Documents and Settings\All Users\Application Data\Microsoft\Network\Downloader\qmgr0.dat": omitido.
Motivo: El proceso no puede tener acceso el archivo porque está siendo utilizado por otro proceso.

Advertencia: No se puede abrir "unidad: \Documents and Settings\All Users\Application Data\Microsoft\Network\Downloader\qmgr1.dat": omitido.
Motivo: El proceso no puede tener acceso el archivo porque está siendo utilizado por otro proceso.
Nota: La unidad es un marcador de posición para el directorio raíz que contiene los archivos de sistema del equipo.

Causa

BITS crea y utiliza los archivos Qmgr0.dat y Qmgr1.dat. Cuando se ejecuta BITS, siempre se bloquean los archivos Qmgr0.dat y Qmgr1.dat. Debido a este estado bloqueado, la aplicación de backup no puede abrir y copiar los archivos. Por lo tanto, observará que el archivo está siendo utilizado por otro proceso.

Solución

Importante: esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que sigue estos pasos cuidadosamente. Para una mayor protección, haga una copia de seguridad del registro antes de modificarlo. Entonces, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo hacer copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 cómo hacer copia de seguridad y restaurar el registro en Windows


Para resolver este problema, no es necesario hacer copia de seguridad de los archivos Qmgr0.dat y Qmgr1.dat. Puede excluir estos archivos de copia de seguridad para evitar los errores. Para excluir los archivos Qmgr0.dat y Qmgr1.dat, siga estos pasos:
  1. Inicie sesión en el equipo como administrador.
  2. Haga clic en Inicioy, a continuación, haga clic en
    Ejecutar. Aparecerá el cuadro de diálogo Ejecutar .
  3. En el cuadro Abrir, escriba regedit y, a continuación, haga clic en Aceptar.
  4. Abra la siguiente subclave del registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\BackupRestore\FilesNotToBackup
  5. En el panel izquierdo, haga Copia de seguridad de FilesNotTo, seleccione nuevoy, a continuación, haga clic en
    Valor de cadena múltiple.
  6. Nombre la nueva entrada BITS.
  7. Haga doble clic en la entrada de BITS. Aparecerá el cuadro de diálogo Modificar cadenas múltiples .
  8. En el cuadro información del valor, escriba el siguiente valor y, a continuación, haga clic en Aceptar:
    %AllUsersProfile%\Application Data\Microsoft\Network\Downloader\*
  9. Cierre el Editor del registro
Nota: Puede establecer este valor del registro contra la entrada Common AppData en la siguiente ubicación para equipos que ejecutan sistemas operativos de idioma distinto del inglés:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Más información

Pasos para reproducir el problema

  1. Haga clic en Inicioy, a continuación, haga clic en
    Ejecutar. Aparecerá el cuadro de diálogo Ejecutar .
  2. En el cuadro Abrir , escriba cmdy, a continuación, haga clic en Aceptar.
  3. En el símbolo del sistema, escriba el comando siguiente y, a continuación, presione ENTRAR:
    net start bits
    Este comando muestra el estado de BITS.

    Nota: Asegúrese de que BITS se ejecuta antes de realizar la copia de seguridad de la carpeta.
  4. En el símbolo del sistema, escriba el comando siguiente y, a continuación, presione ENTRAR:
    ntbackup.exe
    Aparecerá el cuadro de diálogo copia de seguridad o el Asistente para restauración .
  5. Haga clic en modo avanzado. La
    Aparece el cuadro de diálogo Utilidad de copia de seguridad - [sin título] .
  6. Haga clic en la ficha copia de seguridad .
  7. En el panel izquierdo, expanda Mi PCy, a continuación, expanda la unidad.
  8. Expanda Documents and Settingsy, a continuación, haga clic para seleccionar la casilla de verificación de Todos los usuarios .
  9. Escriba unidad: \Backup.bkf en el nombre del medio o del archivo de copia de seguridad de cuadro y, a continuación, haga clic en Iniciar copia de seguridad. La
    Aparece el cuadro de diálogo Información de tarea de copia de seguridad .
  10. Haga clic en Avanzadas. Aparecerá el cuadro de diálogo Opciones avanzadas de copia de seguridad .
  11. Haga clic para activar la casilla de verificación Deshabilitar instantáneas de volumen y, a continuación, haga clic en Aceptar.

    Nota: No es necesario deshabilitar la copia sombra de volumen si su equipo ejecuta el sistema operativo Microsoft Windows 2000.
  12. Haga clic en Iniciar copia de seguridad. Aparecerá el cuadro de diálogo de Progreso de copia de seguridad y copia de seguridad de la carpeta continúa.
  13. Después de completa el proceso de copia de seguridad, haga clic en
    Informe. Puede observar el mensaje de error en el informe que se menciona en la sección "Síntomas".

Referencias

Para obtener más información, visite los siguientes sitios Web de Microsoft Developer Network (MSDN):
Platform SDK: Servicio de transferencia inteligente de fondo
http://msdn2.microsoft.com/en-us/library/aa362708.aspx

Servicio de transferencia inteligente de fondo
http://msdn2.microsoft.com/en-us/library/aa362827.aspx
Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

331716 INFO: lista de problemas conocidos para servicio de transferencia inteligente en segundo plano (BITS)

Nº de error: 19429 (Mantenimiento de contenido)
Propiedades

Id. de artículo: 839090 - Última revisión: 17 ene. 2017 - Revisión: 1

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