Imágenes no aparecen como esperaba o recibe un mensaje de error cuando abre un archivo HTML en un equipo basado en Windows XP Service Pack 2

Importante: este artículo contiene información que muestra cómo reducir la configuración de seguridad o desactivar las características de seguridad en un equipo. Puede realizar estos cambios para solucionar un problema específico. Antes de realizar estos cambios, le recomendamos que evalúe los riesgos asociados con la implementación de esta solución en su entorno concreto. Si decide implementar esta solución alternativa, tome las medidas adicionales oportunas para ayudar a proteger su sistema.

Síntomas

Cuando abre un archivo HTML en un programa después de instalar Microsoft Windows XP Service Pack 2 (SP2), puede aparecer uno de los siguientes problemas:
  • Recibirá un mensaje de error al ver el archivo HTML en un programa basado en Windows.
  • Recibirá un mensaje de error de ActiveX al ver el archivo HTML en un programa basado en Windows.
  • Al abrir el archivo HTML en Microsoft Internet Explorer, las imágenes no aparecen tal como espera.

Causa

Estos problemas pueden deberse a una característica de seguridad mejorada que se incluye en Windows XP SP2. Esta característica de seguridad mejorada que ayuda a proteger el equipo contra los ataques de usuarios malintencionados o de software malintencionado, como virus informáticos. De forma predeterminada, esta característica está activada en el registro.

Solución alternativa

Advertencia: Esta solución puede hacer que su equipo o su red sean más vulnerables a los ataques de usuarios malintencionados o de software malintencionado, como virus. No recomendamos esta solución, pero proporcionamos esta información para que puede implementar esta solución temporal a su propia discreción. Utilice esta solución bajo su propia responsabilidad.

Importante: esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que sigue estos pasos cuidadosamente. Para una mayor protección, haga una copia de seguridad del registro antes de modificarlo. Entonces, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo hacer copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 cómo hacer copia de seguridad y restaurar el registro en Windows


Para evitar estos problemas, cambie el valor de la subclave FEATURE_LOCALMACHINE_LOCKDOWN en 0.

Nota: De forma predeterminada, el valor de la subclave FEATURE_LOCALMACHINE_LOCKDOWN se establece en 1 en Windows XP SP2.

Para ello, siga estos pasos:
  1. Cierre todos los programas basados en Windows.
  2. Haga clic en Inicio, haga clic en Ejecutar, escriba regedit en el cuadro Abrir y, a continuación, haga clic en Aceptar.
  3. Busque y, a continuación, haga clic en la subclave del registro siguiente:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_LOCALMACHINE_LOCKDOWN
  4. En la subclave FEATURE_LOCALMACHINE_LOCKDOWN , siga estos pasos:
    1. Haga clic en Iexplore.exe.
    2. En el menú Edición , haga clic en Modificar.
    3. En el cuadro información del valor , escriba 0 y a continuación, haga clic en Aceptar.
    4. Haga clic en Explore.exe.
    5. En el menú Edición , haga clic en Modificar.
    6. En el cuadro información del valor , escriba 0 y a continuación, haga clic en Aceptar.
  5. Para salir del Editor del registro, haga clic en Salir en el menú archivo .
  6. Reinicie Windows.

Más información

Cuando el valor de la subclave FEATURE_LOCALMACHINE_LOCKDOWN se establece en 1, se aplican las siguientes restricciones de Windows XP Service Pack 2 para Microsoft Internet Explorer y el Explorador de Microsoft Windows:
  • No permitir ActiveX.
  • No permitir comportamientos de binarios.
  • No permitir en Java.
  • Pedir el script que se ejecuta.
  • Pedir datos entre dominios.
Se saben que los problemas que se describen en la sección "Síntomas" se produce con los siguientes programas:
  • Broderbund 3D Home Architect Deluxe 5.0
  • Adobe Photoshop 7.0
  • Macromedia Flash
  • Dreamweaver MX de Macromedia Studio MX 6.0
  • Studio de Macromedia Flash MX MX 6.0
  • Microsoft Excel 2002
  • Microsoft Office Excel 2003
  • Microsoft Office Outlook 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft PowerPoint 2002 Service Pack 2
  • Microsoft PowerPoint 2002
  • Microsoft Office Publisher 2003
  • Microsoft Office Visio 2003
  • Microsoft Visio 2002 Service Release 1
  • Microsoft Works Suite 2003 (Microsoft Word 2002)
  • Taller de impresión ValuSoft 2003
Los productos de terceros que se indican en este artículo están fabricados por compañías independientes de Microsoft. Microsoft no otorga ninguna garantía, implícita o de otro tipo, respecto al rendimiento o la confiabilidad de estos productos.

Propiedades

Id. de artículo: 878461 - Última revisión: 17 ene. 2017 - Revisión: 1

Comentarios