Algunas reglas están deshabilitadas y recibe un mensaje de error cuando intenta crear o habilitar reglas en Outlook

Síntomas

Después de actualizar a Microsoft Office Outlook 2003 (o posterior), puede observar que algunas reglas están deshabilitadas y no se puede habilitar. Otras reglas funcionan correctamente. Si intenta activar las reglas deshabilitadas, recibirá el siguiente mensaje de error:
Una o más reglas no se pueden cargar al servidor de Exchange y se han desactivado. Puede que algunos de los parámetros no son compatibles o no hay espacio suficiente para almacenar todas las reglas.

Causa

  • Los buzones de Microsoft Exchange Server 2007, Exchange Server 2010 o Exchange Server de 2013

    Este comportamiento se produce si las reglas del buzón superan la cuota de reglas establecida para su buzón. El límite de tamaño de las reglas para los buzones en Exchange Server 2007 (y versiones posteriores) tiene un tamaño predeterminado de 64 KB por buzón. El total de las reglas de límite de tamaño también es personalizable limitan hasta 256 KB por buzón.

  • Buzones en Exchange Server 2003

    Este comportamiento se produce si las reglas del buzón superan un tamaño de 32 kilobytes (KB). El límite de tamaño total de las reglas para los buzones en Exchange Server 2003 es de 32 KB. No se puede cambiar el límite de las reglas para Exchange 2003.
En Outlook 2003 (y posterior), ha aumentado el tamaño de las reglas principalmente para proporcionar compatibilidad con el formato Unicode.

Solución alternativa

Exchange Server 2007, Exchange Server 2010 y Exchange Server de 2013

Si el buzón está en Exchange Server 2007 o posterior, puede pedir a su administrador de Exchange para aumentar la cuota de reglas del buzón.

El siguiente comando de ejemplo establece la cuota de reglas en el valor máximo de 256 KB.

John@contoso.com Set-Mailbox - RulesQuota: 256kb
El comando de ejemplo siguiente permite ver la cuota de reglas actual para un buzón.

Get-Mailbox john@contoso.com | FL displayname, rulesquota

Si el Administrador de Exchange no puede aumentar la cuota de reglas del buzón, intente una de las siguientes soluciones provisionales que se aplican a todas las versiones de Exchange.

Todas las versiones de Exchange

Para solucionar temporalmente este comportamiento para que se restauren las reglas, utilice uno o varios de los métodos siguientes para reducir el tamaño de las reglas existentes

Método 1

Cambie el nombre de las reglas por un nombre más corto. Para cambiar el nombre de una regla en Outlook, siga estos pasos.

En Outlook 2010 y versiones posteriores:
  1. En la pestaña archivo , haga clic en Info.
  2. A continuación, haga clic en Administrar reglas y alertas.
  3. En la ficha Reglas de correo electrónico , haga clic en la regla que desee cambiar.
  4. Haga clic en Cambiar las reglasy, a continuación, haga clic en Cambiar nombre de regla.
  5. Escriba un nuevo nombre más corto para la regla y, a continuación, haga clic en Aceptar.
  6. Haga clic en Aceptar para cerrar el cuadro de diálogo reglas y alertas .
En Outlook 2007 y Outlook 2003:
  1. En el menú Herramientas , haga clic en reglas y alertas.
  2. En la ficha Reglas de correo electrónico , haga clic en la regla que desee cambiar.
  3. En la lista Cambiar regla , haga clic en Cambiar nombre de regla.
  4. Escriba un nuevo nombre más corto para la regla y, a continuación, haga clic en Aceptar.
  5. Haga clic en Aceptar para cerrar el cuadro de diálogo reglas y alertas .

Método 2

Elimine las reglas antiguas. Para eliminar una regla en Outlook, siga estos pasos:

En Outlook 2010 y versiones posteriores:
  1. En la pestaña archivo , haga clic en Info.
  2. A continuación, haga clic en Administrar reglas y alertas.
  3. En la ficha Reglas de correo electrónico , haga clic en la regla que desee cambiar.
  4. Haga clic en el botón Eliminar y, a continuación, haga clic en para confirmar la eliminación.
  5. Haga clic en Aceptar para cerrar el cuadro de diálogo reglas y alertas .
En Outlook 2007 y Outlook 2003:
  1. En el menú Herramientas , haga clic en reglas y alertas.
  2. En la ficha Reglas de correo electrónico , haga clic en la regla que desea eliminar.
  3. Haga clic en Eliminary, a continuación, haga clic en para confirmar la eliminación.
  4. Haga clic en Aceptar para cerrar el cuadro de diálogo reglas y alertas .

Método 3

Combine reglas similares para reducir el tamaño total de las reglas. Si es posible, combine reglas similares para reducir el tamaño total de las reglas. Después se combinaron reglas similares, elimine las reglas que no necesita más. Para editar una regla existente en Outlook, siga estos pasos.

En Outlook 2010 y versiones posteriores:
  1. En la pestaña archivo , haga clic en Info.
  2. A continuación, haga clic en Administrar reglas y alertas.
  3. En la ficha Reglas de correo electrónico , haga clic en la regla que desee cambiar.
  4. Haga clic en Cambiar reglay, a continuación, haga clic en Editar configuración de regla.
  5. Modifique la regla según corresponda.
  6. Haga clic en Aceptar para cerrar el cuadro de diálogo reglas y alertas .
En Outlook 2007 y Outlook 2003:

  1. En el menú Herramientas , haga clic en reglas y alertas.
  2. En la ficha Reglas de correo electrónico , haga clic en la regla que desea editar.
  3. En la lista Cambiar regla , haga clic en Editar configuración de regla.

    Modifique la regla según corresponda.
  4. Cuando haya terminado, haga clic en Finalizary, a continuación, haga clic en Aceptar para cerrar el cuadro de diálogo reglas y alertas .

    Nota: Si la regla es una regla sólo de cliente, debe hacer clic en Aceptar dos veces para cerrar el cuadro de diálogo reglas y alertas .

Método 4

Mueva el archivo de carpetas personales (.pst) a una ubicación que tiene el nombre de ruta de acceso más corta. Si tiene reglas que mueven los mensajes de correo electrónico a un archivo .pst, mueva el archivo .pst a una ubicación que tiene el nombre de ruta de acceso más corta posible. Por ejemplo, puede mover el archivo .pst a una ubicación como C:\file_name.pst. Para mover el archivo .pst en Outlook, siga estos pasos:
  1. En el panel de exploración, haga clic en Carpetas personales o el nombre de carpeta que aparece para el archivo .pst y, a continuación, haga clic en Propiedades para nombreDeCarpeta.


    Nota: Esta carpeta siempre será una carpeta de nivel superior en el panel de exploración, en correo.

  2. En la ficha General , haga clic en Opciones avanzadas.
  3. En el cuadro de texto nombre de archivo , anote la ruta y el nombre completo del archivo .pst.
  4. Haga clic en Aceptar dos veces para cerrar el cuadro de diálogo nombreDeCarpeta propiedades .
  5. Salga de Outlook.
  6. Utilice el Explorador de Microsoft Windows para mover el archivo .pst a la nueva ubicación.


    Nota: De forma predeterminada, la ubicación de un archivo .pst es la unidad: \Documents and Settings\nombreDeUsuario\Local de programa\Microsoft\Outlook. La ubicación predeterminada es una carpeta oculta. Para utilizar el Explorador de Windows para buscar esta carpeta, primero debe activar la visualización de las carpetas ocultas. Para ello, siga estos pasos:
    1. En el Explorador de Windows, haga clic en Opciones de carpeta en el menú Herramientas .
    2. Haga clic en la ficha Ver .
    3. En la sección Configuración avanzada , haga clic en Mostrar archivos y carpetas ocultos bajo archivos y carpetas ocultos.
    4. Si desea ver todas las extensiones de nombre de archivo, haga clic para desactivar la casilla de verificación ocultar las extensiones para tipos de archivo conocidos en archivos y carpetas.

      Tenga en cuenta que las carpetas ocultas aparecen atenuadas para indicar que no son carpetas típicas.
    5. Haga clic en Aceptar.

  7. Utilice uno de los métodos siguientes para abrir el elemento de correo en el Panel de Control:
    • Para hacer esto en un equipo basado en Windows XP o en un equipo basado en Windows Server 2003, haga clic en Inicio, haga clic en Panel de Control, haga clic en Cuentas de usuarioy, a continuación, haga clic en correo.


      Nota: Si utiliza la vista clásica, haga clic en Inicio, haga clic en Panel de Controly, a continuación, haga doble clic en correo.

    • Para hacer esto en un equipo basado en Microsoft Windows 2000, haga clic en Inicio, seleccione configuración, haga clic en Panel de Controly, a continuación, haga doble clic en correo.
  8. Haga clic en Mostrar perfilesy, a continuación, haga clic en el perfil que contiene el archivo .pst.
  9. Haga clic en Propiedadesy, a continuación, haga clic en Archivos de datos.
  10. Haga clic en el archivo de datos .pst que ha movido y, a continuación, haga clic en configuración.
  11. Cuando se le pida que no se pudo encontrar el archivo de datos en la ubicación antigua, haga clic en Aceptar.
  12. Busque y, a continuación, haga clic en el archivo .pst en la nueva ubicación de carpeta y, a continuación, haga clic en Abrir.
  13. Haga clic en Aceptary, a continuación, haga clic en Cerrar dos veces.
  14. Haga clic en Aceptar.
  15. Salga del Panel de Control.
  16. Reinicie Outlook.

Método 5

Desactive la casilla de verificación sólo en esta máquina . Si utiliza una regla para mover mensajes de correo electrónico a un archivo .pst, haga clic para desactivar la casilla de verificación sólo en esta máquina , a menos que se tiene acceso a su correo electrónico de Exchange Server desde equipos cliente diferentes. Para hacer esto en Outlook, siga estos pasos:

En Outlook 2010 y versiones posteriores:
  1. En la pestaña archivo , haga clic en Info.
  2. A continuación, haga clic en Administrar reglas y alertas.
  3. En la ficha Reglas de correo electrónico , haga clic en la regla que desee cambiar.
  4. Haga clic en Cambiar reglay, a continuación, haga clic en Editar configuración de regla.
  5. Haga clic para desactivar la casilla de verificación sólo en esta máquina si está activada la casilla de verificación.
  6. Complete el Asistente para reglas. Haga clic en Aceptar para cerrar el cuadro de diálogo reglas y alertas .
En Outlook 2007 y Outlook 2003:
  1. En el menú Herramientas , haga clic en reglas y alertas.
  2. En la ficha Reglas de correo electrónico , haga clic en la regla que desea editar.
  3. En la lista Cambiar regla , haga clic en Editar configuración de regla.
  4. Si selecciona esta opción, haga clic para desactivar la casilla de verificación sólo en esta máquina .
  5. Complete el Asistente para reglas.
  6. Haga clic en Aceptar para cerrar el cuadro de diálogo reglas y alertas .

    Nota: Si utiliza reglas de sólo cliente que apuntan a archivos de recursos locales, por ejemplo moviendo elementos a una carpeta en un archivo .pst y utilizar varios equipos para tener acceso a Microsoft Outlook, pueden producirse conflictos de reglas. Por lo tanto, podrían deshabilitarse algunas reglas sólo de cliente.

Más información

Para obtener información adicional acerca de la limitación de 32 KB de las reglas, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

Número máximo de 147298 de reglas por carpeta

Propiedades

Id. de artículo: 886616 - Última revisión: 17 ene. 2017 - Revisión: 1

Outlook 2016, Microsoft Outlook 2013, Microsoft Outlook 2010, Microsoft Office Outlook 2007, Microsoft Office Outlook 2003

Comentarios