Puede recibir un mensaje de error "acceso denegado" cuando un sitio Web le redirige a otra página Web en un equipo que está ejecutando Windows XP Service Pack 2

Importante: Este artículo contiene información acerca de cómo modificar el registro. Asegúrese de hacer copia de seguridad del registro antes de modificarlo. Asegúrese de que sabe cómo restaurarlo si ocurre algún problema. Para obtener más información acerca de cómo hacer copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

Síntomas

Cuando explora un sitio Web utilizando Microsoft Internet Explorer en un equipo que está ejecutando Microsoft Windows XP Service Pack 2 (SP2), puede recibir un mensaje de error "acceso denegado". El mensaje de error puede producirse cuando un sitio Web le redirige a una página Web que contiene la secuencia de comandos que tiene acceso a la colección document.all .

Causa

Este problema puede producirse porque, cuando el código de secuencia de comandos tiene acceso a la colección document.all después de redirigir una secuencia de comandos de cliente, el contexto de la colección document.all anterior se pierde.

Solución

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en la herramienta fecha y hora del Panel de Control.
   Date         Time   Version         Size       File name   ---------------------------------------------------------
07-Dec-2004 20:21 6.00.2900.2577 3,006,976 Mshtml.dll

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Advertencia: pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o mediante cualquier otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar que estos problemas puedan resolverse. Modifique el registro bajo su propio riesgo.

Recibirá este mensaje de error sólo si el equipo está ejecutando Windows XP SP2. Después de aplicar este hotfix, reinicie el equipo y, a continuación, siga estos pasos.

Nota: Esta revisión se incluye en la actualización acumulativa de Internet Explorer de MS05-038. Los pasos siguientes para establecer el valor de clave del registro no son necesarios para habilitar esta revisión cuando MS05-038 está instalado en el equipo.
  1. Salga de Internet Explorer.
  2. Haga clic en Inicio, haga clic en Ejecutar, escriba regedit en el cuadro Abrir y, a continuación, haga clic en Aceptar.
  3. Busque y, a continuación, haga clic en la clave del registro siguiente:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main
  4. Crear una nueva clave denominada FeatureControl bajo la clave que se enumera en el paso 3.
  5. Crear una nueva clave denominada FEATURE_REDIRECT_COLLECTIONCACHE_KB889386 bajo la clave que se enumera en el paso 4.
  6. Seleccione el FEATURE_REDIRECT_COLLECTIONCACHE_KB889386
    clave.
  7. En el menú Edición , elija
    De nuevoy, a continuación, haga clic en valor DWORD.
  8. Escriba iexplore.exey, a continuación, presione ENTRAR.
  9. Haga clic en iexplore.exey, a continuación, haga clic en
    Modificar.
  10. En el cuadro información del valor , escriba
    00000001y, a continuación, haga clic en Aceptar.
  11. En el menú archivo , haga clic en
    Salir.

Referencias

Para obtener más información sobre almacenamiento en caché de objetos de Internet Explorer, visite el siguiente sitio Web de Microsoft:
Propiedades

Id. de artículo: 889386 - Última revisión: 17 ene. 2017 - Revisión: 1

Comentarios